LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-05-2008, 12:59 PM   #1
edwardtomney
LQ Newbie
 
Registered: Oct 2008
Location: Northern California
Distribution: Currently Ubuntu
Posts: 4

Rep: Reputation: Disabled
Monitor Mode on wlan0


Hello,

My problem is on a DELL Inspiron 2200. I am not sure how to identify what wireless chipset is. I am trying to get the wireless card to get into monitoring mode, so that I can play with aircrack-ng on my home network.

I would also be interested in other peoples opinions of this application.

Output from trying to run airodump
/$ sudo airodump-ng wlan0

ioctl(SIOCSIWMODE) failed: Device or resource busy
Error setting monitor mode on wlan0

Output from iwconfig

wlan0 IEEE 802.11g ESSID:"REMOVED ESSID"
Mode:Managed Frequency:2.462 GHz Access Point: 00:18:4D:DA:55:7A
Bit Rate=1 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Link Quality=65/100 Signal level=0 dBm Noise level=-45 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Output from iwconfig wlan0 mode monitor
/$ iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Operation not permitted.

Output of iwpriv wlan0 (not sure what this means)
/$ iwpriv wlan0
wlan0 no private ioctls.

I am a linux newbie, so I appologize if I haven't provided you with all the needed information.

Last edited by edwardtomney; 10-05-2008 at 01:10 PM. Reason: Needed to disable smilies and found more information
 
Old 10-05-2008, 02:17 PM   #2
klearview
Member
 
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Rep: Reputation: 75
First, disable network manager (i.e. you can just right-click on nm-applet and un-tick enable networking).

Then (you need root privileges for this):

sudo iwconfig wlan0 mode Monitor

Then:

sudo airodump-ng wlan0
 
Old 10-06-2008, 12:30 AM   #3
edwardtomney
LQ Newbie
 
Registered: Oct 2008
Location: Northern California
Distribution: Currently Ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you

Hello,

Thank you! That was easy. For anyone else having this problem, after you disable networking, give it a few moments to finish that process, before you try the above mentioned steps.

I was wondering, is there a way to disable the networking like you had me do from the command line?

Again, thank you very much !!!
 
  


Reply

Tags
inspiron, mode, set


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does monitor go out of sync in text mode but work ok in graphics mode? tjsgifan Linux - Hardware 6 09-27-2007 08:42 AM
Wlan0 failing master mode Geneset Linux - Wireless Networking 5 09-18-2007 11:48 AM
iwconfig mode monitor Error: "Set Mode" (8B06) WOP1337 Linux - Wireless Networking 2 04-03-2007 08:13 AM
Can't `iwconfig wlan0 mode master` michaelsanford Linux - Wireless Networking 3 05-05-2005 09:24 PM
Broadcom wireless with ndiswrapper: ifconfig wlan0 works; ifup wlan0 fails orangechicken Linux - Wireless Networking 2 04-17-2004 05:39 PM


All times are GMT -5. The time now is 09:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration