LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2004, 08:32 AM   #1
jhazzy
LQ Newbie
 
Registered: Aug 2004
Posts: 15

Rep: Reputation: 0
Monitor Flickers too much...plz help...!!


Hi,

I am very new to Linux. I have Red Hat 9 installed on my Compaq Presario 7500(SR1130IL) machine.

My monitor flickers so much that I can't look at it continuously for more than 5 minutes.

XF86Config gave me the following info. Could anyone plz help me with what all modifications do I need to do here.

Changing the display color from million to 256 has helpmed me abit.

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "COMPAQ 7500"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 140.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 845"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 8
SubSection "Display"
Depth 24
Modes "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1400x1050" "1280x1024" "1280x960" "1152x864"
"1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Thanks and Regards,
Manish.
 
Old 08-14-2004, 03:08 PM   #2
belga
LQ Newbie
 
Registered: Jul 2004
Location: Montreal, Canada
Distribution: Kubuntu Breezy
Posts: 16

Rep: Reputation: 0
Try adjusting the Horizontal/Vertical Refresh rate in the XF86Config-4 file, I think the second one is way too high.

Quote:
Section "Monitor"
...
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 140.0

...
It worked fine for me with Horiz = 30.0 - 82.0, Vert = 50 - 75 for a Viewsonic VE175b (LCD 17"), check your documentation!

Good luck!

Last edited by belga; 08-14-2004 at 07:24 PM.
 
Old 08-14-2004, 07:07 PM   #3
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
yes u can need to change ur vertical freq

also try using thousands of colors(16 bit)

have u degaused ur monitor

regards
gaurav
 
Old 08-16-2004, 05:34 AM   #4
jhazzy
LQ Newbie
 
Registered: Aug 2004
Posts: 15

Original Poster
Rep: Reputation: 0
Hi,

Thanks for your reply.

I Checked the documents of my monitor(Compaq 7500). It mentions the Hor. frequency as 30~70 and Ver. Frequency as 50-140(my present settings).

I also went to system settings->Display-> Monitro->setting->Probe Monitor. Above mentioned values for hor. and ver. frequency appear.

Video Card is Intel 845 and Driver is i810.

Flickering is worse when I have Colors as Million and thousand, it's relatively better in 256 colors.

I had instlled Turbolinux( For Compaq only) before installing Red Hat 9 and resolution was perfect then.

Same monitor works correctly in Windows environment.

Gaurav, I don't know how to degauss monitor. Also how would it help..??

Regards,
 
Old 08-16-2004, 05:39 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,957

Rep: Reputation: Disabled
I don't know, whether this is pertinent to your problem. I had something similar some time back and raised the lower value like
Code:
VertRefresh 80.0 - 140.0
Perhaps you ought to try it in steps of 10 hz so as not to damage your equipment (Videocard). I never understood, why XFree doesn't allow the choice of a preferred vertical refresh rate...
 
Old 08-16-2004, 10:24 AM   #6
Marc A
Member
 
Registered: Mar 2004
Location: Bxl Europe
Distribution: Debian/Ubuntu
Posts: 84

Rep: Reputation: 15
Hi,

If you can find your old XF86Config-4 file (under turbolinux) you could use it instead of the current one. Otherwise you can use Knoopix. Sart it to simulate your environement mount your RH partition, change read/write and su to copy the XF86Config-4 over the current one. I've done that sometime ago having problems with my lcd screen.

Hope this helps,
 
Old 08-16-2004, 10:35 AM   #7
jhazzy
LQ Newbie
 
Registered: Aug 2004
Posts: 15

Original Poster
Rep: Reputation: 0
Thumbs up

Hi Everyone,

I unfortunately formatted Turbolinux before Installing Red Hat.

As suggested by JZL240I-U, I increased my Vertical Frequency range to 80~140 instead of 50~140.

It has definitely helped me and the flickering has gone to a large extent though it's still not as good as I would have liked it to be.

I would however try with Knoppix as it could be booted from CD.

Thanks once again for all your help.

Regards,
Manish.
 
Old 08-16-2004, 10:41 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,957

Rep: Reputation: Disabled
Well, if it is not enough, raise the lower threshold to 90 hz or 100 hz. Some cards may not accept all values and then default to the next valid lower refresh rate, thus effectively not giving you the 80 hz you wanted. Depending from your display you possibly can find out the lastly used refresh rate in its hardware setup panel.
 
Old 08-16-2004, 10:58 AM   #9
jhazzy
LQ Newbie
 
Registered: Aug 2004
Posts: 15

Original Poster
Rep: Reputation: 0
I too tried doing that. But when I set the lower vertical frequency to 90, graphical screen doesn't appear at all and only text mode becomes available.

So then again I have to roll back the settings to 80 and then after restarting the machine, I could log in graphical mode.

But it accepts 80 as I checked the value in XF86Config file after loggin in.

Could anything else possibly be done here..??

Thanks,
Manish.
 
Old 08-16-2004, 11:07 AM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,957

Rep: Reputation: Disabled
Get the specification of your video card -- alternatively increase the refresh by reduced steps (82 - 84 - 86 ...). What I meant in my previous post was to check the monitor (that thingy with the coloured pictures in front of you ). It usually has a firmware-"coded" popup menu which in some cases shows the real value of the refresh rate...
 
Old 08-16-2004, 11:34 AM   #11
jhazzy
LQ Newbie
 
Registered: Aug 2004
Posts: 15

Original Poster
Rep: Reputation: 0
You are right..!!

Monitor shows vertical frequency as 60 Hz and Horizotal fre. as 48.3 KHz.

I will do hit and trial by changing the frequencies gradually as you suggested.

I could find only the following info about my video card from Hardware Browser or from display setting:-

82845G/GL[Brookdate-G] Chipset Integrated Graphics Device

Manufacturer:- Intel corp

Driver card :- Intel 845

Did you mean this..??

Rgds,
 
Old 08-16-2004, 02:42 PM   #12
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there
degauss is one of the functions of the monitor which u can acess from the menu function of the monitor,
this sometimes helps but in your case as u said it is working fine in windows so that might not help u

also i have heard that compaq does not test its hardware for redhat ot mandrake and many other LINUX so this is troubling u more

regards
gaurav
 
Old 08-17-2004, 02:54 AM   #13
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,957

Rep: Reputation: Disabled
Yeah exactly. Now go to the intel site and search them for drivers, 60 hz is some default from times long gone (U.S. tv frequency ). Brookdale definitely should be able to dish out more than 60 hz.

As an aside take some patience and search this site. With the appropriate combination of keywords you will very probably find a solution in more than a million posts recorded here...
 
Old 08-17-2004, 09:37 AM   #14
jhazzy
LQ Newbie
 
Registered: Aug 2004
Posts: 15

Original Poster
Rep: Reputation: 0
Perfect..!!! I had to scout around a lot but finally I have been able to do it..!!

I went to http://support.intel.com/support/gra...-010512.htm#5, followed the instruction, downloaded the drive and installed it and believe me my screen looks so good...!!!

My monitor has automatically started showing hor. frequency as 70 and vertical as 87.

Thanks for saving my eye.

Thanks to all of you who responded to my comment.

Regards,
Manish.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor flickers when installing Suse 9.3 mayacons SUSE / openSUSE 3 07-22-2005 07:44 AM
monitor flickers on IntelD865GLC with RedHat 9.0 jkmin Linux - Hardware 0 11-01-2004 12:26 PM
plz help: monitor turns off Pacemaker Linux - Newbie 10 04-07-2004 07:11 PM
monitor me plz!!!! navid Linux - Newbie 2 03-03-2004 08:04 AM
Monitor flickers at random times linuxbotx Linux - Hardware 7 10-31-2003 12:21 AM


All times are GMT -5. The time now is 10:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration