LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2002, 07:12 PM   #1
Kuman_Nakal
LQ Newbie
 
Registered: Apr 2002
Posts: 3

Rep: Reputation: 0
Question Modules not detected in slackware


Hi..
I installed slackware 8.0 like two days ago.
i'm aware that the kernel is 2.2, so that i want to upgrade it to 2.4.18. I download the kernel from www.kernel.org
this is what i did:
cd linux
make mrproper
make menuconfig
make dep
make bzImage
make modules
make modules_install
cp linux/arch/i386/boot/ bzImage /vmlinuz-2.4.18
cp linux/System.map /boot/System.map
edit lilo.conf
lilo
reboot

i am able to boot using the new kernel. the problem is all the modules is not detected. At first, i though that i should edit the etc/modules.conf.

alias net-pf-4 off
alias net-pf-5 off

(original)

But later on i realized that the module is loaded on the startup with the error msg " modules is not located.
Then i tried to lsmod. No modules showed up.
When i tried to modprobe all the modules... it says modules not located...
Now i'm confused because i still can boot up to my old kernel and everything works just fine+xwindow is up.

Pls help me to set up my new kernel....

Thanks
 
Old 04-26-2002, 08:13 PM   #2
ph34r3d
Member
 
Registered: Apr 2002
Location: Tamaqua, Pa
Distribution: Slackware. Gentoo 1.4rc3, RH9, Mandrake 9.1, Debian, FreeBSD, OpenBSD, Fedra Core 3 x86_64
Posts: 71

Rep: Reputation: 15
You did compile the new kernel in /usr/src/linux correct?

Make sure you compiled it in there, then run "make distclean"
then recompile everything, and remake all the dep


I always just do:


make menuconfig
make dep
make modules
make modules_install
make clean
make bzlilo; make bzImage

when I reboot, everything works fine...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop LCD not detected properly on Slackware 10.1 linumax Slackware 5 06-11-2005 12:55 PM
CDROM is not being detected by Slackware calvin_the_bols Slackware - Installation 2 05-14-2005 05:55 PM
PCI soundcard not detected (emu10k1, linux 2.6.9, slackware) Ben2210 Linux - Hardware 0 11-06-2004 01:36 PM
CRD-8160B not detected by Slackware deGrasse Linux - Hardware 5 10-06-2004 01:59 PM
No modules detected in installation ar1 Linux - Newbie 1 11-30-2003 08:38 PM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration