LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2003, 04:38 AM   #1
Beuzekom
Member
 
Registered: Aug 2003
Location: Netherlands
Distribution: Redhat 9.0
Posts: 38

Rep: Reputation: 15
modules load


Hi,

How can I make a module load automatically in RH9.0 - using some software in which I have (at every restart) to reload it (modprobe command)

Thanks
Jamie
 
Old 08-22-2003, 06:02 PM   #2
BigBadPenguin
Member
 
Registered: Jun 2003
Location: Warwick (.ac.uk)
Distribution: Arch, Slackware 9.0, (knoppix standing by)
Posts: 256

Rep: Reputation: 30
I hope its the same on redhat, have you got a file /etc/rc.d/rc.modules ? If so add the modprobe commands in there and it will be done automatically. Its safest to do the full path to modprobe e.g. "/sbin/modprobe emu10k1 " but if this is the right file in redhat there should already be some lines for you to base yours on.
 
Old 08-22-2003, 06:25 PM   #3
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I'm on RedHat 9.0 now here. There's no /etc/rd.d/rc.modules in my box. (when will RedHat stop breaking compatibility with odd paths huh?) but there's in my Slackware box. Anyway, I have my joypad module (modprobe joydev) located at:

/etc/rc.d/rc.local

Try adding your module in there
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe: FATAL: Could not load /lib/modules/.../modules.dep Ankardo Debian 9 02-01-2011 06:09 PM
modules won't load huntz Slackware 2 10-03-2004 11:37 PM
FATAL: could not load /lib/modules/2.6.1/modules.dep Fr33B33R Slackware 3 01-12-2004 06:40 AM
modules.conf - Cannot get modules to load automatically gundelgauk Linux - General 1 12-28-2003 12:27 AM
Load Modules Before X Parksy Linux - Software 13 08-05-2003 09:58 PM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration