LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-15-2012, 03:25 PM   #1
frumpus
Member
 
Registered: Feb 2010
Posts: 38

Rep: Reputation: 0
modprobe command not found


I can't seem to access the modprobe command. 'man modprobe' works fine and the documentation is there, but when I try to use the modprobe command (even with 'sudo') the command is not found. Do I have to be in a particular directory or am I doing something else wrong?

This is RedHat 5.

Any suggestions would be appreciated. Thanks!
 
Old 02-15-2012, 03:33 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,656

Rep: Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233
This a bit surprising - to my eyes at all.

You should be root to run modrobe, so type 'su -' first.

Then try to locate the modprobe commmand with 'which modprobe' (here it return /sbin/modprobe but it could be elsewhere for RedHat).

Once you'll have finded the location, use the full path of the command to launch it, e.g. '/sbin/modprobe', just in case the location wouldn't be in $PATH.

Last resort, if you really think you don't have that command, run (as root) 'updatedb' (takes a while), then 'locate modprobe' to check

Last edited by Didier Spaier; 02-15-2012 at 03:35 PM.
 
Old 02-15-2012, 03:34 PM   #3
edgardl
LQ Newbie
 
Registered: Feb 2012
Location: Mexico
Distribution: Debian
Posts: 9

Rep: Reputation: Disabled
Hello, you could try to see where the command is, for example I obtained this

Code:
# which modprobe
# /sbin/modprobe
another way would be

Code:
# find / -name modprobe
probably you need to modify your $PATH
 
Old 02-15-2012, 03:41 PM   #4
frumpus
Member
 
Registered: Feb 2010
Posts: 38

Original Poster
Rep: Reputation: 0
Interesting. Running 'which modprobe' as root returns:

which: no modprobe in (/usr/bin:/bin)

I did find modprobe in /sbin though, that just doesn't seem to be in the path.

That's one problem solved. Thanks a bunch!
 
Old 02-15-2012, 03:52 PM   #5
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Quote:
Originally Posted by frumpus View Post
Interesting. Running 'which modprobe' as root returns:

which: no modprobe in (/usr/bin:/bin)

I did find modprobe in /sbin though, that just doesn't seem to be in the path.
How did you switch to root? If using
Code:
su
alone, the current user's environment is preserved and the PATH environment variable is not updated. Instead, using
Code:
su -
the actual root's environment is set, since it acts as a login shell.
 
Old 02-15-2012, 03:55 PM   #6
frumpus
Member
 
Registered: Feb 2010
Posts: 38

Original Poster
Rep: Reputation: 0
When I try su - I am asked for the root password, which I do not have. I am in the sudoers file so I use 'sudo'. the '-' does not seem to work with sudo however.
 
Old 02-15-2012, 03:56 PM   #7
frumpus
Member
 
Registered: Feb 2010
Posts: 38

Original Poster
Rep: Reputation: 0
I was really hoping modprobe would solve my tape drive problem but no joy. Guess I get to start a new thread.
 
Old 02-15-2012, 04:49 PM   #8
theW
Member
 
Registered: Jul 2011
Distribution: arch, vector, mint
Posts: 37

Rep: Reputation: Disabled
If you are in the wheel group and the sudoers file than you do have permission to do this. The problem however is than sbin is not in your path. You can execute it anyway by doing something like
Code:
sudo exec /usr/sbin/modprobe
That should work for you.
 
Old 02-15-2012, 05:25 PM   #9
John VV
Guru
 
Registered: Aug 2005
Posts: 13,463

Rep: Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800
Quote:
When I try su - I am asked for the root password, which I do not have
with out root access you do not
have your system administrator do it

also rhel DOSE NOT i repeat DOSE NOT !!! use "sudo" ( never did ) that us a mostly Debian / Ubuntu command

now sudo CAN be set up and often is but it is NOT set up by default
 
  


Reply

Tags
modprobe


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe: command not found sutley Linux - Newbie 3 07-29-2005 06:39 PM
modprobe: command not found tombaaaaa Linux - Newbie 7 07-23-2004 06:46 PM
Modprobe command not found DoThatPlan Linux - Software 2 07-14-2004 09:21 AM
'modprobe' command not found DeltaXFX Fedora 5 07-09-2004 03:31 PM
modprobe: command not found....? Tommi Linux - Newbie 3 06-27-2003 07:54 AM


All times are GMT -5. The time now is 07:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration