LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-17-2004, 05:44 PM   #1
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Rep: Reputation: 16
modprobe


I've installed the linux-wlan-ng driver and everything went fine. I've also configured the wlan.conf and wlancfg-<ssid> files just like it told me. The problem i get is when i try running the command "modprobe prism2_pci" like it tells me. When i do, i get this message...

[root@linux jared]# modprobe prism2_pci
/lib/modules/2.4.22-10mdk/kernel/drivers/pcmcia/ds.o.gz: init_module: Operation not permitted
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.22-10mdk/kernel/drivers/pcmcia/ds.o.gz failed

Seems to me like it should be looking in /etc/wlan/ and not /lib/modules/... I looked in the control center and it is seeing the prism 2.5 wavelan chipset, however the module it is using is orinoco_pci. I did an lsmod and didn't see orinoco_pci listed. How can i get this card loaded?
 
Old 02-17-2004, 07:02 PM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
Look in your dmesg and see if the system initialized your card with the orinoco_pci driver. It could be it won't let the init_module work because the card is bound already. Just out of curiousity, what card is it?
 
Old 02-17-2004, 10:30 PM   #3
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Original Poster
Rep: Reputation: 16
The card is a Dlink DWL-520. The output from the dmesg command was looong. I didn't see anything about the orinoco driver though. I did a find for orinoco_pci and it didn't find anything.
 
Old 02-17-2004, 10:31 PM   #4
rhraz
Member
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 80

Original Poster
Rep: Reputation: 16
Also, there was a couple of entries about IRQ conflicts, not sure if that might have anything to do with it. If you'd like me to post the whole thing i can. I warn you though, it's long
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to load module "ndiswrapper" with modprobe; modprobe ndiswrapper doesn't work! Benjamin Linux - Wireless Networking 30 05-25-2008 08:04 AM
Making modprobe pcspkr stick with modprobe.preload? gm4jjj Fedora 3 06-16-2004 04:27 AM
Modprobe !! AZIMBD03 Red Hat 0 05-27-2004 05:12 PM
modprobe: modprobe: Couldn't locate module nvnet.o/nvaudio.o xiojqwnko Linux - Newbie 2 12-08-2003 06:41 PM
modprobe: modprobe can't locate module ppp0 in redhat 7.1 while shutting down. cyberdude3k Linux - Networking 1 09-08-2003 01:01 PM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration