LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2014, 09:20 AM   #1
casperdaghost
Member
 
Registered: Aug 2009
Posts: 349

Rep: Reputation: 16
modify power / sleep setting via command line Fedora 20


Everytime I close the lid to the laptop it goes into suspend mode and kills my ssh connection - it is kind of driving me nuts.
I need to adjust the settings via command line - so i downloaded
the dconfig editor - but it is not really working.

is there a way to modify the laptop settings from the command line so it does not go into suspend mode and kill my ssh connection.

Code:
sudo yum install -y dconf-editor
Code:
[FEDORA_CASPER@new-host-3 ~]$ gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action blank
No such key 'lid-close-battery-action'
[FEDORA_CASPER@new-host-3 ~]$
 
Old 05-25-2014, 02:16 AM   #2
GaWdLy
Member
 
Registered: Feb 2013
Location: San Jose, CA
Distribution: RHEL/CentOS/Fedora
Posts: 457

Rep: Reputation: Disabled
Well, the error is pretty clear. The key doesn't exist.

Have you tried looking through the schemas or keys to see where the issue is?

gsettings list-keys
gsettings list-schema
Gsettings list-recursively | grep whatever

http://manpages.ubuntu.com/manpages/...ettings.1.html
 
Old 05-25-2014, 08:01 PM   #3
casperdaghost
Member
 
Registered: Aug 2009
Posts: 349

Original Poster
Rep: Reputation: 16
The error is clear - but the reason why is not.
For some reason the gnome editor no longer has this lid setting in Fedora 20.

I edited /etc/systemd/logind.conf,
uncommented HandleLidSwitch,
and changed its value to ignore.

gave it the old ...
Code:
[FEDORA_CASPER@new-host-3 ~]$ sudo systemctl restart systemd-logind.service
[sudo] password for FEDORA_CASPER:
[FEDORA_CASPER@new-host-3 ~]$
...... works fine

Check out the manpages logind.conf for more options.

I suppose i could have used the gsettings gui, but i am too lazy.

Last edited by casperdaghost; 05-25-2014 at 08:13 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop power setting issue - laptop won't sleep on critical bettery __spc__ Linux - Laptop and Netbook 1 09-17-2013 02:21 PM
Redhat 4.8 Command Line Sleep/Standby Question ghost_1on Red Hat 3 09-07-2012 04:25 AM
Monitor Power setting in Command Line Joseph Matthews Linux - Laptop and Netbook 0 08-01-2010 11:25 AM
LXer: Power your command line with Terminator LXer Syndicated Linux News 0 03-16-2008 02:40 PM
command line counter tool to replace "sleep" kutlu Linux - Software 3 12-25-2007 11:42 PM


All times are GMT -5. The time now is 04:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration