LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2003, 03:41 PM   #1
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Rep: Reputation: 0
modem und RH9 is driving me crazy


So, I thought I had the modem configure (after all, yesterday I was proudly surfing the web from within my RedHat 9 installation). And now that I have rebooted my machine the wvdial.conf seems to be correctly configured. But I can only get it to connect as root. And even so I cannot get the browser to find that connection. So now I am surfing from Win98 again
I have seen in another thread that I might have to change the routing or something but I did not quite understand that.

So how, when and where do I have to make adjustments? I don't like it when my successes keep being only temporary solutions.
 
Old 08-01-2003, 04:01 PM   #2
JanRigter
LQ Newbie
 
Registered: Jul 2003
Location: Netherlands
Distribution: SuSE/Debian
Posts: 26

Rep: Reputation: 15
Hi pal_o_matic,

It is easy to let a user use wvdial.
Here's what you do:

$ su
<password>
# visudo (this is the command you must use to edit the file sudoers to allow users to have access to root privileges, see manpages for details and examples)

In this file there is a section calles user privilege specification
add the line:
username ALL = NOPASSWD: /usr/bin/wvdial, /usr/bin/pppd root, /usr/bin/skill -c wvdial

This will allow the user to dial in, have a deamon running and kill it at the end of session. All you have to do is issue the command wvdial to start up and skill -c wvdial to shut down at the end.
I use the Enlightenment window manager and I have two entries in my user menu, each with a nice icon for it. They have these command calls behind them. Works great.

I'm not sure about your description about the browser not finding the connection. I'm not a RH user myself. I'll leave that to a wiser head than mine.

Viel glueck!

Jan
 
Old 08-02-2003, 07:10 AM   #3
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Original Poster
Rep: Reputation: 0
Uh-uh ... no good. The problem is not that I cannot run wvdial. It just keeps telling me that the "device or resource" was "busy". And I am very sure that the modem was not used at that point of time.
But that only happens when I am running wvdial as a user. As root it dials nicely and noisily. But still. Once it is done dialing the last thing I see on the screen is a message stating that wvdial just sent pppd and the it goes into waiting.
I took it that it meant now I am connected to the ISP. But I am not able to use the WWW.

Maybe I should also describe how I got connected the first - and only - time I managed to. Because after that the wvdial configuration file was filled out nicely.
Somewhere in the system tools menu I found the internet connection wizard. There I could very easily enter the connection info which I later found within wvdial.conf. At the end of the wizard I had the option to activate the new connection and upon doing so the modem started dialing and I was hooked up. However when running that wizard now I am prompted to create a new connection which means that I would end up with thousands of connections if I kept doing so. Moreover I need root rights to run that (though that I might be able to take care of with the visudo).

Maybe I can somewhere find the configuration of that wizard and see what it did in the end to hook me up? ... I don't know. Windows is starting to get on my nerves again. But not being able to configure Linux is rather annoying, too.
 
Old 08-02-2003, 10:41 AM   #4
captainstorm
Member
 
Registered: Jun 2003
Location: Oricola, Italy
Distribution: RH 9, so far
Posts: 261

Rep: Reputation: 30
"device or resource" was "busy".

This problem appears to be that driver module not installed properly, or, you did not choose the right device name.

If you have problem using vidial, try the command "kppp". This is a very good dial up program, so far as I know.

This is a user friendly program. If you have installed properly the driver for the modem, the device should be /dev/modem. Try the "modem query" in it. If you see "modem is ready", then everything is OK.

There are several articles about how to use kppp, just search on the google. Or, I could send you some at your e-mail.
 
Old 08-02-2003, 12:04 PM   #5
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Original Poster
Rep: Reputation: 0
Well I had tried kppp before I started fuzzing around with wvdial and that internet wizard. I have found out that the wizard is some kind of front end for the network configuration. But when starting that I do get my configured ISPs but for some insane reason my modem won't respond to them any more.

OK, back to kppp it is then.

This is the program which bugged me by hanging up the modem right after establishing the connection. Kind of "I came, I saw, I hung up".

Let's see what google has to say about that.

Little anecdote on the side: My Mozilla won't start any more either. At least not in the current session, but even now it should not be doing that. So right now I am using Konqueror. And here I thought it was Windows who gives us the unexplainable nonsense ... yes, I am officially annoyed now.
 
Old 08-03-2003, 05:32 AM   #6
tomp_tag
LQ Newbie
 
Registered: Apr 2003
Location: Chicago
Distribution: BDI-EMC, RH7.2
Posts: 7

Rep: Reputation: 0
pal_o_matic,
I have a similar problem. I think you may need to look at what happens right between 'i saw-i hungup'. I've gotten just barely past that and am into 'i dialed up- i connected- i stayed on forever and couldnt surf at all'.
The wvdial (not to open old wounds) does have a terminal that can show you the negotiations that happen when you log on. Hopefully you're just getting booted due to some typo in your id or password. That'd be easy to fix.
Roundabout ways to check... take your config info to another machine that connects and surfs ok, try it there. Or trap a 'log' of what happens when booted off and post it here.
regards, tomp
 
Old 08-03-2003, 06:09 AM   #7
pal_o_matic
LQ Newbie
 
Registered: Jul 2003
Location: Hannover, Germany
Distribution: RedHat 9.A
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by tomp_tag
pal_o_matic,
I have a similar problem. I think you may need to look at what happens right between 'i saw-i hungup'. I've gotten just barely past that and am into 'i dialed up- i connected- i stayed on forever and couldnt surf at all'.
Well, by now I have gotten to the same state. Actually it is the same situation as I have when I dial up via wvdial (but that only works as root ... as normal user it's still "device or resource busy".)

Using the network device control menu works ... or rather kind of works. But for that I also need root rights and it is a more complicated solution than I was hoping for.

Quote:

Or trap a 'log' of what happens when booted off and post it here.
regards, tomp
Do you mean the log of my linux boot or from wvdial? For the latter ... how do I do that?
 
Old 08-03-2003, 08:45 AM   #8
Disruptor
LQ Newbie
 
Registered: Jul 2003
Location: Hellas - Crete - Heraklion
Distribution: Red Hat 9
Posts: 24

Rep: Reputation: 15
Hi guys! Just like to say a few words about kppp: If you see it "freezing" upon
"waiting OK" (or something like that if I can recall correctly), there is a tricky
solution you can apply. In the configuration tabs of kppp there are some time
switches: turn them all to minimum. Run kppp using this configuration. It
should throw log messages saying: "shell-script timed-out!" (or something). Let
it repeat this messages for 3-4 times then cancel the process. Then rise the time
switches to "reasonable" values and run kppp again. Wait for about 1 minute
(yes it's slow) and you should connect. If you don't e-mail and I'll tell what to
do. And something else: If you are using RedHat make sure that either you don't
have a firewall running or if you do have a firewall make sure that you allow
incoming packets from the www and e.t.c. Also note that once you disable
the firewall, you also need to make changes take affect: the easy way to do it
is to reboot.

Cheers,
Dominique
 
Old 08-03-2003, 03:10 PM   #9
JanRigter
LQ Newbie
 
Registered: Jul 2003
Location: Netherlands
Distribution: SuSE/Debian
Posts: 26

Rep: Reputation: 15
Hi people,

Thought I'd join the hunt...
I managed to find this page:
http://www.madisonlinux.org/pipermai...st/000996.html
A guy has a similar problem. Can only run kppp as root.
There is an answer plus a link to the place where he got it from.
See previous posts in thread also.

You could try that one...

Cheers,
Jan
 
Old 08-03-2003, 05:09 PM   #10
Disruptor
LQ Newbie
 
Registered: Jul 2003
Location: Hellas - Crete - Heraklion
Distribution: Red Hat 9
Posts: 24

Rep: Reputation: 15
Quote:
Originally posted by JanRigter
Hi people,

Thought I'd join the hunt...
I managed to find this page:
http://www.madisonlinux.org/pipermai...st/000996.html
A guy has a similar problem. Can only run kppp as root.
There is an answer plus a link to the place where he got it from.
See previous posts in thread also.

You could try that one...

Cheers,
Jan
Very interesting I must admit. Wish I knew about it when I was
trying to get ppp to work. Anyway better late than ever!

Cheers,
Dominique
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X11 driving me crazy.... trawler Linux - Newbie 3 10-11-2005 06:40 PM
[ ] @ are driving me crazy FireInTheDark Linux - Software 1 11-28-2004 10:42 AM
Sound driving me crazy eatstatic Slackware 7 11-21-2004 04:47 PM
Help this is driving me crazy!!!!!! Wolfy Linux - Hardware 1 07-07-2004 02:32 AM
ATi's driving me crazy... Hammett Linux - Software 0 04-21-2004 04:25 PM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration