LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2006, 11:03 PM   #1
Mithrilhall
Member
 
Registered: Feb 2002
Location: Massachusetts
Distribution: Debian (Lenny)
Posts: 286

Rep: Reputation: 30
Modem question


I just installed Asterisk@Home and I'm loving it.

The only problem that I've run into is my modem wasn't detected.

Under /dev there was no modem. I downloaded and installed the drivers for my modem (internal) and they installed successfully (or so it said). Now when I look under /dev and issue "ls -l" I see the modem as "modem -> ttySHSF0".

Is there anything else I need to do to get the modem working properly? Is there some way I can test the modem from the command line?

Please keep in mind that I'm a total n00b when it comes to Linux.
 
Old 03-24-2006, 02:19 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,641

Rep: Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539Reputation: 1539
You must make sure that the kernel module for your modem is loaded into the kernel:
Code:
lsmod
To test your modem you can use:
Code:
minicom
See the man pages of these programs for details
 
Old 03-24-2006, 10:33 AM   #3
Mithrilhall
Member
 
Registered: Feb 2002
Location: Massachusetts
Distribution: Debian (Lenny)
Posts: 286

Original Poster
Rep: Reputation: 30
Question

Ok...I ditched the internal modem for an external modem.

I had to delete /dev/modem and recreate the symbolic link to point to ttyS0 (modem -> /dev/ttyS0).

I used minicom and tested the modem and all seems to be working.

I fired up minicom and changed the settings to point to ttyS0 instead of ttyS1. This is the output I got:



Welcome to minicom 2.00.0

OPTIONS: History Buffer, F-key Macros, Search History Buffer, I18n
Compiled on Feb 21 2005, 19:32:30.

Press CTRL-A Z for help on special keys

AT S7=45 S0=0 L1 V1 X4 &c1 E1 Q0
OK




I typed AT and received an "OK".

So, my question is....does it look like this modem is working properly? Is there anything else I can do to test it out?


###################################################################
Ok...I know the modem is working now. Thanks for you help.

Last edited by Mithrilhall; 03-24-2006 at 10:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
modem question.... murrowman789 Slackware 11 06-28-2005 12:52 AM
Another modem question NNP Linux - Hardware 6 06-08-2005 06:28 PM
Question about a modem... ctbx Linux - Newbie 4 11-22-2004 11:16 PM
modem question brookes Mandriva 2 10-22-2003 06:24 PM
Modem Question goofymari Linux - Newbie 5 10-01-2001 03:57 AM


All times are GMT -5. The time now is 07:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration