LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2004, 08:31 PM   #1
brette
LQ Newbie
 
Registered: Oct 2004
Distribution: Fedora 2
Posts: 10

Rep: Reputation: 0
Modem Not Found


I am trying to install my external Maestro Jeststream Dual Voice modem.

When I select the configure internet then choose modem linux searches for attached modems. It then says none detected. It is contected to COM1 and turned on, also it works fine on win2k.

Am I doing something wrong? If so how am I to install my modem?

Any help would be greatley appreciated. Cheers.
 
Old 10-28-2004, 09:19 PM   #2
slide-rule
Member
 
Registered: Jan 2004
Location: New England area, US
Distribution: Mandrake 9.2
Posts: 39

Rep: Reputation: 15
Apologies if you've read this (you didn't mention) but google for "Modem-HOWTO" to get a general overview for manual config'ing various modem types. Annoying that modem auto-config is still rather spotty; seems like internal, pci-based, "real" modems fare best; external, serial-based varieties not so much, but at least this latter variety (yours) generally are more reliable to be made to work, as they have to be "real" modems.
 
Old 10-28-2004, 11:17 PM   #3
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
http://www.linmodems.org
go there and get and run scanmodem tool to find out what chipset you have and then get the appropritate driver.
 
Old 10-29-2004, 03:11 AM   #4
Dummy-in-Linux
Member
 
Registered: Jun 2004
Location: Bangkok, Thailand
Distribution: Fedora 25 86_64
Posts: 357

Rep: Reputation: 32
Hello Brette,

It is not that difficult to make your modem work with Fedora Core 2, you will find in the menu (Internet) that there is a program called “KPPP”.

If you start this program you get the usual (Connect to, Login ID and Password) but you first select “Configuration”.

Now you get Accounts, Device, Modem, Graph…You need to select “Device”

At modem device you select /dev/ttyS0 (COM1), then go to “Modem” and select “Modem Commands” and change the second Initialization string in +ms=v34,0 +ms=v90,0

The initialization string I give here is based on my know-how that Meastro is using a Lucent chipset.

Click OK OK and enter your internet provider information at the first screen….

Connect to Internet and tell us the good news.

With kind regards,

Richard

Or go and buy a ADSL modem…..http://adsl.yoll.net
 
Old 10-30-2004, 05:44 PM   #5
brette
LQ Newbie
 
Registered: Oct 2004
Distribution: Fedora 2
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks D-i-L,

I don't have KPPP (wasn't part of my install?). I'll look for a download and get back to you.
 
Old 10-31-2004, 07:52 AM   #6
Dummy-in-Linux
Member
 
Registered: Jun 2004
Location: Bangkok, Thailand
Distribution: Fedora 25 86_64
Posts: 357

Rep: Reputation: 32
Hello Brette,

If ou have the Fedora Core 2 CD's you can install it easy from CD.

Just go to "System Settings" and select "Add/Remove Applications" then select the "KDE desktop Environment" and select the "KDENetwork" option.

Insert the requested CD and you are ready to use KPPP (KPPP also works with Gnome)

With kind regards,

Richard
 
Old 10-31-2004, 08:16 AM   #7
Dummy-in-Linux
Member
 
Registered: Jun 2004
Location: Bangkok, Thailand
Distribution: Fedora 25 86_64
Posts: 357

Rep: Reputation: 32
Hello Brette,

I just remember that you can also make your modem work without KPPP.

Go to "System Settings" select "Network" when the Network Configuration opens, you click on "New" and select "Modem Connection" click "Forward"

You probably get the message "Modem not found" that is no problem. If your modem is connected on Serial port 1, you select /dev/ttyS0 click "forward".

Select your ISP or give your own ISP information and click "forward"

Now your modem is probably already working, but to finetune your settings you open "Network Configuration" again and select your modem and click on "edit".

Go to "Advanced" and change the modem initialization string to the one I give in a previous posting.

Now you can connect to your provider by "Active" the modem or disconnect by "Deactive" your modem

With kind regards,

Richard

P.S. Sorry for my bad English languages skills, but hope you understand it....

Last edited by Dummy-in-Linux; 10-31-2004 at 08:19 AM.
 
Old 10-31-2004, 10:26 PM   #8
brette
LQ Newbie
 
Registered: Oct 2004
Distribution: Fedora 2
Posts: 10

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks man!

These instructions look pretty straight forward even for a linux numpty like me.

I'll let you know how it goes tomorrow when I get the chance to try it out.
 
Old 11-01-2004, 09:19 PM   #9
brette
LQ Newbie
 
Registered: Oct 2004
Distribution: Fedora 2
Posts: 10

Original Poster
Rep: Reputation: 0
No luck.

I couldn't find kde network and I couldn't work out where to typ "/dev/ttyS0".
 
Old 11-04-2004, 02:43 PM   #10
brette
LQ Newbie
 
Registered: Oct 2004
Distribution: Fedora 2
Posts: 10

Original Poster
Rep: Reputation: 0
Finally figured it out...

When I first tried to install the modem it did a search and showed "/dev/ttyS0 (COM1)". All the times since it didn't do a search. But I figured out where to change the string and deleted the "(COM1)" so it now reads "/dev/ttyS0" and it worked.

Now I just gotta figure out how to connect to my ISP. I'm using the same settings as Windows with everthing set on automatically select IP and DNS but it keeps saying "resolving with {ISP}" (in mozilla) when I think it should be saying "loading {page}". After about 30 seconds it throws an error (which I cannot remember ATM).

Last edited by brette; 11-04-2004 at 02:44 PM.
 
Old 11-04-2004, 05:46 PM   #11
Dummy-in-Linux
Member
 
Registered: Jun 2004
Location: Bangkok, Thailand
Distribution: Fedora 25 86_64
Posts: 357

Rep: Reputation: 32
Hello Brette,

I not know which version of Mozilla you use, but the newer versions support IPv6 most ISP's don support this yet.

To turn IPv6 off you can edit the /etc/modprobe.conf file

type gedit /etc/modprober.conf (in Terminal)

Add the lines below to the file and save it.

#Turn off IPv6
alias net-pf-10 off
alias ipv6 off

This will turn off IPv6 and you only will use the today standard IPv4.

With kind regards,

Richard
 
Old 11-04-2004, 09:03 PM   #12
brette
LQ Newbie
 
Registered: Oct 2004
Distribution: Fedora 2
Posts: 10

Original Poster
Rep: Reputation: 0
Smile

Thanks, I'll give it a go tonight.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
modem not found espn89 Linux - Newbie 11 05-09-2005 07:44 PM
Modem not found jkassemi Linux - Hardware 5 05-21-2004 09:19 AM
Where can I found Modem Driver? adil_haroon Linux - Hardware 1 05-08-2004 12:24 PM
No modem found in RH 8.0 - why? tatham Linux - General 3 05-29-2003 11:20 PM
Modem - No device found karthik_77 Linux - Hardware 3 03-31-2002 01:17 PM


All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration