LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2003, 01:06 PM   #1
virgin
Member
 
Registered: Jun 2003
Location: Pgh, PA
Distribution: debian
Posts: 50

Rep: Reputation: 15
/mnt/fat32 stopped working


so everything was fine with my dual boot fat32 partition mount and then yesterday I remove my user account and make a new one and
today I wake up and I don't have write permissions.

chmod commands are not permitted, and my fstab looks the same as it always did,
although I did change it a little researching this question on LQ.

less /ect/fstab ===
...
/dev/hdb5 /mnt/door vfat users,uid=500,gid=500,umask=002,rw,auto, 0 0

I think I added umask bit today in a failed attempt.

here's the ls -l
[agdedc@localhost mnt]$ ls -l
total 24
drwxr-xr-x 2 root root 4096 Jun 13 22:35 cdrom
drwxr-xr-x 2 root root 4096 Jun 13 22:35 cdrom1
drwxrwxr-x 8 500 500 12288 Dec 31 1969 door
drwxr-xr-x 2 root root 4096 Jun 13 22:35 floppy

(door is the name of my fat32...)
what is the story with that dec 31st stuff????

do I need to scrap this thing and start over?

any ideas?
 
Old 07-06-2003, 02:00 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
That looks odd - try deleting that folder and recreating it as root.
 
Old 07-06-2003, 03:38 PM   #3
virgin
Member
 
Registered: Jun 2003
Location: Pgh, PA
Distribution: debian
Posts: 50

Original Poster
Rep: Reputation: 15
thanks-- that is what I'll do.

just to be sure, if I rm -rf /mnt/door, and then make a new directory,
mkdir /mnt/door,
and restart, that line in the fstab,

/dev/hdb5 /mnt/door vfat users,uid=500,gid=500,umask=002,rw,auto, 0 0

should do the trick right???
or is there something else I should do ?
 
Old 07-06-2003, 03:42 PM   #4
virgin
Member
 
Registered: Jun 2003
Location: Pgh, PA
Distribution: debian
Posts: 50

Original Poster
Rep: Reputation: 15
oh s#!^

look at this!

[root@localhost mnt]# rm -rf door
rm: cannot remove directory `door': Device or resource busy

boy that doesn't look good to me!
 
Old 07-06-2003, 03:57 PM   #5
virgin
Member
 
Registered: Jun 2003
Location: Pgh, PA
Distribution: debian
Posts: 50

Original Poster
Rep: Reputation: 15
hey I am sorry for being so nervous,with that last post... maybe it was because it was mounted,

so I make a new directory, /mnt/hall and change my fstab.
and restart, and i get the same thing.
try to save a little emacs script in there and I get the warning that it is write protected.

[root@localhost mnt]# ls -l
total 24
drwxr-xr-x 2 root root 4096 Jun 13 22:35 cdrom
drwxr-xr-x 2 root root 4096 Jun 13 22:35 cdrom1
drwxr-xr-x 2 root root 4096 Jun 13 22:35 floppy
drwxrwxr-x 3 500 500 12288 Dec 31 1969 hall

this has me stumped.
my fstab is the same as above with /mnt/door changed to /mnt/hall

what should I try next?
 
Old 10-17-2003, 11:38 AM   #6
virgin
Member
 
Registered: Jun 2003
Location: Pgh, PA
Distribution: debian
Posts: 50

Original Poster
Rep: Reputation: 15
meanwhile...

this is ages ago, but I found that the used id number is no longer 500, now it is 501, so I change my fstab line
to
/dev/hdb5 /mnt/door vfat users,uid=501,gid=501,umask=002,rw,auto, 0 0

and the door mounts, is there a better way????

of all the fstab lines I have seen this is the only kind I have had any luck with.
I would like one that makes the mount and gives a lot of permission to any user.

thanks.
 
Old 10-17-2003, 12:07 PM   #7
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try getting rid of 'uid=...', and change the 'gid=...' and 'umask=...' options. Find the group id (gid) of the group you want to use the partition. Maybe the gid for the 'users' group is 500. If you want to make another group and let it use the partition, create one, find it's gid, and put it in 'gid=...'. Then change the permissions using 'umask='. Using 'umask=770' might work. Here's the refurbished fstab line:
Code:
/dev/hdb5 /mnt/door vfat users,gid=500,umask=770,rw,auto 0 0

Last edited by aaa; 10-17-2003 at 12:09 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
su stopped working bulldogzerofive Linux - Software 5 01-17-2005 03:05 AM
It stopped working. UmneyDurak Fedora 8 08-15-2004 03:41 PM
Cannot change the permittion of /mnt/fat32 hkl8324 Linux - Newbie 7 07-18-2004 09:38 AM
My Devices in /mnt appear to not be working... Genesis Linux - Hardware 4 06-22-2003 10:58 AM
My X just stopped working??? freeindy Linux - Newbie 4 11-30-2002 11:53 AM


All times are GMT -5. The time now is 02:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration