LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-19-2004, 12:22 PM   #1
datalord7
LQ Newbie
 
Registered: Jan 2004
Location: uk
Posts: 6

Rep: Reputation: 0
mkhomedir driving me mad :-(


Hi
i have recently installed red hat 9 and think its one of the best os' ive used
anyway i have got round to running the samba server etc and all was well

i have set up my server so windows 98 clients can login as they would into a windows nt domain. at present when a user created on the linux platform logs into the domain from win 98 they are automatically mapped to their home dir in /home/%U that was created by linus when the account was created. I want the windows home directories stored elsewhere lets say /etc/sambaprofiles/%U this seems to work if i modify the [home] part in file /etc/samba/smb.conf but i have to create the directory for the user in /etc/sambaprofiles manually which can be quite annoying with lots of users. I have read pages and pages of info on this and it seems very simple in theory but when i modify my pam file /etc/pam.d/samba and add the line session required pam_mkhomedir.so skel=/etc/sambaskel umask=0022 it just denies and users logon access from 98 client. i have also added to the [global] part of the smb.conf file:
obey pam restrictions = yes
template homedir = /etc/sambaprofiles/%U

but still no joy :-(
i am using VIM to edit the files which i cant see causes any problems though i have read briefely about SWAT apparently to start this i would type in a browser 192.168.1.1:901
if 192.168.1.1 was my ip this just comes up connection refused.

any help with this would be greately appreciated as im on the verge of a mental breakdown here and i know its something silly that im missing :-)

Many thanks

MATT
 
Old 01-19-2004, 05:57 PM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
If I understand this right, you have access to your directories when they are /home subdirectories, but not as /etc subdirectories. This is because your subdirectories tend to inherit the permissions of their parents, in this case, /etc. So, you have two options, open /etc for all to view (bad, bad idea), or pick another location. / itself should be fine, as long as you modify both the samba permissions, and the directory/user permissions to allow this.

There might be a different problem working here, but I think this is a good place to start.

Oh, and to start SWAT, you probably want something like https://127.0.0.1:901/ especially if you're on that machine at the time. https is the "secure" form of http, and 127.0.0.1 is the same as 'localhost', so you can even type localhost (or your computer's name) instead of the numbers. Of course, you should have SWAT installed as well.

Personally, I like webmin+swat, that way everythings in one spot.

-------------

Oops, that's what I get for not reading the whole thing, and checking my facts. http://localhost:901/ should work, provided it's installed and available. https://yourcomputernameoraddress:901/ is probably the best option over your network.

Last edited by scott_R; 01-19-2004 at 06:21 PM.
 
Old 01-21-2004, 07:09 AM   #3
datalord7
LQ Newbie
 
Registered: Jan 2004
Location: uk
Posts: 6

Original Poster
Rep: Reputation: 0
RE MKHOMEDIR

hi thanks for your help i have now created my homes in /samba/profiles and created a skel directory in /samba/skel

i have added these lines to files

smb.conf ive added template homedir = /samba/profiles/%U

to samba in /etc/pam.d i have added at the tep of the session list

session required pam_mkhomedir.so skel=/samba/skel umask=0022

i then create a user on the gnome desktop using the user manager that comes with the gui then add the user to the samba server via the gui samba tool also with gnome

sav my user was john

if i then add a dir in /samba/profiles called john and set permissions for john to rwx and change the owner and group to john when i log in from windows all is well and the profiles is created but not from the /samba/skel directory just from the default windows dir on the c:\ drive

if however i do not create this directory in /samba/profiles then the logon from the win98 machine is just denied. :-(

maybe im missing some winbind stuff in my smb.conf file???



Any idead would be greately appreciated


Thanx
Matt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS driving me mad kkiedrowski Linux - Networking 1 11-27-2005 05:46 PM
kded driving me mad !!! gazza Mandriva 3 03-18-2005 12:19 PM
apt-get, driving me mad? luqman Red Hat 1 03-03-2005 12:03 AM
kernel is driving me mad luqman Linux - Newbie 6 02-18-2005 05:05 AM
kernel is driving me mad luqman Red Hat 2 02-17-2005 07:00 AM


All times are GMT -5. The time now is 06:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration