LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2010, 12:02 PM   #1
cshong87
LQ Newbie
 
Registered: Jun 2010
Posts: 5

Rep: Reputation: 0
mkdir error


I am a student studying computer science course.

Well, I am facing problem when doing lab questions.

I must use DLXLinux bundled in Bochs (bochs.sourceforge.net).

I am required to use the /usr/local directory.

In /usr directory, there is no directory named 'local' but there is one thing called 'local@'. So, when I try to use mkdir command to create 'local' directory in /usr , there are error "cannot make directory.....".

Please look at my screenshot at http://i854.photobucket.com/albums/a...hong/local.jpg .

Is there anything I can do to solve the problem?
 
Old 06-16-2010, 12:20 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Take a look at the output of 'ls -l /usr/' and then see if it makes more sense to you.

Adam
 
Old 06-16-2010, 12:35 PM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Hint: "@" is not part of the directory name
 
Old 06-16-2010, 09:40 PM   #4
cshong87
LQ Newbie
 
Registered: Jun 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Well, thanks for all the replies. the "ls -l" command in /usr directory bring the following result:

lrwxrwxrwx 1 root root 8 May 19 2001 local -> /zip/DLX

Looks like it is a linking. Is there any command to remove the link?
 
Old 06-16-2010, 09:42 PM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
You can just remove the link as if it's a normal file 'rm /usr/local'

You may want to make sure that /zip/DLX doesn't actually exist, though. There could be some very strange reason why /usr/local is linking to a directory called /zip/DLX

Adam
 
Old 06-16-2010, 10:07 PM   #6
cshong87
LQ Newbie
 
Registered: Jun 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by adamk75 View Post
You can just remove the link as if it's a normal file 'rm /usr/local'

You may want to make sure that /zip/DLX doesn't actually exist, though. There could be some very strange reason why /usr/local is linking to a directory called /zip/DLX

Adam
Running ls -l in /zip folder told me that the folder is empty, so no "DLX" in /zip folder.
 
Old 06-17-2010, 03:37 AM   #7
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
AFAIK @ means its a simlink.
local does infact exist.
Try posting the output of readlink /usr/local
 
Old 06-17-2010, 06:35 AM   #8
cshong87
LQ Newbie
 
Registered: Jun 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by smeezekitty View Post
AFAIK @ means its a simlink.
local does infact exist.
Try posting the output of readlink /usr/local
There is no readlink command in DLX linux. I get the "command not found" error when running readlink.
 
Old 06-17-2010, 06:36 AM   #9
prakashsince92
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.10 Maverick
Posts: 37

Rep: Reputation: 0
Hi cshong87,

It may be because group users are not allowed to make changes to /usr.

Try this code ( try becoming root and executing mkdir)

code:

sudo mkdir /usr/local
 
Old 06-17-2010, 10:27 AM   #10
myposts
Member
 
Registered: Jun 2010
Posts: 46

Rep: Reputation: 21
Here...

You have symbolic link in your directory. Symbolic links link to a different file/directory (see the first letter "l" in the output of your "ls -la". If you don't need it, you can remove it, or you can use a different name to create your directory. My advice get Evi Nemeth's book http://www.amazon.com/Linux-Administ...84776&sr=8-1or or training dvds from UNIX Academy http://unixacademy.com/category/3948...X-Training.htm . There are some basic concepts you must learn, otherwise you will be beating around the bush.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to give options like '-v' for mkdir using system call mkdir() ? nehapawar Linux - Newbie 2 02-05-2010 03:13 AM
I don't know. mkdir? Bobzilla2639716495 Linux - General 15 12-03-2007 12:22 PM
MKDIR Error? carlosinfl Linux - General 5 12-08-2006 06:18 PM
mkdir help... Linux~Powered Linux - Software 2 06-13-2004 12:27 PM
Strange mkdir error/behavior : Mandrake ManK Linux - General 4 10-17-2003 02:24 PM


All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration