LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2010, 07:19 AM   #1
z050
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Rep: Reputation: 0
missing separator error


Hello

I m supposed to uncomment this section (or the first line only?) from Makefile. But which ever way i try i get the same error message: 'missing separator'. So if somebody could show me how to do it it'll save my day.

# Use this for Linux with shadow passwords
# contributed by Andrew.Tridgell@anu.edu.au
# add -DLINUX_BIGCRYPT is you have shadow passwords but don't have the
# right libraries and includes
# FLAGSM = -DLINUX -DSHADOW_PWD
# LIBSM = -lshadow

Thanks in advance.
 
Old 08-29-2010, 07:32 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi,

Which part did you uncomment?

Without more info I would assume that this would be the end result:

# Use this for Linux with shadow passwords
# contributed by Andrew.Tridgell@anu.edu.au
# add -DLINUX_BIGCRYPT is you have shadow passwords but don't have the
# right libraries and includes
FLAGSM = -DLINUX -DSHADOW_PWD
LIBSM = -lshadow


Hope this helps.
 
Old 08-29-2010, 07:48 AM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
If the file is longer and ONLY first 4 lines are comments, you can remove the leading # by:
Code:
sed -e '5,$s/^#//' your_file
If it's just a question of those two lines, I guess it'll be quicker just to edit the file, LOL.
 
0 members found this post helpful.
Old 08-29-2010, 07:48 AM   #4
z050
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks a lot druuna . It definitely helped! . I must have tried some 15+ combinations heh. Im new to linux. Anyway, i immediately ran into another problem after 'make' which i have no clue about:

Compiling client.c
gcc -DSTEPPING -DSCANNER -DVERBOSE -DWORKGROUP=\"WORKGROUP\" -DGUEST_ACCOUNT=\"nobody\" -DLINUX -DSHADOW_PWD -c client.c
In file included from /usr/include/asm/signal.h:6,
from includes.h:232,
from client.c:33:
/usr/include/linux/time.h:9: error: redefinition of ‘struct timespec’
/usr/include/linux/time.h:15: error: redefinition of ‘struct timeval’
/usr/include/linux/time.h:20: error: redefinition of ‘struct timezone’
/usr/include/linux/time.h:42: error: redefinition of ‘struct itimerspec’
/usr/include/linux/time.h:47: error: redefinition of ‘struct itimerval’
In file included from includes.h:232,
from client.c:33:
/usr/include/asm/signal.h:15: error: conflicting types for ‘sigset_t’
/usr/include/sys/select.h:38: note: previous declaration of ‘sigset_t’ was here
In file included from includes.h:232,
from client.c:33:
/usr/include/asm/signal.h:104: error: redefinition of ‘struct sigaction’
/usr/include/asm/signal.h:132: error: redefinition of ‘struct sigaltstack’
/usr/include/asm/signal.h:136: error: conflicting types for ‘stack_t’
/usr/include/bits/sigstack.h:55: note: previous declaration of ‘stack_t’ was here
client.c:2714:50: warning: trigraph ??! ignored, use -trigraphs to enable
make: *** [client.o] Error 1


ermm...
 
Old 08-29-2010, 07:51 AM   #5
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi,
Quote:
Originally Posted by sycamorex View Post
If the file is longer and ONLY first 4 lines are comments, you can remove the leading # by:
Code:
sed -e '5,$s/^#//' your_file
Watch out with using this sed statement!!!

It will uncomment _all_ after line 5. There might be other comments which you do not want to uncomment or are actual comments (never to be uncommented)!!
 
Old 08-29-2010, 07:54 AM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Quote:
Originally Posted by druuna View Post
Hi,

Watch out with using this sed statement!!!

It will uncomment _all_ after line 5. There might be other comments which you do not want to uncomment or are actual comments (never to be uncommented)!!
Yes, as I said that might be helpful provided that ONLY the first 4 lines are comments. Otherwise, the sed statement is quite useless.
 
Old 08-29-2010, 08:03 AM   #7
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Quote:
Originally Posted by z050 View Post
Thanks a lot druuna . It definitely helped! . I must have tried some 15+ combinations heh.
You're welcome

Quote:
Anyway, i immediately ran into another problem after 'make' which i have no clue about:

Compiling client.c
client.c:2714:50: warning: trigraph ??! ignored, use -trigraphs to enable
make: *** [client.o] Error 1
All the redefinition, conflicting types and previous declaration message you can, in general, ignore. The actual error seems to be the trigraph message.

I don't have a clue what your are building and if there is any mention of trigraph in the documentation/makefile.

Only advise I can give is to check the documents and set (or unset) trigraph (or related).

Not much to go on, but maybe it helps.
 
Old 08-29-2010, 08:17 AM   #8
z050
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
OH sorry for that, the prog is NAT10 http://www.tux.org/pub/security/secnet/tools/nat10/
 
Old 08-29-2010, 09:05 AM   #9
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi,

It looks like you need to uncomment this as well for intergraph:
# This is for intergraph.
# contributed by cjkiick@flinx.b11.ingr.com
# modified by ttj@sknsws61.sjo.statkart.no
FLAGSM = -DCLIX -D_INGR_EXTENSIONS=1
LIBSM = -lbsd -lc_s


Hope this helps.
 
Old 08-29-2010, 09:41 AM   #10
z050
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the reply and your time (i m beginning to feel really really stupid lol)...but, here we go again :

Compiling client.c
gcc -DSTEPPING -DSCANNER -DVERBOSE -DWORKGROUP=\"WORKGROUP\" -DGUEST_ACCOUNT=\"nobody\" -DCLIX -D_INGR_EXTENSIONS=1 -c client.c
client.c:2714:50: warning: trigraph ??! ignored, use -trigraphs to enable
Compiling util.c
gcc -DSTEPPING -DSCANNER -DVERBOSE -DWORKGROUP=\"WORKGROUP\" -DGUEST_ACCOUNT=\"nobody\" -DCLIX -D_INGR_EXTENSIONS=1 -c util.c
Compiling system.c
gcc -DSTEPPING -DSCANNER -DVERBOSE -DWORKGROUP=\"WORKGROUP\" -DGUEST_ACCOUNT=\"nobody\" -DCLIX -D_INGR_EXTENSIONS=1 -c system.c
Compiling nmb.c
gcc -DSTEPPING -DSCANNER -DVERBOSE -DWORKGROUP=\"WORKGROUP\" -DGUEST_ACCOUNT=\"nobody\" -DCLIX -D_INGR_EXTENSIONS=1 -c nmb.c
nmb.c:43: error: conflicting types for ‘Debug1’
nmb.c:43: note: a parameter list with an ellipsis can’t match an empty parameter name list declaration
nmb.c:42: note: previous declaration of ‘Debug1’ was here
make: *** [nmb.o] Error 1
 
Old 08-29-2010, 09:58 AM   #11
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi again,

After some searching I found out there is a bug in nmb.c.

And after some testing I also found something else that needs changing.

- first remove the nat10 directory and freshly untar the nat10.tar.gz package,

- load the nmb.c file into an editor and remove this line: int Debug1(); (should be on line 43, under int Debug1(char *, ...); and above a blank line. Safe the file and exit the editor. It should now look like this:
int Debug1(char *, ...);

int num_good_sends=0;


- Open the Makefile in your editor and uncomment the following lines:
# Use this for Linux with shadow passwords
# contributed by Andrew.Tridgell@anu.edu.au
# add -DLINUX_BIGCRYPT is you have shadow passwords but don't have the
# right libraries and includes
FLAGSM = -DLINUX -DSHADOW_PWD
LIBSM = -lshadow


That is still like before.

Now look for the intergraph part and only uncomment the first line:
# This is for intergraph.
# contributed by cjkiick@flinx.b11.ingr.com
# modified by ttj@sknsws61.sjo.statkart.no
FLAGSM = -DCLIX -D_INGR_EXTENSIONS=1
# LIBSM = -lbsd -lc_s


This worked for me, running make did build everything without problems.

Hope this helps.
 
Old 08-29-2010, 10:26 AM   #12
z050
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Did everything as you instructed:

o charset.o parse_ip.o -lshadow
/usr/bin/ld: cannot find -lshadow
collect2: ld returned 1 exit status
make: *** [nat] Error 1
 
Old 08-29-2010, 10:32 AM   #13
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi,

Do you have linux with shadow passwords?

The Makefile has 2 options for linux: With or without shadow passwords. If you do you need to edit it as shown in my previous posts, if you do not then you need to edit the second one.

Option 2 would look like this in the Makefile:
# Use this for Linux with shadow passwords
# contributed by Andrew.Tridgell@anu.edu.au
# add -DLINUX_BIGCRYPT is you have shadow passwords but don't have the
# right libraries and includes
# FLAGSM = -DLINUX -DSHADOW_PWD
# LIBSM = -lshadow

# Use this for Linux without shadow passwords
# contributed by Andrew.Tridgell@anu.edu.au
FLAGSM = -DLINUX
LIBSM =


Hope this helps.
 
Old 08-29-2010, 10:41 AM   #14
z050
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Hey its starting to move...think its alive!!!!

Thank you again.
 
Old 08-29-2010, 10:50 AM   #15
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Hi,

You're welcome

Last edited by druuna; 08-29-2010 at 10:51 AM. Reason: You already pushed it. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Makefile:15: *** missing separator. Stop. chakka.lokesh Linux - Software 25 12-22-2010 10:04 PM
Makefile:34: *** missing separator. Stop. crysty2k9 Linux - Software 12 05-07-2010 07:10 AM
Missing Separator in makefile ? mohabic Linux - Newbie 2 01-23-2010 01:11 PM
spamassassin: makefile missing separator Andreja Linux - Software 1 05-31-2004 11:39 AM
Missing Separator? jamespetts Linux - Software 2 09-05-2002 01:24 PM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration