LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2007, 08:29 AM   #1
benny_j
LQ Newbie
 
Registered: Mar 2007
Posts: 16

Rep: Reputation: 0
missing locale


Hi,

Like so many others before me, I'm trying to get iso8859-15 instead of utf-8. I tried running:

sudo locale-gen sv_SE.ISO-8859-15

and that seemed to work:

Generating locales...
sv_SE.ISO-8859-15... done
Generation complete.


but now, when I run the command:

sudo dpkg-reconfigure locale

I get:

Package `locale' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: locale is not installed



I'm not sure but I think this might be bad. If it is ok, where do I go from here?

I am using Kubuntu 7.04 Feisty Fawn with Ubuntu kernel 2.6.20-16-386


Any help would be most appreciated,
Benny Johansson
 
Old 06-04-2007, 11:01 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch
Posts: 1,595

Rep: Reputation: 97
Hya,

I somewhat think that the package name you need may be "locales".

Happy Penguins!
 
Old 06-04-2007, 11:12 PM   #3
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
apt-cache search 'locale'

Does that work on Ubuntu or only on Debian?
 
Old 06-05-2007, 05:39 AM   #4
benny_j
LQ Newbie
 
Registered: Mar 2007
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kaz2100
Hya,

I somewhat think that the package name you need may be "locales".

Happy Penguins!

Yes, I had that package until I compiled the iso-8859-15 code. Does this mean that it was lost and I should download and install that package again or will that just mess things up?

Also, I have been trying to solve this problem by reading previous posts and it seems like I should get some kind of option when running the command
dpkg-reconfigure locale
but that never happend. All I got was a list of chartypes and their status (updated or not). Any idea why?


/Benny
 
Old 06-05-2007, 05:42 AM   #5
benny_j
LQ Newbie
 
Registered: Mar 2007
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73
apt-cache search 'locale'

Does that work on Ubuntu or only on Debian?

Yes, it works the same way for Ubuntu but should I install locale again? The package was present before the whole adding of iso-8859-15 and also, when I type locale I get the whole LC_ output.

/Benny
 
Old 06-05-2007, 07:35 AM   #6
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch
Posts: 1,595

Rep: Reputation: 97
Hya,
Try this and see what happens.
Code:
dpkg-reconfigure locales
Happy Penguins!
 
Old 06-05-2007, 09:02 AM   #7
benny_j
LQ Newbie
 
Registered: Mar 2007
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kaz2100
Hya,
Try this and see what happens.
Code:
dpkg-reconfigure locales
Happy Penguins!

ooh, I didn't put the 's' in locales. Sorry...

But where do I go from here?
How can I choose to use the iso-8859-15 as my systemwide charset?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 09:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 04:34 AM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 04-01-2006 12:38 AM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration