LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2014, 08:50 PM   #1
runningconfig
LQ Newbie
 
Registered: Dec 2014
Distribution: Mint
Posts: 6

Rep: Reputation: Disabled
Missing library - libcrypto.so.1.0.0.0


First post! I recently moved over to Ubuntu to learn Linux and for better support while using GNS3.

I just started receiving the following error when I try to launch GNS3:

Code:
root@zeppelin:/usr/lib# gns3
Traceback (most recent call last):
  File "/usr/local/bin/gns3", line 9, in <module>
    load_entry_point('gns3-gui==1.2.1', 'gui_scripts', 'gns3')()
  File "/usr/lib/python3/dist-packages/pkg_resources.py", line 351, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2363, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2088, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/local/lib/python3.4/dist-packages/gns3_gui-1.2.1-py3.4.egg/gns3/main.py", line 36, in <module>
  File "/usr/local/lib/python3.4/dist-packages/gns3_gui-1.2.1-py3.4.egg/gns3/main_window.py", line 37, in <module>
  File "/usr/local/lib/python3.4/dist-packages/gns3_gui-1.2.1-py3.4.egg/gns3/modules/__init__.py", line 18, in <module>
  File "/usr/local/lib/python3.4/dist-packages/gns3_gui-1.2.1-py3.4.egg/gns3/modules/builtin/__init__.py", line 24, in <module>
  File "/usr/local/lib/python3.4/dist-packages/gns3_gui-1.2.1-py3.4.egg/gns3/servers.py", line 28, in <module>
  File "/usr/lib/python3.4/ssl.py", line 97, in <module>
    import _ssl             # if we can't import it, let the error propagate
ImportError: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
I'm not sure what changed since it can't locate the libcrypto.so.1.0.0 library any more. I did a search for the and didn't come up with anything:

Code:
root@zeppelin:/usr/lib# find /usr/lib -name 'libcry*'
/usr/lib/vlc/plugins/codec/libcrystalhd_plugin.so
/usr/lib/x86_64-linux-gnu/libcrypto.so.0.9.8
/usr/lib/x86_64-linux-gnu/libcrypt.a
/usr/lib/x86_64-linux-gnu/libcrystalhd.so.3
/usr/lib/x86_64-linux-gnu/libcrystalhd.so.3.6
/usr/lib/x86_64-linux-gnu/libcrypt.so
/usr/lib/debug/lib/x86_64-linux-gnu/libcrypt-2.19.so
I checked and the libssl1.0.0 package is installed - I'm not really sure where to go from here.

Is there a way for me to reinstall the package putting the library back in the correct location? Is there a way I can download this specific library since the OS reports the package is already installed?

Thanks in advance!
 
Old 12-12-2014, 12:27 PM   #2
cesarbergara
Member
 
Registered: Feb 2012
Location: Buenos Aires, Argentina
Distribution: Debian, Suse, Mandrake,
Posts: 47

Rep: Reputation: Disabled
Hi. I saw you have an old version of libcrypto (0.9.8) installed.
Try to upgrade your installed version to libcrypto 1.0
You can found it on the web ( www.rpmfind.net , rpm.pbone.net , www.debian.org , etc, and convert with 'alien' from rpm to deb or tgzs).

I hope this will solve the problem.

Have a nice day.
 
Old 12-12-2014, 03:20 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
$ sudo apt-get install --reinstall libssl1.0.0

... will provide
/lib/x86_64-linux-gnu/libcrypto.so.1.0.0
/lib/x86_64-linux-gnu/libssl.so.1.0.0
( Which you probably have already.)


You are not supposed to work with GNS 3,
or any other "user application" as root.
"root" is for administrative commands only.
Please do : $ gns3
.. as unprivileged user.


GNS 3 packages https://launchpad.net/~gns3/+archive/ubuntu/ppa


-

Last edited by knudfl; 12-12-2014 at 03:30 PM.
 
1 members found this post helpful.
Old 01-03-2015, 03:37 PM   #4
runningconfig
LQ Newbie
 
Registered: Dec 2014
Distribution: Mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
$ sudo apt-get install --reinstall libssl1.0.0

... will provide
/lib/x86_64-linux-gnu/libcrypto.so.1.0.0
/lib/x86_64-linux-gnu/libssl.so.1.0.0
( Which you probably have already.)


You are not supposed to work with GNS 3,
or any other "user application" as root.
"root" is for administrative commands only.
Please do : $ gns3
.. as unprivileged user.


GNS 3 packages https://launchpad.net/~gns3/+archive/ubuntu/ppa


-
thanks for the path - and i'll keep $ in mind.
 
  


Reply

Tags
gns3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
google talk plugin complains of missing version information in libssl & libcrypto RandomTroll Slackware 2 04-27-2013 05:45 PM
[SOLVED] ./configure problem for libsf library due to apparently missing libdb library. vectrum Linux - Software 6 08-05-2011 03:11 PM
Problem executing scp command: missing dependency libcrypto.a shyam16 Linux - Newbie 6 06-15-2011 04:29 AM
ldd reports shared library missing, but library exists on disk athv_gr Linux - Newbie 7 05-13-2009 01:31 PM
libcrypto.so.0 missing ziggie216 Linux - Software 2 11-10-2005 01:06 AM


All times are GMT -5. The time now is 04:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration