LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2010, 11:30 AM   #1
pshankland
Member
 
Registered: Feb 2006
Location: UK
Distribution: CentOS 5.5
Posts: 46

Rep: Reputation: 15
Question Missing Dependency Errors via Yum


Hi all,

I am in the process of install Graphviz for NagVis but when I run yum install 'graphviz*' I get the following:

Code:
yum install 'graphviz*'
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: anorien.csc.warwick.ac.uk
 * base: anorien.csc.warwick.ac.uk
 * extras: anorien.csc.warwick.ac.uk
 * rpmforge: apt.sw.be
 * updates: anorien.csc.warwick.ac.uk
Setting up Install Process
Package graphviz-guile-2.22.0-4.el5.rf.i386 already installed and latest version
Package graphviz-devel-2.22.0-4.el5.rf.i386 already installed and latest version
Package graphviz-doc-2.22.0-4.el5.rf.i386 already installed and latest version
Package graphviz-graphs-2.22.0-4.el5.rf.i386 already installed and latest version
Package graphviz-2.22.0-4.el5.rf.i386 already installed and latest version
Package graphviz-java-2.22.0-4.el5.rf.i386 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package graphviz-lua.i386 0:2.8-1.el5.rf set to be updated
--> Processing Dependency: graphviz = 2.8-1.el5.rf for package: graphviz-lua
--> Processing Dependency: libgvc.so.2 for package: graphviz-lua
---> Package graphviz-ocaml.i386 0:2.8-1.el5.rf set to be updated
--> Processing Dependency: graphviz = 2.8-1.el5.rf for package: graphviz-ocaml
---> Package graphviz-perl.i386 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libgv_perl.so.0 for package: graphviz-perl
---> Package graphviz-php.i386 0:2.8-1.el5.rf set to be updated
--> Processing Dependency: graphviz = 2.8-1.el5.rf for package: graphviz-php
--> Processing Dependency: libgvc.so.2 for package: graphviz-php
---> Package graphviz-python.i386 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libgv_python.so.0 for package: graphviz-python
---> Package graphviz-ruby.i386 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libruby.so.1.8 for package: graphviz-ruby
--> Processing Dependency: libgv_ruby.so.0 for package: graphviz-ruby
--> Processing Dependency: /usr/bin/ruby for package: graphviz-ruby
---> Package graphviz-tcl.i386 0:2.22.0-4.el5.rf set to be updated
--> Running transaction check
---> Package graphviz-lua.i386 0:2.8-1.el5.rf set to be updated
--> Processing Dependency: graphviz = 2.8-1.el5.rf for package: graphviz-lua
--> Processing Dependency: libgvc.so.2 for package: graphviz-lua
---> Package graphviz-ocaml.i386 0:2.8-1.el5.rf set to be updated
--> Processing Dependency: graphviz = 2.8-1.el5.rf for package: graphviz-ocaml
---> Package graphviz-perl.i386 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libgv_perl.so.0 for package: graphviz-perl
---> Package graphviz-php.i386 0:2.8-1.el5.rf set to be updated
--> Processing Dependency: graphviz = 2.8-1.el5.rf for package: graphviz-php
--> Processing Dependency: libgvc.so.2 for package: graphviz-php
---> Package graphviz-python.i386 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libgv_python.so.0 for package: graphviz-python
---> Package graphviz-ruby.i386 0:2.22.0-4.el5.rf set to be updated
--> Processing Dependency: libgv_ruby.so.0 for package: graphviz-ruby
---> Package ruby.i386 0:1.8.5-5.el5_4.8 set to be updated
---> Package ruby-libs.i386 0:1.8.5-5.el5_4.8 set to be updated
--> Finished Dependency Resolution
graphviz-php-2.8-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: graphviz = 2.8-1.el5.rf is needed by package graphviz-php-2.8-1.el5.rf.i386 (rpmforge)
graphviz-lua-2.8-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgvc.so.2 is needed by package graphviz-lua-2.8-1.el5.rf.i386 (rpmforge)
graphviz-python-2.22.0-4.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgv_python.so.0 is needed by package graphviz-python-2.22.0-4.el5.rf.i386 (rpmforge)
graphviz-ruby-2.22.0-4.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgv_ruby.so.0 is needed by package graphviz-ruby-2.22.0-4.el5.rf.i386 (rpmforge)
graphviz-lua-2.8-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: graphviz = 2.8-1.el5.rf is needed by package graphviz-lua-2.8-1.el5.rf.i386 (rpmforge)
graphviz-perl-2.22.0-4.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgv_perl.so.0 is needed by package graphviz-perl-2.22.0-4.el5.rf.i386 (rpmforge)
graphviz-ocaml-2.8-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: graphviz = 2.8-1.el5.rf is needed by package graphviz-ocaml-2.8-1.el5.rf.i386 (rpmforge)
graphviz-php-2.8-1.el5.rf.i386 from rpmforge has depsolving problems
  --> Missing Dependency: libgvc.so.2 is needed by package graphviz-php-2.8-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgv_ruby.so.0 is needed by package graphviz-ruby-2.22.0-4.el5.rf.i386 (rpmforge)
Error: Missing Dependency: graphviz = 2.8-1.el5.rf is needed by package graphviz-php-2.8-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgvc.so.2 is needed by package graphviz-php-2.8-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: graphviz = 2.8-1.el5.rf is needed by package graphviz-lua-2.8-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: graphviz = 2.8-1.el5.rf is needed by package graphviz-ocaml-2.8-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgvc.so.2 is needed by package graphviz-lua-2.8-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgv_python.so.0 is needed by package graphviz-python-2.22.0-4.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libgv_perl.so.0 is needed by package graphviz-perl-2.22.0-4.el5.rf.i386 (rpmforge)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
I am running CentOS 5.5 32bit and have only added the extra rpmforge repo's.

Could someone point me in the right direction?

Thanks.
 
Old 06-29-2010, 01:17 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Well, the error messages seem to imply that the additional packages need the old 2.8-1.el5 version of graphviz, and you have the newest version (2.22.0-4.el5) installed.

You could try downgrading your installed software to the 2.8-1 version or recompiling the interface(s) you need against the newer libraries.
 
1 members found this post helpful.
Old 06-29-2010, 02:05 PM   #3
Bhagyesh
Member
 
Registered: Jul 2009
Posts: 35

Rep: Reputation: 17
Verify the version of package that you have installed and the one that you are getting through package update.

I guess it is due to the version conflict

you can also try : yum resolvedep <package> (I am not sure if this would definitely help you)
 
1 members found this post helpful.
Old 06-29-2010, 03:25 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531
In addition to what PTrenholme offered you chose to run 'yum install 'graphviz*';'. I wonder if you need ALL those packages. Between all those packages there's a libgvc dependency of at least three different versions that can't be resolved this way. If you for instance run 'yum install graphviz-lua' or 'yum install graphviz-php' you won't have those dependency errors. If downgrading to the old 2.8-1.el5 version doesn't work or isn't wanted then I agree installing the necessary -devel packages, recompiling the required .src.rpm and installing that would be the most efficient option wrt package and dependency maintenance.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum Error: Missing Dependency vijay1585 Linux - Newbie 2 04-26-2009 06:41 PM
Missing Dependency - yum hectorDUQUE Fedora 6 06-29-2008 09:33 PM
RHEL5, yum, and missing dependency.... grantcarmichael Linux - Software 2 05-15-2008 08:12 PM
How to tell yum missing dependency is actually there decrepit Fedora 2 02-04-2007 06:36 AM
yum missing dependencY puppet Linux - Software 6 10-26-2005 11:20 AM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration