LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2009, 10:34 PM   #1
TinGod
LQ Newbie
 
Registered: Aug 2009
Posts: 7

Rep: Reputation: 0
Mint is silent (Sound card help)


Hi all,

I just installed Mint 7 today and am unable to get it to play any sounds. When running XP (on a separate hard drive), the sound card(s) work fine and I've made sure that none of the channels are muted in ALSAMIXER.

I'v tried "modprobe snd_ca0106" and it returned the dollar sign so I assume that the Sound Blaster driver is present.

Also, I'm not sure if this is related but, just in case, Rhythmbox looks for and is unable to find a plugin every time I try to run it but Alsaplayer and GNOME MPlayer recognize my music and seem to play it but no sound.

I have read numerous similar questions but some don't seem to apply to my situation and in some cases, I'm not sure what I'm looking at since I'm very new to this.

Thanks in advance for your help.

Here are the results of several commands(?) that I've seen requested in others posts.

lspci -v
Quote:
03:00.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
Subsystem: Creative Labs Device 1007
Flags: bus master, medium devsel, latency 64, IRQ 16
I/O ports at d8a0 [size=32]
Capabilities: <access denied>
Kernel driver in use: CA0106
Kernel modules: snd-ca0106

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)

Subsystem: Dell Device 0181

Flags: bus master, medium devsel, latency 0, IRQ 23

I/O ports at ec00 [size=256]

I/O ports at e8c0 [size=64]

Memory at dfebfe00 (32-bit, non-prefetchable) [size=512]

Memory at dfebfd00 (32-bit, non-prefetchable) [size=256]

Capabilities: <access denied>

Kernel driver in use: Intel ICH

Kernel modules: snd-intel8x0
aplay -l
Quote:
**** List of PLAYBACK Hardware Devices ****
card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 0: ca0106 [CA0106]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 1: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 2: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 3: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
lsmod | grep snd
Quote:
snd_ca0106 39968 1
snd_intel8x0 37532 3
snd_ac97_codec 112292 2 snd_ca0106,snd_intel8x0
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 82948 4 snd_ca0106,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 2 snd_ca0106,snd_seq_midi
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 29704 2 snd_pcm,snd_seq
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 62628 19 snd_ca0106,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd _seq,snd_timer,snd_seq_device
ac97_bus 9856 1 snd_ac97_codec
soundcore 15200 1 snd
snd_page_alloc 16904 3 snd_ca0106,snd_intel8x0,snd_pcm
lshw
Quote:
*-multimedia

description: Multimedia audio controller

product: CA0106 Soundblaster

vendor: Creative Labs

physical id: 0

bus info: pci@0000:03:00.0

version: 00

width: 32 bits

clock: 33MHz

capabilities: bus_master cap_list

configuration: driver=CA0106 latency=64 maxlatency=20 mingnt=2 module=snd_ca0106

*-multimedia

description: Multimedia audio controller

product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller

vendor: Intel Corporation

physical id: 1e.2

bus info: pci@0000:00:1e.2

version: 03

width: 32 bits

clock: 33MHz

capabilities: bus_master cap_list

configuration: driver=Intel ICH latency=0 module=snd_intel8x0
 
Old 08-02-2009, 03:05 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
One question: did you run alsaconf (as root)?

Markus

Last edited by markush; 08-02-2009 at 05:28 PM.
 
Old 08-02-2009, 03:10 PM   #3
TinGod
LQ Newbie
 
Registered: Aug 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by markush View Post
One question: did you rund alsaconf (as root)?

Markus
I did not. Is the command just alsaconf?
Thanks.
 
Old 08-02-2009, 05:35 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
alsaconf is a script, originaly by Suse but also running for example on slackware.
alsaconf sets up your sound-device.
In the earlier days of alsa it was necessary to run this script by hand, but in these days in most distros alsaconf runs while installation and one would not run it by hand.
But since I don't know if mint sets up alsa while installation I would suggest to try it.

Markus
 
Old 08-02-2009, 10:07 PM   #5
TinGod
LQ Newbie
 
Registered: Aug 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by markush View Post
alsaconf is a script, originaly by Suse but also running for example on slackware.
alsaconf sets up your sound-device.
In the earlier days of alsa it was necessary to run this script by hand, but in these days in most distros alsaconf runs while installation and one would not run it by hand.
But since I don't know if mint sets up alsa while installation I would suggest to try it.

Markus
When I try to run alsaconf or sudo alsaconf, it returns "alsaconf: command not found" Is there something else I should try?
 
Old 08-02-2009, 11:28 PM   #6
TinGod
LQ Newbie
 
Registered: Aug 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Update:

1. I got Rhythmbox to work by deleting incompatible audio files.
2. I disabled the onboard soundchip in BIOS and now
Quote:
cat /proc/asound/cards
only lists Sound Blaster Live 7.1.
3. I added myself to the audio group.

4. Still no sound.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NVidia Sound is silent :( em21701 Slackware 9 03-04-2008 11:32 PM
no sound. OSS silent, ALSA broken r00tb33r Linux - Hardware 4 03-10-2007 02:37 AM
CD sound silent, cannot unmute noid Linux - Newbie 8 07-24-2005 06:57 AM
No sound,a silent world Swift&Smart Slackware 11 05-21-2005 08:02 AM
Silent Night.....my sound don't work draggin Linux - Hardware 6 12-24-2004 11:40 PM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration