LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2012, 02:46 AM   #1
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Rep: Reputation: 2
Mint is eager and stubborn :)


Just installed Linux Mint 12 on the lappy (I am posting from one of my netbooks right now).

Other stuff I can take my time with but I need to set up the wireless connection to do anything else on the lappy.

For reasons unknown to me Linux keeps trying to access a police surveillance vans wifi and keeps refusing to connect to my wireless network. I admire Linux's spirit but I would like to be connected to my wireless network before I end up in prison. The network manager is being troublesome to say the least.

So... how do I get it to stop trying to connect to the cop van and use my wireless network instead? Z/Z
 
Old 01-23-2012, 02:59 AM   #2
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Ok, i REALLY mean no offense, but this made my day...
http://npoze.com/wp-content/uploads/...e-VAN-0921.jpg
http://blog.rootshell.be/2008/07/18/funny-ssid/
Somebody within range of your wireless device has a sense of humor.

I dont use network manager, so i cant really comment on it, but if you can see your AP's SSID, you should be able to tell network manager to connect to that, and make it the default connection.

Last edited by fukawi1; 01-23-2012 at 03:00 AM.
 
1 members found this post helpful.
Old 01-23-2012, 03:06 AM   #3
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
I nearly died at IPFreely... although FreeDonkeyPron is uber. Z/Z
 
Old 01-23-2012, 03:16 AM   #4
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 378

Rep: Reputation: 41
Wink Police Yikes !!

I think someone is messing with your mind. At least the cops secured their network. You can always set up a wireless router and then simply select that choice from multiple choices in the menu.

You can also hide your network and then use the options for accessing a hidden network. KDE's networking tool has this in a GUI.

Like the cops, you should secure your network. Use WPA instead of WEPP.
 
1 members found this post helpful.
Old 01-23-2012, 04:58 AM   #5
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
The router is secure BUT the network manager in Mint will not "lock on" to my router's wireless signal and instead keeps on trying to access other wireless networks I do not have the hex keys for. This is my first time using a distro of Linux with a network manager. During install it accessed a local hotspot easy until I could dig up my key but after the install I had the problems with the manager trying to access other networks and the driver for the mini not installing... so I switched to an alfa. Last time I checked I was stuck on an unsecured network that wouldn't give me access and it was the only network listed.

With the network manager gone haywire I really have no other choice than to ask for help here or reinstall the OS and hope it doesn't mess up again (technically it is probably my fault for not knowing how configure the network manager but in my defence I did not tell it to try to connect any network at random).

The other problem is grub is going to act up if I try to remove Mint from the windows side. I had issues with the boot managers a little while back and lost all my data... not something I am looking forward to doing again since it took me over a week to dl NWN2 again (I like the classics that are more game than eyecandy).

Suggestions would be nice... I know how to use windows and parted magic to fix partitions but I still do not know how to alter the boot manager w/o screwing up windows. Z/Z
 
Old 01-23-2012, 05:16 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Not sure if this will help, but run this:
Code:
wpa_passphrase ssid passphrase
ssid = name of your wireless network.
Then edit /etc/wpa_supplicant.conf, adding the results.
 
1 members found this post helpful.
Old 01-23-2012, 05:21 AM   #7
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Slow down there.
You don't have to reinstall.
You MAY have to get dirty on the commandline though..

You say you dug up the key, and I am guessing you know the SSID. If not, you should be able to find these by booting back into Windows and writing down the info.

You can configure the wireless interface via the commandline. If you only connect to one WLAN, then it will be simple, if you intend to connect to multiple WLANS, there are a couple of options.

Before going into the commandline side of things, you may want to try installing wicd, which is a Network Manager esque GUI application that handles configuring wireless adapters fairly well.

Here is a basic guide to setting up wireless via the command line.
http://www.ghacks.net/2009/04/14/con...-command-line/

And here is a more detailed guide to the same. http://www.linuxhomenetworking.com/w...ess_Networking

For the record, anything that you read that pertains to Debian or Ubuntu, should be compatible with Mint.
Although your WLAN interface name may vary (wlan0, wifi0, ath0, etc)
 
1 members found this post helpful.
Old 01-23-2012, 05:21 AM   #8
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Thankx Bri... I'll give it a shot after I de-stress a bit... I'll post the results in a bit... you never know the manager might act a little different after I restart in Mint again. Z/Z

P.S.: These are command line entries right... do I have to use sudo or change to a certain directory?

P.P.S.: fukawi thanks... Wicd was very easy to manage when I was using BT5 but for some reason did not pick up one quarter of the networks that Mint's network manager is picking up now. I'll post in a bit after I relax before I blow a gasket. Z/Z

Last edited by LinuxNoobX; 01-23-2012 at 05:27 AM.
 
Old 01-23-2012, 05:35 AM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Oh, yeah, forgot that, use sudo.
Then, for the editing, run:
Code:
gksudo gedit /etc/wpa_supplicant.conf
gksudo is for opening any GUI as root.

Last edited by brianL; 01-23-2012 at 05:41 AM.
 
1 members found this post helpful.
Old 01-23-2012, 08:30 AM   #10
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Two levels of elevation? Probably be in a lot of trouble if I screw up that command Normally I'd be very curious about root-related topics BUT that is a little advanced for a guy who can't get his wireless to work properly (that guy being me). 10 more minutes of House and I'll start trying the ideas on how the get the manager to work properly. Z/Z
 
Old 01-23-2012, 09:18 AM   #11
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Wink Thankx everybody :)

I am not completely retarded... it turned out to be a wonky process conflict after all and I was able to set up the wireless properly with the standard network manager after I restarted Mint.

I'll try not to cause any false alarms in future Thanks for all your help Z/Z
 
Old 01-23-2012, 09:20 AM   #12
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Good to hear you figured out, now try to stay out of troubles!
 
Old 01-23-2012, 09:27 AM   #13
LinuxNoobX
Member
 
Registered: Jan 2012
Location: Evermore
Distribution: Linux Mint 12
Posts: 165

Original Poster
Rep: Reputation: 2
Wink

Come on man... you know people who pick up Linux are not looking for trouble... ROFLMAO !!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New and eager to learn! dminish LinuxQuestions.org Member Intro 1 10-10-2011 11:24 AM
New to Linux and eager to try... help me! Ambrusch Linux - Distributions 4 03-03-2007 08:43 PM
New to Linux and eager to try... help me! Ambrusch Linux - Distributions 1 03-03-2007 08:55 AM
Stubborn freebsd nc3b *BSD 9 08-22-2006 02:47 PM
Stubborn router Thulemanden Linux - Networking 6 07-29-2006 03:13 PM


All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration