LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2008, 09:56 AM   #1
crapper
Member
 
Registered: Jul 2004
Posts: 48

Rep: Reputation: 15
Mint Display Problems ?


Mint Display Problems
I'm new to Linux, I have tried other live CD versions of Linux and could not get used to them and kept going back to WindowsXP.
Tried Mint and it's great, have removed XP as this Mint seems to be just right and easy to use.
Installation of Mint gives me a full screen of 1280x1024
My problem is keeping the 1280x1024 screen size to fill my 17in monitor. I keep getting a half-inch black line at the bottom of the monitor.
I use the monitor (H-Position and V-Position) to correct it and stretch it to fill the monitor screen. The problem happens again when I leave a full screen game like "Arena" my monitor changes back to having a black half-inch line at the bottom, And I then have to stretch the monitor settings again.
Is there a way to fix this and keep my monitor settings from changing ?



Motherboard: ASUS M2N-X Plus.
Graphics: Nvidia 8600 GT
Monitor: Acer AL1717=17in recommended setting 1280x1024.

crapper
 
Old 11-01-2008, 11:17 AM   #2
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Rep: Reputation: 15
Could you post your /etc/X11/xorg.conf? If it's a setting there you're likelier to get help if you post it.
/CZ
 
Old 11-01-2008, 11:41 AM   #3
crapper
Member
 
Registered: Jul 2004
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Count Zero View Post
Could you post your /etc/X11/xorg.conf? If it's a setting there you're likelier to get help if you post it.
/CZ
Thanks. This is what /etc/X11/xorg.conf shows.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection



crapper
 
Old 11-01-2008, 12:34 PM   #4
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Rep: Reputation: 15
Just a guess but under the Section "Screen", try inserting (between Defaultdepth and EndSection):

SubSection "Display"
Modes "1280x1024"
EndSubSection

/CZ
 
Old 11-01-2008, 03:07 PM   #5
crapper
Member
 
Registered: Jul 2004
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Count Zero View Post
Just a guess but under the Section "Screen", try inserting (between Defaultdepth and EndSection):

SubSection "Display"
Modes "1280x1024"
EndSubSection

/CZ
Hi Count Zero.
No still no luck, same still happens, any further suggestions.

crapper
 
Old 11-01-2008, 05:32 PM   #6
crapper
Member
 
Registered: Jul 2004
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by crapper View Post
Hi Count Zero.
No still no luck, same still happens, any further suggestions.

crapper
It's not the resolution of 1280x1024 that is being altered, it's the V-Position of the monitor that is not being held by the system ?

And this is reducing the visual size of the visable screen leaving a half inch black line at the bottom of the screen.

Any one no how this can be fixed ?


Thanks. This is what /etc/X11/xorg.conf shows.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


crapper
 
Old 11-02-2008, 03:22 AM   #7
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Rep: Reputation: 15
Ok, then I think that what you are looking for is the options HSyncStart, HsyncEnd, VSyncStart, VsyncEnd and HTotal, VTotal They control, I think, where the displayed screen starts and ends as well the absolute size. I haven't had any need for these options myself so I can't give you any specific instructions but www.google.com/linux gave this that might be useful:


http://languor.us/node/65


Hope it helps
/CZ
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Display problems kris.c Fedora 3 03-02-2008 11:27 AM
Linux Mint: WOW problems. Nokturnl Linux - Newbie 1 02-17-2008 04:27 PM
re installation of grub in Linux mint after installing xp over mint sampad.sarangi General 1 01-15-2008 06:37 PM
LXer: Linux Mint is.....Mint! LXer Syndicated Linux News 0 11-18-2007 07:41 AM
Linux Mint in Microsoft Virtual PC 2007. Mouse problems. lammis Linux - Software 3 11-12-2007 10:43 AM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration