LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-24-2014, 03:22 AM   #1
wimpy
LQ Newbie
 
Registered: Jun 2014
Posts: 8

Rep: Reputation: Disabled
Mint 17 Qiana Mate - making the resolution permanent


I've asked this elsewhere without getting a reply that works. I'm using a combination of cvt and xrandr as the basis of a script which adds the mode 1360x768_60.00 to the available options in Control Centre -> Monitor:
Code:
#!/bin/sh
#Make screen resolution change
xrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
xrandr --addmode VGA-0 1360x768_60.00
xrandr --output VGA-0 --mode 1360x768_60.00
#END
I've set this up as a desktop icon and can run it inside a terminal. It works fine. A look in Control Centre -> Monitor confirms the change of resolution. Trying to set this as Default, however results in a a hiatus at the next boot and the OS reverts to 1920x1080. The monitor is a Benq 22.5in and the AGP card is a Radeon X800GT.


I wanted to make the change permanent so I guessed that I needed to enter the file to run somewhere in the boot sequence or to insert the nitty-gritty of the code into something that does run in the boot sequence. It was suggested that the place to insert the code was /etc/mdm/Init/Defaults. Unfortunately that does not work. I suspect that, even if that code does run, it is overwritten by some other file.
As an aside, the system looks nice but it is a PITA to make any adjustments. It seems to be a waste to have GUIs all over the show, which cannot be used and the superuser has to resort to command line manipulation.
I would be grateful for any advice or suggestions to get this done.
 
Old 06-24-2014, 06:01 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
As you have discovered, xrandr changes to resolution only last to the next reboot. To make changes permanent, you need to add them to your xorg.conf file.

You need to look at your LinuxMint documentation to learn how to do edit the file, or create it if it doesn't exist.
 
Old 06-25-2014, 07:46 AM   #3
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
Quote:
Originally Posted by wimpy View Post
I've set this up as a desktop icon and can run it inside a terminal. It works fine.
most distros have a gui for managing startup applications, so you could make this into an executable shell script and tell mint to execute it every login.
would that be sufficient?
it's certainly safer than creating and editing xorg.conf.
 
Old 06-25-2014, 08:00 AM   #4
wimpy
LQ Newbie
 
Registered: Jun 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
@ondoho Thanks for the reply. There was no xorg.conf in /etc/X11. I created one using a puppy lunux one as a template. Unfortunately, the video driver for puppy does not have the same name as the one that Mint uses (Mint's driver is clearly a lot better). It just ignores xorg.conf on boot-up. Is there a way in linux to get at the name of the driver used?
I still haven't found a way of inserting the script into the boot train.I tried putting in init.d and running update-rc.d. That didn't work - it went back to its default of 1920x1080.
 
Old 06-26-2014, 09:32 AM   #5
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
my point precisely.

why don't you try adding the script to your desktop sessions autostart (no root privileges involved)?
i know it's technically not permanent, but at least it gets applied automatically.
 
Old 06-27-2014, 04:35 PM   #6
wimpy
LQ Newbie
 
Registered: Jun 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
Yes. I think that's going to be the best solution. Thanks for the input - I'll mark this as "Solved"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Linux Mint 17 Qiana MATE : Video Review and Screenshot Tour LXer Syndicated Linux News 0 06-08-2014 12:03 PM
Linux Mint 17 “Qiana” MATE and Cinnamon released jeremy Linux - News 1 06-02-2014 12:57 PM
[SOLVED] Mate switched to cinnamon wthout permission mint-13-mate littlejoe5 Linux Mint 7 05-08-2014 11:54 PM
Change network NIC speed and making it permanent in Linux Mint 14 64 bit GJQ Linux - Newbie 3 08-10-2013 12:34 AM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration