LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2011, 10:50 PM   #1
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Rep: Reputation: Disabled
Smile Mint 11 won't recognize my ethernet connection/unable to connect to internet


Hi, I am brand new to linux. I just bought a computer that had Mint 11 x64 installed on it. I am using a modem with a direct ethernet connection into the desktop box. when i turn on the computer, it does not recognize that there is a connection. i tried rebooting the system with the start-up disc to no avail.
i tried to go into the network connections editing menu to ensure the MAC address was correct; however, when i try to enter in my devices MAC address, the "save" option goes away so the new address cannot be updated.
i have a feeling the network may be locked to the previous owners internet connection, but don't see anyway to change it.
thanks in advance for your help!!
 
Old 08-28-2011, 04:13 AM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hallo travellindaze, welcome to LQ,

could you please (in Linux) open a terminal and post the output of
Code:
lspci -k | grep -iA5 ether
and
Code:
ifconfig
You're obviously connected with a Windows-computer, if it is the same network, please (in Windows) open the cmd-shell and post the output of
Code:
ipconfig /all
Markus
 
Old 08-28-2011, 11:15 AM   #3
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
hi markus, thank you so much for your reply!
i will keep this page open so i can reply sooner next time...
i really appreciate your help!
this is probably a really stupid question, but i can't figure out which
key makes the vertical line that is in the first code. i will try to figure
this out while awaiting your response.
also, once i get the response after entering in the code, do you want me to post
it back to you?
and yes, your thoughts about windows must be correct because my lap top, which is the only
other computer i have run from this internet connection, is operating with windows 7
thanks again!
andrea
 
Old 08-28-2011, 11:17 AM   #4
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
ok, figured out the vertical bar thing, no need to
respond to that
 
Old 08-28-2011, 11:39 AM   #5
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
output code results

from the cmd-shell on the windows laptop:

C:\Users\strangebrew>iconfig /all
'iconfig' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\strangebrew>iconfig/all
'iconfig' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\strangebrew>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : strangebrew-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : grandenetworks.net

Wireless LAN adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
Physical Address. . . . . . . . . : 90-4C-E5-72-8C-DF
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : grandenetworks.net
Description . . . . . . . . . . . : Atheros AR8132 PCI-E Fast Ethernet Contro
ller (NDIS 6.20)
Physical Address. . . . . . . . . : 70-5A-B6-03-18-55
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::a992:cdf:9c28:c667%11(Preferred)
IPv4 Address. . . . . . . . . . . : 24.155.110.14(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.254.0
Lease Obtained. . . . . . . . . . : Saturday, August 27, 2011 4:34:44 PM
Lease Expires . . . . . . . . . . : Monday, August 29, 2011 2:16:48 PM
Default Gateway . . . . . . . . . : 24.155.111.254
DHCP Server . . . . . . . . . . . : 192.168.64.33
DHCPv6 IAID . . . . . . . . . . . : 234890074
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-BA-8C-64-70-5A-B6-03-18-55

DNS Servers . . . . . . . . . . . : 66.90.130.101
66.90.130.10
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.grandenetworks.net:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : grandenetworks.net
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:3813:382e:e764:91f1(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::3813:382e:e764:91f1%15(Preferred)
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter 6TO4 Adapter:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Reusable Microsoft 6To4 Adapter:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 13:

Connection-specific DNS Suffix . : grandenetworks.net
Description . . . . . . . . . . . : Microsoft 6to4 Adapter #4
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2002:189b:6e0e::189b:6e0e(Preferred)
Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
DNS Servers . . . . . . . . . . . : 66.90.130.101
66.90.130.10
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{C67F58B7-6C96-43C5-A4E1-D231D395359B}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

from the linux box

zuvuya@zuvuya-MS-7309 ~ $ lspci - | grep -iA5ether
grep: 5ether: invalid context length argument

Usage: lspci [<switches>]

Basic display modes:
-mm Produce machine-readable output (single -m for an obsolete format)
-t Show bus tree

Display options:
-v Be verbose (-vv for very verbose)
-k Show kernel drivers handling each device
-x Show hex-dump of the standard part of the config space
-xxx Show hex-dump of the whole config space (dangerous; root only)
-xxxx Show hex-dump of the 4096-byte extended config space (root only)
-b Bus-centric view (addresses and IRQ's as seen by the bus)
-D Always show domain numbers

Resolving of device ID's to names:
-n Show numeric ID's
-nn Show both textual and numeric ID's (names & numbers)
-q Query the PCI ID database for unknown ID's via DNS
-qq As above, but re-query locally cached entries
-Q Query the PCI ID database for all ID's via DNS

Selection of devices:
-s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
-d [<vendor>]:[<device>] Show only devices with specified ID's

Other options:
-i <file> Use specified ID database instead of /usr/share/misc/pci.ids.gz
-p <file> Look up kernel modules in a given file instead of default modules.pcimap
-M Enable `bus mapping' mode (dangerous; root only)

PCI access options:
-A <method> Use the specified PCI access method (see `-A help' for a list)
-O <par>=<val> Set PCI access parameter (see `-O help' for a list)
-G Enable PCI access debugging
-H <mode> Use direct hardware access (<mode> = 1 or 2)
-F <file> Read PCI configuration dump from a given file
zuvuya@zuvuya-MS-7309 ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 6c:62:6d:ed:bb:5c
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:43

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2880 (2.8 KB) TX bytes:2880 (2.8 KB)

zuvuya@zuvuya-MS-7309 ~ $


thanks again for your help
 
Old 08-28-2011, 12:15 PM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Quote:
Originally Posted by travellindaze View Post
C:\Users\strangebrew>iconfig /all
'iconfig' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\strangebrew>iconfig/all
'iconfig' is not recognized as an internal or external command,
operable program or batch file.

....

zuvuya@zuvuya-MS-7309 ~ $ lspci - | grep -iA5ether
grep: 5ether: invalid context length argument
Well, the commands must be typed correctly, otherwise they won't work. the command for lspci on the Linux-machine was
Code:
lspci -k | grep -iA5 ether
and blanks are necessary!

Your Network uses DHCP!

The ethernet-NIC on Linux seems to be recognized by the system and eth0 is up. So it seems your Linux is not configured to use DHCP.

You should read the manuals and find out how to configure Linux Mint to use DHCP. I'm not experienced with Mint, but there should be a file /etc/network/interfaces, you can edit it and configure for DHCP.

Markus

Last edited by markush; 08-28-2011 at 12:16 PM.
 
Old 08-28-2011, 02:39 PM   #7
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hi Markus, sorry about that, here is the correct code response:


zuvuya@zuvuya-MS-7309 ~ $ lspci -k | grep -iA5 ether
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
Subsystem: Micro-Star International Co., Ltd. Device 7309
Kernel driver in use: r8169
Kernel modules: r8169
zuvuya@zuvuya-MS-7309 ~ $

well, i tried to update the DCHP information in Edit Connections menu and was not successful. i found the following tutorial
http://webcache.googleusercontent.co...www.google.com

however, when i tried to manually enter in the information, the save button became inactive so that i could not update the information. as well, i was unsure of what to enter into the Search Domain field.
i am going to keep working on it, but if you have any other suggestions please let me know!
thank you,
andrea
 
Old 08-28-2011, 02:51 PM   #8
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
also, under the IPv4 settings in the edit network settings menu, the connection method is set
to Automatic (DHCP)

i ran a ping test ping test and here were the results

zuvuya@zuvuya-MS-7309 ~ $ ping -c 127.0.0.1
Usage: ping [-LRUbdfnqrvVaAD] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface]
[-M pmtudisc-hint] [-m mark] [-S sndbuf]
[-T tstamp-options] [-Q tos] [hop1 ...] destination

thanks again for any advice you have to offer, i am truly stumped by this issue!
andrea
 
Old 08-28-2011, 03:02 PM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Quote:
Originally Posted by travellindaze View Post
zuvuya@zuvuya-MS-7309 ~ $ ping -c 127.0.0.1
Usage: ping [-LRUbdfnqrvVaAD] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface]
[-M pmtudisc-hint] [-m mark] [-S sndbuf]
[-T tstamp-options] [-Q tos] [hop1 ...] destination
well, 127.0.0.1 is the localhost, your own machine, this will always work if eth0 is really up. But the -c option needs a number (count), you should use
Code:
ping -c3 127.0.0.1
But this helps only to verify that the network-card is working.

You can as an alternative to enabling DHCP configure for a static IP-configuration and use exactly the settings of the "ipconfig /all" output from the Windows-machine.

Markus
 
Old 08-28-2011, 04:21 PM   #10
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
hi markus, thanks again for all your help!
ok, i did enter in the static ip information through the edit network connections
option. the computer now recognzies that there is an ethernet connection...yay!
however, i still cannot get online.

one issue that may be the cause is that i am unable to edit the MAC address in the edit
connection menu. the address it points to is

6C:62:6D:ED:BB:5C

if i try to edit by putting in the MAC address from my router, the save option goes away
and i cannot update it. do you think this may be the issue? any ideas on how to get around
it?
thanks so much again for all your help! i appreciate
your patience with me
 
Old 08-28-2011, 04:25 PM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
The MAC adress is static, you cannot change it.

If you have a correct IP-configuration but cannot get a connection, it maybe there's only the DNS-server missing. Please post the output of
Code:
cat /etc/resolv.conf
Markus
 
Old 08-28-2011, 04:36 PM   #12
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
well, all that comes up is

# Generated by NetworkManager

does that look right???
 
Old 08-28-2011, 04:41 PM   #13
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
well, there must be an entry in the form
Code:
nameserver 8.8.8.8
you can as well use the entry as it is in Windows which would be
Code:
nameserver 66.90.130.101
edit the file /etc/resolv.conf and place the line in the file.

Markus
 
Old 08-28-2011, 05:01 PM   #14
travellindaze
LQ Newbie
 
Registered: Aug 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
ok, i got to the etc file, and found the folder resolvconf
when i open it up, there is a file entitled update-libc.d and inside
that is a file in a format unfamiliar to me entitled avahi-daemon

where should i place the code you sent me? (sorry, this may be a stupid
question!)
 
Old 08-28-2011, 05:08 PM   #15
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
isn't there a file "resolv.conf" in the /etc folder?

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installed mint 10, cannot connect to wireless or wired internet connection vnag Linux - Newbie 3 03-04-2011 02:17 PM
Unable to Connect to Internet using Linux Mint. MexDeath Linux - Networking 8 08-13-2009 12:04 AM
Unable to connect to internet via ethernet after tweaking interfaces and hosts file ylawayjdp Linux - Newbie 2 02-27-2009 12:12 PM
Unable to connect to internet via ethernet xav.vijay Linux - Networking 3 06-06-2008 04:57 PM
unable to connect to internet with ADSL CONNECTION ashwin_cse Linux - Networking 2 11-13-2005 06:48 AM


All times are GMT -5. The time now is 06:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration