LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2015, 11:56 AM   #1
callowaa
LQ Newbie
 
Registered: Jan 2014
Posts: 2

Rep: Reputation: Disabled
Minimal Centos 6.6 Wifi can scan and see APs but will not connect to an AP


I am currently running a Minimal version of Centos 6.6 Ive searched all over the internet to see if anyone has seen this problem before. I can do a iwlist scan wlan0 and see my AP but it will not connect. I have encryption turned off. Ive tried to use a static and DHCP address in the ifcfg-wlan0 file. I used a laptop to verify that I am able to connecto to my AP and get an IP address so I know the AP is functioning properly.

any help would be appreciated.

Thanks

Running Centos 6.6 Minimal
WIadapter : ASUS USB-N13
Ive installed the following:
Wireless-tools
wpa-supplicant
dbus
r8192cu drivers
rtlwifi-firmware

********messages file has the following when I do a ifup wlan0:

[root@localhost log]# tail -f messages
Feb 10 11:46:54 localhost dhclient[1756]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x2a6a01ee)
Feb 10 11:46:54 localhost dhclient[1756]: send_packet: No such device or address
Feb 10 11:47:04 localhost dhclient[1756]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x2a6a01ee)
Feb 10 11:47:04 localhost dhclient[1756]: send_packet: No such device or address
Feb 10 11:47:14 localhost dhclient[1756]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12 (xid=0x2a6a01ee)
Feb 10 11:47:14 localhost dhclient[1756]: send_packet: No such device or address
Feb 10 11:47:26 localhost dhclient[1756]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13 (xid=0x2a6a01ee)
Feb 10 11:47:26 localhost dhclient[1756]: send_packet: No such device or address
Feb 10 11:47:39 localhost dhclient[1756]: No DHCPOFFERS received.
Feb 10 11:47:39 localhost dhclient[1756]: No working leases in persistent database - sleeping.
Feb 10 11:50:53 localhost dhclient[4075]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5 (xid=0x5128c82e)
Feb 10 11:50:58 localhost dhclient[4075]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7 (xid=0x5128c82e)
Feb 10 11:51:05 localhost dhclient[4075]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20 (xid=0x5128c82e)

--------------------------------

********When I do a ip link show wlan0:

[root@localhost dispatcher.d]# ip link show wlan0
11: wlan0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
link/ether ac:9e:17:5b:9d:8d brd ff:ff:ff:ff:ff:ff

----------------------------------

*********message log when I do a iwlist wlan0 scan:

Feb 10 11:54:21 localhost dhclient[1756]: send_packet: No such device or address
Feb 10 11:54:36 localhost kernel: _rtw_pwr_wakeup call ips_leave....
Feb 10 11:54:36 localhost kernel: ==>ips_leave cnts:1
Feb 10 11:54:36 localhost kernel: ===> rtw_ips_pwr_up..............
Feb 10 11:54:36 localhost kernel: ===> ips_netdrv_open.........
Feb 10 11:54:36 localhost kernel: ===> FirmwareDownload91C() fw:Rtl819XFwImageArray_TSMC
Feb 10 11:54:36 localhost kernel: FirmwareDownload92C accquire FW from embedded image
Feb 10 11:54:36 localhost kernel: fw_ver=v88, fw_subver=2, sig=0x88c0
Feb 10 11:54:36 localhost kernel: fw download ok!
Feb 10 11:54:36 localhost kernel: Set RF Chip ID to RF_6052 and RF type to 2.
Feb 10 11:54:37 localhost kernel: IQK:Start!!!
Feb 10 11:54:37 localhost kernel: Path A IQK Success!!
Feb 10 11:54:37 localhost kernel: Path B IQK Success!!
Feb 10 11:54:37 localhost kernel: Path A IQK Success!!
Feb 10 11:54:37 localhost kernel: Path B IQK Success!!
Feb 10 11:54:37 localhost kernel: IQK: final_candidate is 0
Feb 10 11:54:37 localhost kernel: IQK: RegE94=fe RegE9C=3ff RegEA4=fd RegEAC=3fa RegEB4=102 RegEBC=b RegEC4=fa RegECC=1
Feb 10 11:54:37 localhost kernel: Path A IQ Calibration Success !
Feb 10 11:54:37 localhost kernel: Path B IQ Calibration Success !
Feb 10 11:54:37 localhost kernel: pdmpriv->TxPowerTrackControl = 1
Feb 10 11:54:37 localhost kernel: rtl8192cu_hal_init in 560ms
Feb 10 11:54:37 localhost kernel: <=== rtw_ips_pwr_up.............. in 569ms
Feb 10 11:54:37 localhost kernel: ==> ips_leave.....LED(0x00028080)...
Feb 10 11:54:38 localhost kernel: survey done event(3a) band:0 for wlan0
Feb 10 11:54:40 localhost dhclient[1756]: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15 (xid=0x3d6d4ae3)
Feb 10 11:54:40 localhost dhclient[1756]: send_packet: No such device or address
Feb 10 11:54:41 localhost kernel: ==>rtw_ps_processor .fw_state(0)
Feb 10 11:54:41 localhost kernel: ==>ips_enter cnts:2
Feb 10 11:54:41 localhost kernel: ===> rtw_ips_pwr_down...................
Feb 10 11:54:41 localhost kernel: ====> rtw_ips_dev_unload...
Feb 10 11:54:41 localhost kernel: usb_read_port_cancel
Feb 10 11:54:41 localhost kernel: usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
Feb 10 11:54:41 localhost kernel: usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
Feb 10 11:54:41 localhost kernel: usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
Feb 10 11:54:41 localhost kernel: usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
Feb 10 11:54:41 localhost kernel: usb_write_port_cancel
Feb 10 11:54:41 localhost kernel: ==> rtl8192cu_hal_deinit
Feb 10 11:54:41 localhost kernel: bkeepfwalive(0)
Feb 10 11:54:41 localhost kernel: card disble without HWSM...........
Feb 10 11:54:41 localhost kernel: <=== rtw_ips_pwr_down..................... in 30ms
Feb 10 11:54:55 localhost dhclient[1756]: No DHCPOFFERS received.
Feb 10 11:54:55 localhost dhclient[1756]: No working leases in persistent database - sleeping.



-----------------------------------------------------


*********output from iwlist wlan0 scan:

Cell 03 - Address: FC:8F:C4:09:49:5C
ESSID:"ANT"
Protocol:IEEE 802.11b
Mode:Master
Frequency:2.422 GHz (Channel 3)
Encryption keyff
Bit Rates:11 Mb/s
IE: Unknown: DD9E0050F204104A0001101044000102103B0001031047001063041253101920061228FC8FC409495C1021001B5265616C74 656B2053656D69636F6E647563746F7220436F72702E1023000752544C387878781024000D45562D323031302D30392D3230 1042000F3132333435363738393031323334371054000800060050F20400011011000952544B5F41505F3278100800022688 1049000600372A000120
Quality=48/100 Signal level=91/100


---------------------------------------------------------

*******ifcfg-wlan0 ... please note you will see a bunch of #'s just trying different configs:

TYPE=Wireless
DEVICE=wlan0
ESSID=ANT
MODE=Managed
#MODE=Auto
#TYPE=Ethernet
NM_CONTROLLED=no
BOOTPROTO=dhcp
BROADCAST=192.168.100.255
NETMASK=255.255.255.0
IPADDR=192.168.100.10
NETMASK=255.255.255.0
#PREFIX=24
GATEWAY=192.168.100.1
RATE=auto
SECURITYMODE=off
RTS=auto
FRAG=auto
#DEFROUTE=yes
#IPV4_FAILURE_FATAL=yes
#IPV6INIT=no
#NAME=wlan0
UUID=3c9clabd-3ce0-4aea-304a-bf243b69e989
ONBOOT=no
ONHOTPLUG=yes
HWADDR=AC:9E:17:5B:9D:8D
PEERDNS=no
#PEERROUTES=yes
 
Old 02-10-2015, 02:45 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
the dynamic WIRELESS tools are in the desktop environments
( in the "Network Manager DE tools)
servers do not use wireless so it is not fully supported
install the default Gnome desktop
and your wireless will work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi card won't associate with certain APs zuzoa Linux - Laptop and Netbook 6 05-01-2014 08:25 PM
iwlist does not scan for APs on channel 12 & 13 Jorek Linux - Networking 1 04-05-2011 03:04 PM
How can I view wireless APs and connect to one? Brnzwngs Linux - Wireless Networking 1 07-26-2005 09:40 AM
Cannot scan for APs with my card mrboris Linux - Wireless Networking 0 05-18-2004 01:40 AM
WiFi w/ Mandrake 9.2: Multiple APs dlocalized Linux - Newbie 0 12-08-2003 08:41 PM


All times are GMT -5. The time now is 04:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration