LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-05-2004, 11:52 AM   #1
blink_00
LQ Newbie
 
Registered: Oct 2004
Distribution: Suse 9.2 OpenExchange 4.1 United Linux
Posts: 13

Rep: Reputation: 0
Migrated files are now all read only


I am gleefully switching as much stuff as I can away from windows and in our small office I installed Suse & Samba on a machine to be our storage server. Last nite after copying all my existing files over to samba I discovered that they now are all read only. Specifically the permissions on the files have been changed to Archived. So when I try and open an autocad file I get the msg.

Code:
The file you are trying to open is either in use  or locked...
Something along those lines..... My main workstations are XP Pro and I know that sometimes when trading files amongst themselves XP will set it to read only but I havenever seen "archive" before.

Is it possible to change the attributes globally on all files I have copied in?

Is this something that happened to the files once they arrived based on my smb.conf? And can I changed/add something to each folder so all users can modify? I have set up each folder that the files are in to chmod 777.

I am at a loss ....any ideas are much appreciated
 
Old 12-05-2004, 12:12 PM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,675
Blog Entries: 9

Rep: Reputation: 45
Re: Migrated files are now all read only

Quote:
Originally posted by blink_00
I am gleefully switching as much stuff as I can away from windows and in our small office I installed Suse & Samba on a machine to be our storage server. Last nite after copying all my existing files over to samba I discovered that they now are all read only. Specifically the permissions on the files have been changed to Archived. So when I try and open an autocad file I get the msg.

Code:
The file you are trying to open is either in use  or locked...
Something along those lines..... My main workstations are XP Pro and I know that sometimes when trading files amongst themselves XP will set it to read only but I havenever seen "archive" before.

Is it possible to change the attributes globally on all files I have copied in?

Is this something that happened to the files once they arrived based on my smb.conf? And can I changed/add something to each folder so all users can modify? I have set up each folder that the files are in to chmod 777.

I am at a loss ....any ideas are much appreciated
You seem to have found one of the more up to date problems (IMO anyway).

XP either pro or home, are usually formatted at NTFS. NTFS partitions usually end up as read only, because write access is still being worked on.

What you might have to do, is repartition, so that you also have a FAT32 partition. You'd then move/migrate the files there, and then you can do read/write stuff.

That seems to be how a lot of people are accomplishig that at the moment - there is stuff for direct write access, but I wouldn't know how stable it is yet

regards

John
 
Old 12-05-2004, 06:49 PM   #3
blink_00
LQ Newbie
 
Registered: Oct 2004
Distribution: Suse 9.2 OpenExchange 4.1 United Linux
Posts: 13

Original Poster
Rep: Reputation: 0
So you think it would work for me to create a fat32 partition , copy files there then migrate them to the Linux box. Its strange that they are only labeled Archive and yet thats enough to cause problems. I tried to access & change them from a win2k machine and it has no problems with the permissions. I can read from and save back to the linux box fine.....hmmm . So maybe this is an XP issue??
 
Old 12-15-2004, 12:45 AM   #4
blink_00
LQ Newbie
 
Registered: Oct 2004
Distribution: Suse 9.2 OpenExchange 4.1 United Linux
Posts: 13

Original Poster
Rep: Reputation: 0
Folder permissions fixed

Ok.....I solved the challenge. I have been able to acccess any/all the directory folders I had set up in smb.conf but was unable to save/open or change anything from my client machines running either 2000 or XP. After many hours googling I discovered this little gem regarding permission setting for the directory AND the files inside. Simply do a chmod 766 -R /folder (or 777...whatever )the important thing is the -R ...that gives the permission to write/modify the files located inside the directory. Just thought I'd pass that along
 
Old 12-15-2004, 10:55 AM   #5
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,675
Blog Entries: 9

Rep: Reputation: 45
Well done blink_00 you're better than me, I'd have still probably been sitting here scratching my ************ ?(ha, I'll leave that up to your imagination )

regards

John
 
Old 12-15-2004, 11:12 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
blink_00:

To avoid this problem in the future, you may want to change the create mask for your share in smb.conf
The create mask sets the default permissions for a file that is created on a share.

I believe this has nothing to do with NTFS write access, since all operations are going through the smb protocol.

This is from man smb.conf:
Code:
create mask (S)

    When a file is created, the necessary permissions are calculated according to the mapping from DOS modes to UNIX permissions, and the resulting UNIX mode is then bit-wise 'AND'ed with this parameter. This parameter may be thought of as a bit-wise MASK for the UNIX modes of a file. Any bit not set here will be removed from the modes set on a file when it is created.

    The default value of this parameter removes the 'group' and 'other' write and execute bits from the UNIX modes.

    Following this Samba will bit-wise 'OR' the UNIX mode created from this parameter with the value of the force create mode parameter which is set to 000 by default.

    This parameter does not affect directory modes. See the parameter directory mode for details.

    Note that this parameter does not apply to permissions set by Windows NT/2000 ACL editors. If the administrator wishes to enforce a mask on access control lists also, they need to set the security mask.

    Default: create mask = 0744

    Example: create mask = 0775
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mozzla problems-can not read files online, can not read attachments sarajevo Linux - Software 1 09-20-2005 07:58 PM
How program to read files with extension .dat y .cfg files COMTRADE in fedora 1? ivonne Linux - Software 0 11-22-2004 12:42 PM
Just Migrated from Windows to Linux Red Hat 9 and need help blufire Linux - Laptop and Netbook 7 07-13-2004 09:29 PM
Migrated Mandrake 9.2 to Kernel 2.6.5 jmynkbht Mandriva 0 04-06-2004 01:53 AM
M$ Migrated FROM BSD to Win 2000!! pnh73 General 1 10-27-2003 10:42 AM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration