LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-20-2003, 09:30 PM   #1
Mark_Grieveson
LQ Newbie
 
Registered: Nov 2002
Location: Toronto, Ontario, Canada
Distribution: SuSE Personal 8.1
Posts: 15

Rep: Reputation: 0
midi files


Hello. I cannot play midi files with applications such as NoteEdit, Timidity, or Kmid (Kmidi works, however). I have a Creative sound blaster Live! card. It plays CDs, wav files, ogg vorbis, MP3, etc. Midi is a real problem, however. I have SuSE 8.1 Personal edition. When I look at the Control Centre, Sound, Midi, it does not list any devices that I can use (I don't have external midi devices attached though). But, I wish to be able to play midi files, to write and edit midi files with NoteEdit, and I cannot seem to do this.
Any help would be appreciated.
 
Old 10-21-2004, 05:10 AM   #2
pranij
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 9.1
Posts: 15

Rep: Reputation: 0
Question

The same problem with me except midi does not work at all. i have suse 9.1 professional. the midi files run in windows xp but not in linux so i guess that probably means configuring the sound card in linux which i have no idea how to do. i'm really looking forward for some help...........and thanks in advance.

Last edited by pranij; 11-02-2004 at 06:20 PM.
 
Old 11-02-2004, 06:16 PM   #3
pranij
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 9.1
Posts: 15

Rep: Reputation: 0
Unhappy

hello anyone???
windows says it's SigmaTel C-Major Audio soundcard, and linux says 82801DB AC'97 Audio Controller . is anything else is needed? someone please help.
 
Old 11-05-2004, 12:39 PM   #4
Hawkeye_uk
LQ Newbie
 
Registered: Oct 2004
Location: Scotland
Distribution: Fedora Core 2
Posts: 5

Rep: Reputation: 0
midi playback

Hi guys im a sound tech so i hope this helps

With midi files you may or may not know that no actual sound is stored in the file its self. Its just a code for which note, instrument, channel, pan, effect yada yada

As such you need to have a device that already has each sound on it, e.g a sampler, not all sound cards have this feature i know the Creative SB Audigy pro has bit not if yours does.

If you are using a keyboard with a midi IN on it you can connect you keyboard to this and tell you sequencer that your midi out is going to your keyboard and you midi file will play thru your keyboard. its usually in setup but this varies from programme to programme.

Your sound card may have some limited instruments on it also if thats the case set up your sound card as the midi out device.

Your operating system whether linux or windows should not really change the way the file is proccessed (The biggest mistake people make is thinking of sound as sound wherever it is DONT think of it as an electrical signal that you have to direct to your speakers when it comes out the speakers then its sound!!!) nor the way your sound card treats it.

IF you set your midi system up with your keyboard as the midi out device this will bypass your sound card to a certain degree. It will still handle the signal and you have to tell it what its handling, but its not involved in processign the signal in to a listnable format, you keyboard will do that bit!!!

It can all be a bit confusing.

Finally i was having major difficultys setting up my midi system on windows (before i started using linux) and noticed in my advanced settings in the bios theres an option to enable or disable you midi capability. double check that its enabled

hope this helps
Hawkeye

Last edited by Hawkeye_uk; 11-05-2004 at 12:42 PM.
 
Old 11-05-2004, 01:49 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
HI,
i have the same card sound blaster live and i can play midi files sound with all apps i want so here i try to explain.

I will just start from the top even though some people seem farther than others.

i have a boot script that loads soundfonts using the utility sfxload
(get it if it's not there
the command i use is
/usr/local/bin/sfxload -D 0 /usr/local/lib/sfbank/CT4MGM.SF2
(the number after -D is the number of the sound card)

on shutdown
/usr/local/bin/sfxload -i

you can do this by hand

the file CT4MGM.SF2 is from my SB Live install disk there were two on there a 2MG and a 4MG
some people have a 8MG, your names may be different as well all end in .SF2 look in every folder on the disk.

you most likely have another utility "pmidi" if you don't get it
"pmidi -l" will show you the ports
mine says:
Code:
 Port     Client name                       Port name
 64:0     Rawmidi 0 - EMU10K1 MPU-401 (U    EMU10K1 MPU-401 (UART)
 65:0     Emu10k1 WaveTable                 Emu10k1 Port 0
 65:1     Emu10k1 WaveTable                 Emu10k1 Port 1
 65:2     Emu10k1 WaveTable                 Emu10k1 Port 2
 65:3     Emu10k1 WaveTable                 Emu10k1 Port 3
the first one is in and out raw midi port through the soundcards game port
the others are output using the loaded wave table
now:
pmidi -p 65:0 mysong.mid
should play !
the alsa mixer slider is "music"
amixer set Music 100
to get that going

if you have vkeybd (virual keyboard) attach it to midi in with (for me)
vkeybd -addr 64:0 -octave 5 &
to play your wave table
or just attach a real keyboard to the game port and sellect EMU10K1 MPU-401 (UART) as the midi input
in programms like muse
you can also use aconnect to hook stuff to gether like to hook a keyboard to aseqview
to see ports available for connection "aconnect -il" for input "aconnect -ol" for output
aconnect 128:0 73:0
as an example hooks sender port 128 to recieving port 73

Ok lastly someone mentioned timidity and other soft synths do not use you the cards wave table
so if like timidity they don't automaticall load their wave table you have to feed them one.
timidity has a configure file /usr/share/timidity/timidity.cfg
in it put one line
soundfont /usr/local/lib/sfbank/CT4MGM.SF2
or whatever other sf2 file you want to play with
and it will work
timidity also has a server mode to for instance make the soft synth available to a keyboard
/usr/bin/timidity -iA -B2,8 -Os &
starts the server and tells you what ports are open for connections

Oh yea someone said kmidi -- you have to set the output port in "Settings ->MIDI Settings".

go yea forth all and make funny computer music !

Last edited by foo_bar_foo; 11-05-2004 at 02:01 PM.
 
Old 11-05-2004, 07:25 PM   #6
pranij
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 9.1
Posts: 15

Rep: Reputation: 0
hi, thanks for the replies guys. however i am still not able to solve my problem. lets go through this slowly.

Quote:
Originally posted by Hawkeye_uk
As such you need to have a device that already has each sound on it, e.g a sampler, not all sound cards have this feature i know the Creative SB Audigy pro has bit not if yours does.
well, i think that mine has this feature. windows xp can generate sound so i guess linux should also be able to do it shouldn't it? i certainly use the same card.

Quote:
Originally posted by Hawkeye_uk
Your operating system whether linux or windows should not really change the way the file is proccessed.
this is exactly what i am hoping for.

Quote:
Originally posted by Hawkeye_uk
Finally i was having major difficultys setting up my midi system on windows (before i started using linux) and noticed in my advanced settings in the bios theres an option to enable or disable you midi capability. double check that its enabled
i have gone through my midi and i could not find this thing being disabled.

Quote:
Originally posted by foo_bar_foo
i have a boot script that loads soundfonts using the utility sfxload
(get it if it's not there
so how to get it? i dont seem to have it.

Quote:
Originally posted by foo_bar_foo
the command i use is
/usr/local/bin/sfxload -D 0 /usr/local/lib/sfbank/CT4MGM.SF2
typing /usr/local/bin/sfxload ...... gives me
bash: /usr/local/bin/sfxload: No such file or directory

typing "pmidi -l" gives me this:

Port Client name Port name
128:0 KAMix qamix

and then "pmidi -p 128:0 mysong.mid" gives me nothing.

so what else should i do?

Last edited by pranij; 11-05-2004 at 07:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot play MIDI files! koolgentoo Linux - Hardware 2 07-24-2005 08:26 AM
I need to play midi files... trey85stang Linux - Software 2 02-27-2005 12:06 PM
How to play MIDI files: needed a MIDI mapper? vharishankar Linux - General 3 12-30-2004 01:12 AM
Cannot play midi files... djib Linux - Laptop and Netbook 1 12-04-2004 08:46 PM
Reading midi files. gbowden Programming 2 08-07-2004 03:42 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration