LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-11-2011, 12:32 PM   #1
Blasphemous
Member
 
Registered: Nov 2011
Distribution: Debian testing XFCE
Posts: 50

Rep: Reputation: Disabled
Red face Microphone not working


Can't get my laptop integrated microphone to work.
I'm using Debian Squeeze Stable.

Here's my situation according to alsamixer:

http://img714.imageshack.us/img714/8991/schermatacd.png

http://img856.imageshack.us/img856/9718/schermata1t.png

http://img685.imageshack.us/img685/867/schermata2c.png

Ideas?
 
Old 12-11-2011, 02:57 PM   #2
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
hi,

please, post the results of the following commands:
Code:
arecord -l
and
Code:
cat /etc/modprobe.d/alsa-base.conf
What is the model of your laptop?

good luck..
 
Old 12-11-2011, 03:13 PM   #3
Blasphemous
Member
 
Registered: Nov 2011
Distribution: Debian testing XFCE
Posts: 50

Original Poster
Rep: Reputation: Disabled
Quote:
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Quote:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
I'm using a HP pavilion Dv5 1102el: http://h10025.www1.hp.com/ewfrf/wc/d...roduct=3841102

I have to say that, in a previous Debian installation, the mic worked fine!

Btw, thanks for your help..
 
Old 12-11-2011, 05:05 PM   #4
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
as root, edit your /etc/alsa-base.conf file with the text editor of your choice and add the following line
Code:
options snd-hda-intel model=hp-dv5
reboot and check your microphone...

Recently I had a similar problem and this solution worked for me...good luck!

FYI, you can find a complete guide to sound card related problems here.
 
Old 12-11-2011, 06:14 PM   #5
impert
Member
 
Registered: Feb 2009
Posts: 282

Rep: Reputation: 53
Hi,
I had a battle getting my mcrophone to work,so I made a note of the settings. Change the card to suit.

Recording_settings.txt
Hope this helps.
 
Old 03-26-2012, 08:10 PM   #6
jmlm_1970
Member
 
Registered: Nov 2010
Location: Aveiro, Portugal, Europe
Posts: 38
Blog Entries: 1

Rep: Reputation: 1
The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).
 
Old 03-27-2012, 03:26 PM   #7
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
I guess that linux-backports-modules-alsa-generic package is specific for Ubuntu: may work for that, but might not be suited for Debian...
Quote:
Originally Posted by jmlm_1970 View Post
options snd-hda-intel model=auto enable=yes
why "auto" when the model is known!??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone not working andrewc54 Linux - Hardware 8 03-26-2012 08:03 PM
microphone not working answerme Linux - Newbie 4 06-11-2008 12:31 AM
Microphone not working. jadex Linux - Hardware 8 04-04-2007 10:45 AM
Microphone not working Ashrack Linux - Software 0 09-01-2006 07:48 AM
microphone not working Abrocadabro Debian 1 12-03-2004 01:37 AM


All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration