LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Memory for crash kernel (0x0 to 0x0) notwithin permissible range (http://www.linuxquestions.org/questions/linux-newbie-8/memory-for-crash-kernel-0x0-to-0x0-notwithin-permissible-range-785024/)

casualzone 01-27-2010 05:01 AM

Memory for crash kernel (0x0 to 0x0) notwithin permissible range
 
I installed CentOS 5.4.. I saw this message:
Memory for crash kernel (0x0 to 0x0) notwithin permissible range

Is it ok?
I google around it said that it is a known issue and harmless.


I installed CentOS 5.2 before. It was ok. Kernel is 2.6.18 too. Just wonder why

Kernel version:
Linux phot1-nec4 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Agrouf 01-27-2010 05:19 AM

Hello,
I have this message too on my critical production servers since one year at least. No problem here. Red Hat said it is harmless.

Fracker 11-15-2010 02:00 AM

Well, one of my critical server is doing anything after this message, what should i do?

DucQuoc 12-06-2011 09:24 PM

I'm not sure if I should resurrect the topic, but for the ppl who met the similar problem to Fracker you can try either:

* Edit the GRUB boot menu to remove the "quiet" option in the line "kernel ..." , save it.
* If it's running inside a VM, enable the "APIC support" (IO-APIC) from the configuration.

Then next reboot may solve the issue :) .

hth,
Quote:

Originally Posted by Fracker (Post 4159080)
Well, one of my critical server is doing anything after this message, what should i do?


devUnix 12-07-2011 12:24 AM

During installation if Dump Memory/Storage is created then the message would not show up. It is ignorable.

Passmossis 12-07-2011 01:20 PM

I've done some research on this message as I have it on all of my RHEL 5.X systems. This is only an error if you are utilizing kdump, as kdump would need a sizable amount of allocated memory. If you are not using kdump, this alert does not apply to you.

A large number of people have spent time, including myself, researching this issue only to find it is not an issue for them.


Reference information:
https://bugzilla.redhat.com/show_bug.cgi?id=431584

I hope this helps.

grim76 12-07-2011 08:30 PM

This error is in regard to the crashkernel=xxx@yyy parameter on the grub boot line.

You can fix this by editing the line and changing it to crashkernel=128M or crashkernel=256M Those values have worked well in the environment I am in.

Also you will want to configure /etc/kdump.conf and uncomment the line that works for your configuration. In the event that you do not want kdump you can remove the crashkernel value from the grub line without issue.


All times are GMT -5. The time now is 04:05 AM.