LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2013, 05:08 PM   #1
Soapm
Member
 
Registered: Dec 2012
Posts: 180

Rep: Reputation: Disabled
Mdadm


The emails from my raid array keep going to root@gmail.com and for the life of me I can't figure out how to stop this. I am using exim4 on a Wheezy box. I added an email address to the /etc/mdadm/mdadm.conf and it made no difference.

To test the emails I read to use this command

Code:
mdadm –monitor –scan –test
But when I do I get this error

Code:
An option must be given to set the mode before a second device
Man this is frustrating, can someone point me in the right direction? What is the error trying to tell me? I wish it was more informative. I've read man mdadm until I'm cross eyed and I have no idea what it means by "an option must be given" since the guide is full of options??? WTF??? What kind of option? What's an example of an option that it's looking for?
 
Old 06-11-2013, 05:51 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,609

Rep: Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702
Most likely you have a wildcard rule in exim which is converting mail for foo to foo@gmail.com. Check your config.

If you had shown the full error message instead of the first line it would be more obvious.
Code:
mdadm: An option must be given to set the mode before a second device
       (–scan) is listed
It's telling you it thinks you are calling out a device named -scan because command options to mdadm require two dashes.
 
Old 06-11-2013, 06:29 PM   #3
Soapm
Member
 
Registered: Dec 2012
Posts: 180

Original Poster
Rep: Reputation: Disabled
yes, this is my exim4 alias file but it doesn't seem to work either. So what I did to compensate was put email addresses in all the files that send notifications.

Quote:
# /etc/aliases
mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
root: chuck
chuck: ME_@gmail.com
Also, I read the entire error message and how you gut using two dashes out of that is beyond me??? To dashes does work but there are several website with the command having one dash and it makes me scratch my head why people say use google first, since I rarely if ever find anything that's right using google and since I'm new to Linux, I don't know it's wrong until someone like you explains the correct way.

Thanks for the help.
 
Old 06-12-2013, 09:08 AM   #4
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,609

Rep: Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702
I used the secret man mdadm command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Attempts to work around a mdadm bug/ mdadm cannot get exclusive access to /dev/md127 Sereph Linux - Newbie 1 08-16-2011 04:21 AM
MDADM screws up the LVM partitions? Can't mount the LVMs after mdadm stopped alirezan1 Linux - Newbie 3 11-18-2008 05:42 PM
unable to load MDADM module BUT mdadm works?!?!?! alirezan1 Linux - Software 2 09-08-2008 08:58 PM
mdadm says "mdadm: /dev/md1 not identified in config file" when booting FC7 raffeD Linux - Server 1 08-11-2008 12:47 PM
do you know mdadm? Coldburn Linux - Newbie 1 08-31-2004 03:22 PM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration