LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2005, 12:06 PM   #1
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Rep: Reputation: 15
Mandriva won't turn off computer


Hi, I have a shutdown problem with Mandiva, when I shut down it won't turn off the computer, I had the same bother with Mandrake 10. can you help? Adrian
 
Old 06-06-2005, 12:13 PM   #2
visaris
Member
 
Registered: Dec 2004
Distribution: gentoo
Posts: 190

Rep: Reputation: 30
This sounds like you have a motherboard that doesn't support ACPI (Advanced Configuration and Power Interface) or your kernel does not support ACPI.. Maybe someone else knows how to check / turn this on?
 
Old 06-06-2005, 12:18 PM   #3
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
first thing you wanna do is determine whether your board uses APM or ACPI for power management... which is it??
 
Old 06-06-2005, 01:38 PM   #4
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
Linux can't shut down the PC without a power management module, it just doesn't know how.

Mandriva has an option in the Control Center (under Boot Options, I believe) to enable acpi when booting. If you don't have apm turned on already (`lsmod` should tell you which modules you have already), try enabling acpi and see how it goes. Don't use both of them, though - they don't play nicely together, from what I've seen on google.

...One of these days I'll get around to fixing this for myself, too...
 
Old 06-06-2005, 05:00 PM   #5
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
acpi

Hi, I tried acpi, and it asked for a cd and reset my boot menu, but still wouldn't shut down.( I should explain: I have spent the past 3 days on the General forum trying to add Mandriva to my boot menu ) I have 2 Hard drives one with XP and Mandriva and one with XP and Suse. I got it all back but had to repair Suse and edit the grub file menu.
I did read an article a few weeks ago with a similar problem, I think they're advice was a bios fix,out of my depth on that one. thanks for your help, Adrian
just to mention suse 9.2 shuts down ok
 
Old 06-06-2005, 05:06 PM   #6
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Re: acpi

Quote:
Originally posted by obstinatesod
just to mention suse 9.2 shuts down ok
post the output of these commands from the suse installation:
Code:
ps aux | grep acpi
Code:
lsmod | grep apm

Last edited by win32sux; 06-07-2005 at 09:12 AM.
 
Old 06-07-2005, 03:17 AM   #7
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
acpi/apm

Hi , this is what I got when I typed in your code:

aaria5@linux:~> su
Password:
linux:/home/aaria5 # ps aux | grep acpi
root 6 0.0 0.0 0 0 ? S< 07:36 0:00 [kacpid]
root 5266 0.0 0.0 1388 532 ? Ss 07:37 0:00 /usr/sbin/acpid -c /etc/acpi/events.ignore
root 6747 0.0 0.0 2604 704 pts/1 S+ 08:13 0:00 grep acpi
linux:/home/aaria5 #
linux:/home/aaria5 # lsmod | grep apm
linux:/home/aaria5 #
I didn't get anything when I typed: lsmod | grep apm
 
Old 06-07-2005, 09:23 AM   #8
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
what bootloader are you using?? i assume it's been installed from the suse installation, right?? make sure there's an "acpi=on" appended to the section for mandrake... go ahead and post the conf file if you want the thread subscribers to have a look...
 
Old 06-07-2005, 01:19 PM   #9
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
conf file

Hi, Mandriva loaded Lilo by default, I then had to change it to Grub so that I could add it to the Suse Grub boot menu. But the problem was the same when I only had Manrake running, it goes through the shutdown proccess but at the last step to turn off it makes the bios noise but stays on. Q, where and how do I get the conf file?and what is the conf file? (enjoying this but very new) thanks Adrian
 
Old 06-07-2005, 01:34 PM   #10
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Re: conf file

Quote:
Originally posted by obstinatesod
Hi, Mandriva loaded Lilo by default, I then had to change it to Grub so that I could add it to the Suse Grub boot menu.
i'm not sure what you mean here...

Quote:
But the problem was the same when I only had Manrake running, it goes through the shutdown proccess but at the last step to turn off it makes the bios noise but stays on.
yes, that's normal for an acpi board when the acpi daemon isn't running or for an apm board when the apm module isn't loaded... in your case it's acpi, so your objective is to get the acpid running on startup... that is done by adding the "acpi=on" option to the respective line in your bootloader's conf file...

Quote:
where and how do I get the conf file?and what is the conf file?
a conf/config file is any file that stores configuration details... in this case it's your bootloader's conf file... since your bootloader is GRUB, the conf file will probably be /etc/grub.conf... but you need to determine whether you are using the grub from the suse install or the one from the mandrake install, as you can't be using both at the same time... once you know which you are using then you can post the conf file here and we'll show you how to edit it... to post it here just post the output of:
Code:
cat /etc/grub.conf
 
Old 06-07-2005, 02:41 PM   #11
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Hi sorry for not being clear, try this link it will explain far better than I can http://www.linuxquestions.org/questi...1&goto=newpost that I have 2 drives with 4 operating systems, to get both Linux's to work on a boot menu I had to make both loaders either Lilo or Grub,(with a lot of help from your associates)

this is what I got from Mandriva with the code you gave me:
[aaria5@localhost ~]$ su
Password:
[root@localhost aaria5]# cat /etc/grub.conf
cat: /etc/grub.conf: No such file or directory
[root@localhost aaria5]#

and this is what I get from Suse 9.2:
aaria5@linux:~> su
Password:
linux:/home/aaria5 # cat /etc/grub.conf
root (hd1,5)
install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (hd0) /boot/grub/stage20x8000 (hd1,5)/boot/grub/menu.lst
quit
linux:/home/aaria5 #
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off the computer Alan Lakin Yoper 9 12-07-2004 04:00 AM
turn off computer spidna Slackware 2 08-12-2004 01:18 PM
How to turn off computer ginnytwo Linux - Software 10 07-27-2004 02:13 AM
computer won't turn off Marty McFly Linux - Newbie 2 10-28-2003 12:30 PM
Turn off the computer mtb Linux - Newbie 1 11-25-2002 03:56 PM


All times are GMT -5. The time now is 04:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration