LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-30-2006, 11:28 AM   #1
rolnics
LQ Newbie
 
Registered: Dec 2006
Location: U.K.
Distribution: Ubuntu & Debian
Posts: 15

Rep: Reputation: 0
Mandriva One


Well, I've taken the plunge and installed mandriva one 2007, great! Everything is working fine except for 2 things, sound and net connection.

The sound is weird its sounds like really bad static noise all the time, my solution is mute it! If I had a net connection I would try to find some updated drivers maybe?

The other problem and most annoying of all is the net connection! I would assume that it has a connection as I was able to create a user account with mandriva?! But when I try to browse the connection times out! I've used the wizard to setup the connection the final screen says congrats connection setup and then it says something about restart X environment. What is X environment and how do I restart it??
 
Old 12-30-2006, 11:39 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
Quote:
What is X environment and how do I restart it??
The X server is the code that displays your gui interface. As most things in linux, it is an option to start it. To terminate a running x server the 3 hot key of Ctrl + Alt + Backspace will kill it on most systems. Note this does not kill linux, just the gui. To start it from the command line, 'startx' ( without quotes will work.

Your network connection. To get the best help with the fewest messages, please tell us as much as you can about the connection. Is it ethernet connected to a modem? Is it a dial up connection? If yes, tell us as much as possible about the modem, internal or external, driver you are using if it is a win modem. We can't help until we know what we are trying to get working.

Sound, post the results of 'lspci' from the command line. If you know what sound card, or chip set you have post that. Also post the results of the command 'lsmod | grep snd' ( all commands without quotes ).

Since your internet connection is not working under linux, it is most likely the best place to start.
 
Old 12-30-2006, 12:46 PM   #3
rolnics
LQ Newbie
 
Registered: Dec 2006
Location: U.K.
Distribution: Ubuntu & Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by camorri
Your network connection. To get the best help with the fewest messages, please tell us as much as you can about the connection. Is it ethernet connected to a modem? Is it a dial up connection? If yes, tell us as much as possible about the modem, internal or external, driver you are using if it is a win modem. We can't help until we know what we are trying to get working.
Sorry should have posted it that!! doh!

My ISP is Tiscali and I'm using a Netgear DG632 using the ethernet connection, I've just tried resetting the modem and installing through Netgear setup page no success there! I've also pinged the ip of the modem and that seems fine, but being new to linux it's a mare!!!
 
Old 12-30-2006, 03:41 PM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
I had a look, and this Netgear device is a modem/router as far as I can tell.

As I understand it, you have a windoze system and that works. We need to determine a few things. First of all does your linux system get a valid ip address form the router. ( I'm guessing you are running DHCP ) if not, please tell me what the IP address of the router is, the side that connects to your system, and the IP static address you configured into linux.

To validate that, open a konsole and run the following command, and paste copy the results here. '/sbin/ifconfig' ( without the quotes ). I would expect you would see a device called eth0.

Have a look in your /etc/resolv.conf file. Here you should find valid DNS addresses for your ISP. Some routers will store and forward this to any connected PC. You can compare it to what you see in windoze. You could also ask your ISP for the correct addresses.

You can see how your ehternet card is configured by looking in the file
/etc/sysconfig/network-scripts/ifcfg-eth0 if your ethernet card is in fact eth0.

Last thing, your default route should point at your router, that is the ip address of the router on your side, not the side that connects to your ISP.

Do you know how to connect to the router to look at its configuration? Most of them you open a web browser, and enter the IP address of the router ( yoru side not the ISP side ). Most have a default user and password. BTW, you should change that once you know what you are doing.

Let me know how far you can get, and post questions if I have not been clear enough, or assumed the wrong thing.
 
Old 12-30-2006, 05:21 PM   #5
rolnics
LQ Newbie
 
Registered: Dec 2006
Location: U.K.
Distribution: Ubuntu & Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by camorri
I had a look, and this Netgear device is a modem/router as far as I can tell.
Yep! You've done your research then! lol

Quote:
Originally Posted by camorri
As I understand it, you have a windoze system and that works. We need to determine a few things. First of all does your linux system get a valid ip address form the router. ( I'm guessing you are running DHCP ) if not, please tell me what the IP address of the router is, the side that connects to your system, and the IP static address you configured into linux.
That is the default 192.168.0.1

Quote:
Originally Posted by camorri
To validate that, open a konsole and run the following command, and paste copy the results here. '/sbin/ifconfig' ( without the quotes ). I would expect you would see a device called eth0.
And from that I get the following :-
eth0: Link encap: Ethernet HWaddr:00:50:8D:A8:2D:AE
inet addr:192.168.0.2 Bcast: 192.168.0.255 Mask: 255.255.255.0
inet6 addr: fe80::250:8dff:fea8:2dae/64 Scope: link

UP BROADCASTING RUNNING MULTICAST MTU:1500 metric:1
Rx packets:16 errors:0 dropped:0 overruns:0 frame:0
Tx packets:38 errors:0 dropped:0 overruns:0 carrier:0
collisons:0 txquelelen:1000

Rxbytes:5099 (4.9 KiB)
Txbytes:5662 (5.5 KiB)
Interrupt:22 base address:0x8000


Lo: local:loopback
inet addr:127.0.0.1 255.0.0.0
inet6 addr::1/128 scope:host
uploopback mtu:16436 metric:1
rxpack 13
tx pack 13

Rxbytes:708 (708.0 b)
Txbytes:708 (708 b)


Quote:
Originally Posted by camorri
Have a look in your /etc/resolv.conf file.
All that had in it was nameserver = 192.168.0.1

Quote:
Originally Posted by camorri
You can see how your ehternet card is configured by looking in the file
/etc/sysconfig/network-scripts/ifcfg-eth0 if your ethernet card is in fact eth0.
That had in it
Device=eth0
bootproto=dhcp
onboot=yes
metric=10
mii_not_supported=no
usercrtl=no
resolvemods=no
ipv6init=no
dhcp_client=dhclient
needhost name=yes
peerdns=yes
peeryp=yes
peerntpd=no

Quote:
Originally Posted by camorri
Last thing, your default route should point at your router, that is the ip address of the router on your side, not the side that connects to your ISP.

Do you know how to connect to the router to look at its configuration? Most of them you open a web browser, and enter the IP address of the router ( yoru side not the ISP side ). Most have a default user and password. BTW, you should change that once you know what you are doing.

Let me know how far you can get, and post questions if I have not been clear enough, or assumed the wrong thing.
Yeah that's the 192.168.0.1 ip. I wonder why you suggest that I change that????!!!

I hope that makes sense to you, cos it doesn't to me yet!!! And I hope that I have copied it down ok, as I was getting writers cramp after that lot!!! lol
 
Old 12-31-2006, 07:18 AM   #6
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
Quote:
Yeah that's the 192.168.0.1 ip. I wonder why you suggest that I change that????!!!
Sorry if I gave you the impression that I thought you should change the IP addressing of your router. There is nothing wrong with the addressing on the router, and your system gets a good IP address.

The single problem I see is:

Code:
All that had in it was nameserver = 192.168.0.1
Unless this Netgear router is different than most I have see, linux does not have valid IP addresses for yoru ISP's name servers.

My router passes my linux system, and any other PC I add to the network, the DNS addresses when DHCP happens. You should be able to connect to your router, and see the configuration. In there, somewhere, you should be able to find the nameserver addresses. See if you can find them, edit the /etc/resolv.conf file, and add the nameserver addresses. That should get you going.

If you can not find the addresses, your ISP's support should be able to tell you what they are. Don't tell them it is a linux system, they'll probably give you th e standard line... " we don't support linux " which translated means " we don't know anything about linux... "

Let us know how it goes.
 
Old 12-31-2006, 08:56 AM   #7
rolnics
LQ Newbie
 
Registered: Dec 2006
Location: U.K.
Distribution: Ubuntu & Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks camorri for all your help on this! I'm now typing this from my linux setup!!

I tried the editing of the resolv.conf but that didn't seem to work, so I went through the wizard again on the ethernet connection and opted for manual settings, and entered the DNS for my ISP, which I noted from my windows setup and hey presto I'm online!!

Now for the sound issues hey?! I'm running a Sound Blaster Audigy ex and a Yamaha SW1000xg, I always have my headphones plugged in the sound blaster

lspci reported the following:-
00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge (rev 11)
00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge (rev 11)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4200] (rev a3)
02:00.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
02:00.1 Input device controller: Creative Labs SB Audigy Game Port (rev 03)
02:00.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port
02:01.0 Multimedia audio controller: Yamaha Corporation Unknown device 1000
02:05.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
02:05.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
02:05.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


I tried lsmod first, but got the error message bash lsmod:command not found, so from reading other topics I typed /sbin/lsmod | grep snd which returned the follow, I hope that's right??

snd_seq_dummy 3492 0
snd_seq_oss 29312 0
snd_seq_midi_event 7008 1 snd_seq_oss
snd_seq 46832 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 39040 0
snd_mixer_oss 15264 1 snd_pcm_oss
snd_emu10k1 106944 1
snd_rawmidi 19360 1 snd_emu10k1
snd_ac97_codec 91524 1 snd_emu10k1
snd_ac97_bus 2816 1 snd_ac97_codec
snd_pcm 66148 3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_seq_device 7052 5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer 18916 3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc 8328 2 snd_emu10k1,snd_pcm
snd_util_mem 4224 1 snd_emu10k1
snd_hwdep 7332 1 snd_emu10k1
snd 44452 13 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq _device,snd_timer,snd_hwdep
soundcore 7808 1 snd
 
Old 12-31-2006, 10:46 AM   #8
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
You are learning fast. I'm glad you got the network connection working. You should have been able to edit /etc/resolv.conf as root, not as a regular user. If not, do a ls -l /etc/resolv.conf and look at the permissions, who wons the file. Since it is working now, just leave it alone. ( If it ain't broke, don't fix it...)

Sound... You seem to have the correct sound driver loaded for the Sound Blaster Audigy. snd_emu10k1 is the driver listed at here :

http://www.alsa-project.org/alsa-doc...ve_Labs#matrix

I could not find a driver listed for the Yamaha card.

You are past the most common hurdle, no sound driver, or wrong sound driver loaded. At this point I can only guess at what might be causing the choppy sound. An interrupt conflict is possible. PCI bus cards can share IRQ's. If you get a situation with two devices fighting for system service, you can get choppy sound. I have seen a few posts with this as the problem. The fix is to figure out what IRQ this card is using, and change it, so it is the only device using an interupt. Usually done with system BIOS. Newer systems use a 'plug and play BIOS', should be called plug and pray... Plug and play can use IRQ sharing. It may be possible to turn off plug and play.

I think the first thing I would try is to pull out the Yamaha card and try again. This is just a guess, but it is worth a try.

If that doesn't help, I hope someone else has some thoughts...
 
Old 12-31-2006, 11:14 AM   #9
rolnics
LQ Newbie
 
Registered: Dec 2006
Location: U.K.
Distribution: Ubuntu & Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Thumbs up

Yes, i shall leave well alone!!! as it works!!!

I thought the soundcard drivers were right, I'll try taking out the other card at some point . . . in the future!

But once again thanks for your help on getting me up and running with the net I was getting very frustrated at rebooting and answering thing via windows!

Now i must doing some learning! Know any good linux books! lol
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
does Mandriva work with Asus P5WD2 mobos and is Mandriva free? asilentmurmur Mandriva 2 08-12-2006 05:41 AM
Mandriva 2006 - Greeting mail message from mandriva can't be removed JBailey742 Linux - Software 1 03-27-2006 03:55 AM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration