LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-25-2009, 02:06 AM   #1
eschrock
Member
 
Registered: Mar 2009
Posts: 34

Rep: Reputation: 15
Mandriva hangs on boot


Hi,

I recently had to manually shutdown my Mandriva 2009 box after it froze while I was attempting to switch users. Now, no matter what boot option I use, except for safe mode, Mandriva will load a bunch of stuff, go through some Network things (snort, etc), and then freeze after "Starting wine... [ OK ]". I am very new to linux, and don't really know where to begin with this. I realize that I haven't given much detail, but that's because, well, I don't know what details are important. Ask me about what you need to help me, because I really have no clue what could be causing this.

Please help!
 
Old 03-25-2009, 10:03 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
You may have defined your problem, "Starting wine..." and things freeze. This is not an easy problem to define.

First of all, how long are you waiting to see if it stays "frozen"?

Here is a very good list of things to do to try and avoid the reset, power off type fix.

http://mandrivausers.org/index.php?showtopic=24558

Have a look through that thread, and post back with what you can get it to do.

Will ctrl + alt + F1 give you a command prompt? If yes, have a look at 'dmesg' for errors. You could also have a look at the system logs.
 
Old 03-25-2009, 04:31 PM   #3
eschrock
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 15
Ok. Ctrl-alt-f1 drops me into a command prompt no problem. I checked dmesg, and it gave me a bunch of network setup stuff. The last few things were

device eth0 entering promiscuous mode
device eth0 exiting promiscuous mode
device eth0 entering promiscuous mode

and then nothing. The nice thing about it 'hanging' in this way is that i can press the power button and it will shutdown nicely. It seems like it is just waiting for something, rather than running into an error somewhere.

Can you tell me how to check the system logs? Since it seems to have to do with configuring network connections, I feel like if I can get it to skip whatever it is having a problem with on boot and get to my desktop, I can setup network connections again and possibly avoid this. What do you think? I'm just guessing so... also, could you tell me how i would go about 'skipping' whatever it's having trouble with at boot?

Thanks again!
 
Old 03-26-2009, 09:34 AM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Since you can get to a command prompt, your system is not frozen. That is a good thing.

Quote:
Can you tell me how to check the system logs?
Get to the command prompt. Log as root, and go to directory /var/log/ You will find your log files there. There should be one called 'syslog' You can view the log file with the 'cat' command. So as root, 'cat /var/log/syslog'. The file should output to you screen. Have a look at the end of the log, that is the most probable location for errors.

If you want to scan the entire log, try 'cat /var/log/syslog | less' You can then use the page up and page down keys to browse for errors. Or if you want to just see the errors 'cat /var/log/syslog | grep error' will do it. All commands without the quotes.

It may be your ethernet interface also. You can configure the interface if you can use the vi or vim editors. vim is a little easier than vi, it has a help facility. The file for eth0 will be -

Quote:
/etc/sysconfig/network-scripts/ifcfg-eth0
on a Mandriva system. If the interface has a different name, then change the ifcfg-eth0 part to ifcfg-whateveritis.

To check the status of the interface, run the command 'ifconfig' as root. It will dump out the status of all defined interfaces. If the interface is not up, then run 'ifconfig eth0 up' and see what happens.

Hope this helps...
 
Old 03-27-2009, 02:45 AM   #5
eschrock
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 15
So, nothing out of the ordinary, it seems... the only error in syslog and dmesg was 'DSDT.aml not found' which is apparently harmless.

Checking ifconfig, it looks like eth0 is up and running, the only odd thing being the entry "Interrupt: 19 Base address:0x200" at the end of it, which was different from the other network connections. But when I google that it doesn't seem out of the ordinary either.

The last few entries in the syslog were something like "CMD (usr/share/stuffidontremember/promisc_check.something)". There were about four of those. Could that be the problem? Googling gives a thread about VMware:

http://communities.vmware.com/thread/64096

which kinda seems similar in that the writer believes that eth0 is causing a hang by alternating between promiscuous and not. I don't know though. Do you think something is going on there? Is there any way to make it skip this part on boot so I can get past whatever the problem is?

Thank you again, I really appreciate the time you've spent helping me already.
 
Old 03-27-2009, 09:10 AM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
The IRQ and base address can change, they are assigned. If you can do a ping, and it works, then I would forget the ethernet interface.

Earlier you mentioned Wine. One thing I would try is to disable it, and see if that is the cause.

Are you running VM ware?

I don't have a lot of experience with solving issues with init scripts. I do know at points in the boot process you switch run levels. In each level your system will run scripts to get things going.

I hope someone can chime in and give some help with how to debug this... Logs and dmesg have not pointed at anything in particular.
 
Old 03-28-2009, 02:18 AM   #7
eschrock
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 15
Thank you!

Can you tell me how to disable wine? And how to check if I actually am running VM ware? And do you know who I could talk to about init scripts?
 
Old 03-28-2009, 06:03 AM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
Can you tell me how to disable wine?
I'm not an expert here. I will post what my understanding is, hopefully this may lead you to a solution.

Open a konsole, and go to /etc/rc.d directory. If you do an 'ls' command, you should see something like this.

Quote:
/etc/rc.d ls
init.d/ rc0.d/ rc2.d/ rc4.d/ rc6.d/ rc.local* rc.sysinit*
rc* rc1.d/ rc3.d/ rc5.d/ rc.alsa_default*
Your system can run in various run levels. Safe mode is one of them. Regular desktop operation, where you want to get to is another. ( I think it is run level 5 ) Shutdown is another. O.K. if you look at the listing, your will see directories for rc0.d to rc5.d ( six run levels ). You will see three other files, rc, rc.local and rc.sysinit.

This is the area I know least about. Which one gets control, and in what order. I do know if you want to modify your system, say you want to always run a command, at boot time, you can add the commands to rc.local. ( intended for the user to modify ).

When your system starts, as you enter say run level 5, the system runs what is in the rc5.d directory. If you look there, there are a bunch of sym links to stuff in init.d.

Now go to init.d, look there. Here you find the scripts that do the work.

So the short way to stop anything during booting would be to remove the init script for that function. Don't just erase the file. I would copy it to some place else, so you could put it back later, it that does not get you up all the way. I would remove the sym link in the rc5.d the same way. If you don't, the system is sure to choke, if it finds a sym-link to a non existent file.

Track exactly what you are doing here, write it down. You may need to reverse your way back out. You have the possibility of borking your system, worse than it is now.

If this doesn't work, my last suggestion is to go here-->http://www.linuxquestions.org/ join that board, and post the problem. There are people there that know mandy far better than I. The knowledge of the run init scripts should be there.

Sorry for the long post, but that is my best advice at this point.

If you were running VMware, you would know it. It is a 'virtual machine' for booting other systems.

It might help you if you scanned through the man pages for 'init' and 'runlevel' You can switch runlevels with the init command.

Last edited by camorri; 03-28-2009 at 06:21 AM.
 
  


Reply

Tags
boot, hang, mandriva


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva One hangs at boot mhl Mandriva 3 03-12-2009 06:53 AM
Mandriva Flash 4GB - Boot Hangs lpanala Linux - Laptop and Netbook 1 06-01-2007 11:52 AM
Mandriva 2006 - eth0 hangs during boot; then fails; have to reconnect manually JBailey742 Linux - Software 11 04-01-2006 02:51 PM
Mandriva install hangs at boot NF4 Lordservant Linux - Hardware 2 02-14-2006 01:50 PM
Mandriva LE 2005 hangs on boot up gamito Mandriva 22 10-08-2005 06:19 AM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration