LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2003, 08:42 AM   #1
xilent
LQ Newbie
 
Registered: Dec 2002
Location: Dundee, UK
Distribution: debian GNU/Linux
Posts: 27

Rep: Reputation: 15
Unhappy Mandrake Problems


Hi,

Ive been using Linux for a month or so now and im really just experimenting with the different distros, ive recently installed Mandrake 9.0, everything works fine except i cant connect to the net, im using a 1Mb/s cable connection with my cable modem connecting to my onboard Realtek 8100 Lan , every other OS works fine, from what i can tell Mandrake is identifying this as a Realtek 8139 which is part of the 810x family, does anyone have any ideas how i can rectify this????

Cheers

Xilent
 
Old 03-11-2003, 09:56 AM   #2
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
According to this page -
http://www.tux.org/hypermail/linux-e...-Oct/0002.html
It uses the same driver as the 8139c card. So, have you tried lsmod as root to see which modules are running? Also, how do you know your web connection isn't running? Have you tried pinging your router/modem?
 
Old 03-11-2003, 02:56 PM   #3
xilent
LQ Newbie
 
Registered: Dec 2002
Location: Dundee, UK
Distribution: debian GNU/Linux
Posts: 27

Original Poster
Rep: Reputation: 15
yeah the connection is running as i pinged the modem and also entered into the modem config, Mandrake has identified the LAN card as the right one and loaded the RTL8139 module but i just cant get any traffic from the internet,

????

stumped,

when i installed xandros that auto configs and works straight away, as did suse, red hat, and lycoris,


stumped!!!!!!
 
Old 03-11-2003, 03:34 PM   #4
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Looks like you need to go into the Mandrake Control Centre, and Set up your Connection. Have you tried that yet?

If you have, and it's no dice, edit files by hand. If you can ping, it looks like your /etc/resolv.conf file needs your isp's dns servers in. Here's my file -

# search athlon.xp.carl
search athlon.xp.carl
nameserver 158.43.240.4
nameserver 158.43.240.3


# ppp temp entry


Obviously, your hostname will be different, as will your dns servers, but mine should work for you, anyway. If in doubt, contact your isp for their server numbers.
 
Old 03-11-2003, 03:38 PM   #5
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
In the MCC, can you change the settings for the firewall (Shorewall) without them returning when you reopen the MCC?
If you cant change them, try a working firewall(iptables) gui like Guarddog or Firestarter to properly control network access.
 
Old 03-12-2003, 07:00 AM   #6
xilent
LQ Newbie
 
Registered: Dec 2002
Location: Dundee, UK
Distribution: debian GNU/Linux
Posts: 27

Original Poster
Rep: Reputation: 15
Thumbs up ahhhhhh

Yep it was the resolv.conf file, didnt have any dns info in it at all, added my isp's dns info and works great,

cheers for all the help



For a laugh
http://www.ubergeek.tv/switchlinux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Sound Problems xmms problems.... devinWhalen Mandriva 6 04-16-2004 05:05 PM
internet problems with mandrake 10, eth problems rApT0r Linux - Newbie 10 04-11-2004 07:44 PM
Mandrake 9.1 Install problems (Graphical problems) sw4eternity Linux - Newbie 5 11-01-2003 09:43 PM
Mandrake 9.0 Installation Problems: X-Server, GUI Problems? chromelocust Linux - Software 4 03-21-2003 02:59 AM
Some problems with Mandrake sloptaco Linux - Distributions 2 08-15-2001 06:30 PM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration