LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-05-2003, 07:09 PM   #1
ShadowStorm
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 7

Rep: Reputation: 0
Mandrake problem


i finally have Mandrake 9.1 installed on my system.. it's the only operating system on my computer. When i boot mandrake from my floppy it goes into console mode and asks me to login. but i don't want to go into console mode, i want the graphix mode, so i hit ctrl+alt+F7. after that the screen goes black and nothing happens.. why?

 
Old 10-05-2003, 07:22 PM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Dunno,

but I'd say you'd be better off doing a complete re-install for the moment - should only take about 30 to 40 minutes.

When I first installed 9.1, I read a review somewhere that basically said leave everything to default's except the package selection thing, and select all the stuff down the left hand column plus kde and gnome and leave the rest blank - if you need it, you can install it later.

And when I installed debian, my system wouldn't even "start X" because of a graphics card snag i had to manually install the nvidia driver (that is pre compiled with my mandrake boxed set, but not even included with debian as it's "commercial/proprietary") - so you're not using some mega new graphics card are you ???

regards

John
 
Old 10-05-2003, 07:26 PM   #3
ShadowStorm
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
my grpahix card is not mega new,, i can tell you that... it's a ATI Radeon 7500 ... (i think).. and i just installed Mandrake like 4h ago so i couldn't have ruined anything..
 
Old 10-05-2003, 07:50 PM   #4
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
If you have net access then you should check out the "linux driver" for your graphics card. If you see stuff like this

usr/X11R6/lib/X11/xinit/xserverc: /usr/bin/X11/X: no such file or directory
/usr/X11R6/lib/X11/xinit/xserverc: exec /usr/bin/X11/X: no such file or directory

xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 111): server error

at the end of the boot dialogue, then it's a good bet that it isn't starting "X" which is (I believe) an indicator of graphics card driver problems.

Or better still, if you've got net access, download knoppix and burn the disc, and boot from that - then at least if you can run knoppix from the disc, you should be able to get net access - don't forget about looking into "winmodems", as they can be a hinderance.

If you can run knoppix, and get net access, then you can alternatively install it to the hard drive, in a "mandrake sort of way", the only difference is visually, and that you have a debian package manager system instead of an rpm based system.

regards

John
 
Old 10-05-2003, 07:58 PM   #5
ShadowStorm
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Personally i don't think it's a Graphic card problem at all.

I turn on the computer and put in the floppy then
LILO comes up and i select "linux" then
the next screen comes up and starts doing a lot of writing (lol)then when it's done it come out into console mode and asks me to login.. but i want graphic mode so i hit ctrl+alt+F7... after i hit those keys the screen goes black and nothing happens

i don't get any errors whatsoever so i more sure than not that it's not a graphics card error.
 
Old 10-06-2003, 07:09 AM   #6
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
I know that this is a little "off subject" but I'd still do a re-install (if you can't work out how to change it that is), because recently when doing a hdd install of knoppix, I followed the instructions and made the boot floppy, whenever I tried to get it to fire up from the hard disc, it would tell me that it was starting kdm etc, but would just drop my straight into the command line system input - something that I know little or nothing about.

I have since found that it was down to not having the vmlinuz and the initrd.gz (which is called initrd.img, I think under mandrake) in the correct location. Once I had the files or links to the files in the correct place, it booted into knoppix with no problems. The floppy would be great for recovering the system though.

You could also try booting the system with disc 1 of mandrake, and following the F1 options to see if that gives you any clues to starting the system with the gui. There's also a possiblity that you may need to check out the xf86config thing to get it to start with the gui - sorry, you'd have to surf to find out more about that, I've only had to try it once, and with the amount of system related questions it asked, I was just doing "hit or miss" answers.

Because it does sound like you need to change the default start up. My attempts at debian have taught me this, because that wanted to start XDM, and I wanted KDM (familiarity, I suppose). Or the other suggestion is to check the "run level" start, I think you'll find that command line start up is run level 3 and graphic interface is run level 5.

Sorry I can't be more specific - this is mainly stuff that I have read about or seen in passing as the start up/boot dialogue zooms up the screen - oh, and if you need to see if there's anything that you need to check on the boot/start up dialogue use screen lock, it took me ages to work that out (my stupidity, I suspect).

Hope this give you some things to try/investigate.

regards

John

Last edited by bigjohn; 10-06-2003 at 07:11 AM.
 
Old 10-06-2003, 12:56 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
first, do
startx
after you log in. ctrl-alt-f7 is not going to help if X hasn't started yet.
If all is installed fine and dandy, you will get to the gui. Then you can go to mandrake control center and set it to start X automatically - I think under boot.

If startx fails, it is most certainly a problem with your graphics card. First, login, become root using the command su and then
XFdrake
this is a configuration tool. See if you can find a setting that works. If not, search in this forum - I'm sure there's tons of relevant postings.
 
Old 10-06-2003, 05:33 PM   #8
SugarIsSweeter
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: Mandrake 9.1
Posts: 7

Rep: Reputation: 0
I agree about the re-install. Linux seriously takes a fraction of the time of any other OS I've used to reinstall (I reinstalled OS X on my iBook last night and it too a good 3 hrs - lol, NOT good times...) and its the best way to rid the computer of sketchy errors, and since you suspect that its not the graphics card, I would assume sketchy error and reinstall
 
Old 10-31-2003, 12:10 AM   #9
barry505
LQ Newbie
 
Registered: Oct 2003
Location: Minnesota USA
Distribution: Mandrake 9.2, Windows XP Pro, Mac OS X 10.2
Posts: 6

Rep: Reputation: 0
Just curious, why are you booting from a floppy, when Linux is the only OS on your computer?

Your X-windows screen doesn't come up when you hit CTRL-ALT-F7 because the X-windows server hasn't been started yet.

I'd would recommend you do a re-install also, sounds like you chose quite a few of the wrong options when you installed. For one, install lilo on the MBR of the hard drive. You can also choose to have the system come up in X-windows and even automatically log in a user. (Just like Windoze in dumb mode.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10.1 problem AciDusT Linux - Newbie 1 03-09-2005 05:33 PM
Problem with Soundcard-Worked good with Redhat.Problem with Mandrake invinciblemk Linux - Newbie 1 02-27-2004 06:02 AM
Mandrake 9.1 Problem InFeStEd Linux - Newbie 1 09-02-2003 06:00 PM
Mandrake 9.1 Problem Sharkannon Linux - Software 0 04-19-2003 01:29 PM
Mandrake 8.1 Problem Daniel(0_0) Linux - Newbie 7 01-25-2002 08:22 PM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration