LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-03-2003, 08:53 PM   #1
shortyzms
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Rep: Reputation: 0
Mandrake Linux 9.1 and SoundBlaster Audigy 2 sound card


I just recently installed Mandrake Linux 9.1 on my computer and I am completely new to the system in every way. I've spent a while searching the net for some way to configure the sound card step by step, but I can't find it anywhere. If it helps any, I have a SoundBlaster Audigy 2 sound card. Basically, the problem is that the OS just won't play sound. I tried to go into the control center and mess with some stuff, but whenever I click "Test Sound," no sound comes out. Does anybody know where I can find out what the heck to do about this or possibly have a solution?

 
Old 09-03-2003, 08:58 PM   #2
shortyzms
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Just in case it helps (I got some kinda fragmented advice on this topic from someone who knows little more about linux than I do) for some reason, my user profile doesn't have the permissions to view the /root directory, even though I am the only user on my version of linux. When I installed it, I told it "No password" for the /root directory when it popped up a little dialog box for me. I had the problem with a hanging machine and blinking caps lock and scroll lock lights because I have approx. 1027 MB of RAM.
 
Old 09-04-2003, 10:06 AM   #3
bm@cage
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
Had the same problem with an older version of Soundblaster.
*First of all, did on install your MDK detect your SB? I suppose it's PCI, so it should have autodetected something, and misconfigured it then.
*Then, in the MDK configuration center, go to hardware, then soundcard,
so you can test the sound (with the test sound option). Normally you can see what the driver is and what the best driver should be. There is also an options button where options of your SB can be set in.
In my configuration I had 4 options (eg: hex adres of the joystick, AMP, ..). Putting a 1 in the second and forth box was all it took to get sound. Do a search on the internet with the driver MDK took to better understand these options.

But another good advice for newbies: do a double boot, so leave a piece of windows on your pc. Then you can be sure you have sound by testing it in the windows configuration (as normally you have gotten an install cd with the SB for windows with mixing program, etc.). I remember that a couple of yours ago I did not have sound because a button was pushed in at the back of one of my boxes. As I had no sound in windows too, I new it was not my linux to blame...

Succes
 
Old 09-04-2003, 10:09 AM   #4
bm@cage
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
for shortyzms:
it's not because root has no password that the user can do what root can do.
You must still become root to do that. So just do su (superuser), enter and don't give a password.
And BTW, I have 64MB ram and 166 Mhz, and MDK 9.1 runs just fine.
Ciao
 
Old 09-04-2003, 10:23 AM   #5
Moses420ca
Member
 
Registered: Jul 2003
Distribution: Ubuntu
Posts: 142

Rep: Reputation: 15
for some weird reason in mandrake 9.1, the main volume is set to mute by default. Find a mixer in your kmenu under multimedia/sound/ and unmute the main volume and turn your sound levels for the main volumes to full and for wave to 80%.
 
Old 09-04-2003, 06:21 PM   #6
shortyzms
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Sorry guys, I don't know what the heck is going on. I looked at the volume control, and it's not muted, so that option's out. I also figured out how to log onto /root (some of you are probably laughing histerically right now) but I can't figure out how to get my machine to play sound. I couldn't find the configuration window that bm@cage was talking about. Can anyone give me specific directions on how to get there? Btw, I think that the install detected my soundcard in case that helps because it appears under...

Mandrake Control Center > Hardware > "HardDrake helps you list and set up your hardware"

Thanks for the patience...

 
Old 09-05-2003, 04:33 AM   #7
bm@cage
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
Mandrake Control Center > Hardware > "HardDrake helps you list and set up your hardware" > Soundcard
You click on the driver, on the right you see the details with 2 buttons under it:
*configure module
*run config tool

The configure module is where you can change some configure options (if it works, on one of my computers it works, on the other not, but then again, I have sound at both, so I don' t worry)

The config tool can also help. With me it lists:
Your card currently use the ALSA "snd-ens1371" driver (default driver for your card is "es1371")
On the Pc that didn't give sound, I changed the driver in this config tool to another driver and then again to the default driver, so es1371, changed options in the configure module, and sound burst forth from my speakers. Note that you better run draksound from a terminal, like this you can check if all works (eg draksound needs to stop ALSA and restart it, if you do it from the config tool you don't now if that worked, but you'll see error messages in the terminal indicating something went wrong)

No garantee that it'll work on your PC though.
Good luck
 
Old 09-11-2003, 01:29 AM   #8
shortyzms
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I am still having problems...
When I run draksound from the Konsole and try to change the driver, I get this...

Saving mixer settings [ OK ]
Shutting down ALSA sound driver (version 0.9.0rc8): no. (sound is being used by pid 2409 )) [FAILED]
snd-emu10k1: Device or resource busy
ALSA driver (version 0.9.0rc8) is already running.
/lib/modules/2.4.21-0.13mdk/kernel/sound/pci/snd-ens1371.o.gz: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/sound/pci/snd-ens1371.o.gz failed
modprobe: insmod snd-ens1371 failed
insmod'ing module snd-ens1371 failed at /usr/lib/libDrakX/modules.pm line 61.

Any new info you can give me?
 
Old 09-11-2003, 03:48 AM   #9
bm@cage
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
Well, as is clear, I'm not so familiar with alsa and arts,
but I would recommend the following:
*the good news is that ALSA is running, so a soundcard is detected and installed, only you don't have sound
*changing configurations does not work as the driver is busy, which should be the first problem you solve
*see who is pid 2409. Pid is the user number, so probably it will be the number for user root or for yourself. That user has a program running that uses sound. Find out what program that is, and shut it down (start with closing all programs, and make sure in the KDE control center the sound options are switched off, eg systhem bell), then retry using draksound and try what I said in the earlier post.
Note that I also had problems with the module snd-ens1371.

If all goes well, you should see draksound shutting down the ALSA driver, and starting it up again.
After this you test the sound again.

Succes, and it would be helpfull if somebody with good knowledge of the driver/ALSA/arts replied to your post. Perhaps do a search on the driver in google for extra help.
 
Old 09-11-2003, 03:53 AM   #10
bm@cage
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
Hi, I just checked the list of drivers on my PC, and noted there is an ES1371 and a snd-ens1371 driver. So if you change driver, do it to ES1371, try sound, and if it does no work, go back to the snd driver
 
Old 09-11-2003, 04:34 PM   #11
shortyzms
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I tried doing as you said, and accomplished the task, but still no sound. I now get new weird output when I run sounddrake.

[root@localhost sbin]# draksound
Saving mixer settings [ OK ]
rmmod: module emu10k1 is not loaded
Loading mixer settings [ OK ]

This output came when I switched the driver from its default to ens1371. After that, I switched it back to snd-emu10k1 and I get this output...

[root@localhost sbin]# draksound
Saving mixer settings [ OK ]
rmmod: module es1371 is not loaded
ALSA driver (version 0.9.0rc8) is already running.
Loading mixer settings [ OK ]

Also, when I start draksound after this, I get two options in the drop-down "driver" box. One says "audigy ()" and the other says "emu10k1 ()"

One more thing. I feel stupid asking a linux expert this, but are you sure that the emu10k1 driver works with my em10k2 chipset?
 
Old 09-12-2003, 04:43 AM   #12
bm@cage
LQ Newbie
 
Registered: Sep 2003
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
Hmm, see http://opensource.creative.com/
ftp://opensource.creative.com/pub/do...CardsSupported

It looks like your problem is solved in
http://www.linuxlogin.com/linux/emu10k1.php http://www.linuxlogin.com/linux/emu10k2.php
by changing a file /etc/emu10k1.conf and getting audigy to work.
You can change this file by typing 'su', giving root password and then do eg 'kwrite /etc/emu10k1.conf'
At your own risk. If sound keeps not working, post a question to one of the first given web pages, and wait for a real driver comming out.

Success

see also http://www.linuxquestions.org/questi...003/06/3/65798
or just google: http://www.google.com/search?hl=en&l...=Google+Search
 
Old 09-14-2003, 12:25 PM   #13
shortyzms
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I found the .php file in question under /mnt/windows, but not anywhere on my linux partition.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundblaster Audigy 2 NX USB Sound Atmchicago Linux - Hardware 72 09-18-2007 12:35 PM
Soundblaster Audigy 2 NX USB Sound sb300869 Suse/Novell 1 10-27-2005 11:20 AM
Driver For SoundBlaster Audigy 2 Value Sound Card shimano55 Linux - Hardware 2 03-20-2005 09:30 PM
No sound on right channel, Soundblaster Audigy 2 thanquol Linux - Hardware 4 11-30-2004 04:52 PM
Can't get sound from Mandrake 9.1 with SoundBlaster Audigy 2 Sound Card... shortyzms Linux - Newbie 3 12-08-2003 06:36 PM


All times are GMT -5. The time now is 10:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration