LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2005, 05:26 PM   #1
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Rep: Reputation: 15
Question Mandrake doesn't unmount/eject devices


HI.
The problem in a nutshell:
System won't eject/unmount CD, DVD or Remote drives

System detail:
OS/Distro Mandrake 10.1
Box P4, 240MB RAM + 1GB SWAP

A typical scenario:
I'm looking for a previous version of a document/presentation that was saved on a CD. After not finding it on CD #1, I right-click on /mnt/cdrom, in Konqueror, select Eject and instead of the CD being ejected I get an error message that says that it can not eject the CD because the device is busy or the device is not mounted etc. If I then manually eject the CD, Konqueror will not read it (it displays the content of the previous CD) or list some files and folders with garbage for names. The only way I can then read the next CD is to reboot.
I've even tried (as root and su root) to unmount the CD using umount /mnt/cdrom , umount -f /mnt/cdrom , umount -l /mnt/cdrom , umount -f -l /mnt/cdrom with basically the same result.

How do I fix this?

K
 
Old 06-11-2005, 05:42 PM   #2
Bluenoser
Member
 
Registered: Jun 2004
Location: Nova Scotia, Canada
Distribution: Ubuntu 8.04 LTS
Posts: 138

Rep: Reputation: 15
Not sure, but have you tried unmounting the device instead of the mount point?

umount /dev/hdc
 
Old 06-11-2005, 06:42 PM   #3
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Could be many reasons you can't unmount... If Konqueror is in /mnt/cdrom you won't be able to umount. Also there could be a process running that is holding your cd captive... Here is an example of a process holding me from unmounting my cdrom.

# umount -f /mnt/cdrom
umount2: Device or resource busy
umount: /mnt/cdrom: device is busy
umount2: Device or resource busy
umount: /mnt/cdrom: device is busy

Then:

[root@localhost kencaz]# fuser -m /mnt/cdrom
/mnt/cdrom: 4452
[root@localhost kencaz]# kill 4452
[root@localhost kencaz]# umount /mnt/cdrom
success!

also check your fstab to see if you have "supermount" enabled
cat /etc/fstab

If it is you will see "supermount" in the file. If not you can envolk it with:

supermount -i enable

Remember this will edit your fstab file so make a backup first... Then you cd's should be mounted automatically when inserted...

KC
 
Old 06-11-2005, 07:26 PM   #4
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Bluenoser, Yep, I've tried unmounting the device itself.
KenCaz, here's what the relavent part of my fstab:
Code:
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
I'll try the fuser thing. won't supermount interfere with k3b?

Last edited by kriidler; 06-11-2005 at 09:07 PM.
 
Old 06-11-2005, 09:02 PM   #5
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Whoa! KenCaz, that fuser routine gavi me a WHOLE lot of numders, and when I started to kill them, I killed my system and had to reboot! And I've enabled supermount with supermount -i enable and now Konqueror doesn't even read the CDs. It mounts them only when I log in. I do have icons for the drives on my desktop, showing them as mounted drives.

Last edited by kriidler; 06-11-2005 at 09:10 PM.
 
Old 06-11-2005, 09:19 PM   #6
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Hmm, must have killed a critical process!!! My sympathy...

Well, supermount should only mount your CD when you insert it. If there is one in at boot it will mount it. It senses when you have removed a CD or Floppy and unmounts the drive. Konqueror, however, should not have anything to do with mounting. Once a CD is mounted you should be able to navigate to /mnt/cdrom and view contents. If you eject the CD and are still in the /mnt/cdrom folder you may have to use F5 to refresh Konq's file list.

If you dont' like Supermount you can disable like this:

supermount -i disable

KC
 
Old 06-12-2005, 11:27 AM   #7
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Thanks Guys.
It looks like the probels solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VCD does not eject even eject button pressed ic_torres Linux - Software 4 12-01-2005 05:40 PM
switch unmount for eject in gnome? tallest Linux - Software 2 02-08-2005 10:19 PM
Unmount problem with Mandrake 9.2 RaiReg Mandriva 10 08-20-2004 07:46 AM
command 'unmount' not found - how can i unmount??? GloVe Linux - General 1 10-04-2003 06:33 AM
Red Hat 7.1 unmount/eject problem. ugge Linux - General 4 10-22-2001 10:50 AM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration