LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2004, 08:03 AM   #1
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Rep: Reputation: 15
Mandrake 9.2 Installation


HI, I don't have any idea of what I have done with my computer. I have go through the installation of mandrake 9.2 from a dvd on my computer. Now, I have a problem with the after installation process. From all the thread that I have read so far, all of them seem to say,
"After the whole installation process, reboot, and if you select 'linux' on your bootloader, you should have your LInux running properly and so on and so on' , however, this is not the case with me. After going through the bloody installation process, and rebooted, I have this big blank screen waiting for me (I believe it's called a single terminal screen). It prompted for my login and password , so I put in 'root' and my password. After that, I have absolutely no idea of where to go, since it didn't do anything for me.

What should I do? How do I get my (say, KDE or Gnome) up and running? Why does this happpen everytime?

Any help would be very appreaciated
 
Old 03-05-2004, 08:18 AM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
if you have actually got to the level 3 login and it tells you login, and you then put in you root password and you then get something like [suwandy_chandra@thepc root]# or similar, then yes you're into the level 3 login. at the # prompt try typing kdm

then see what happens. if you've just inadvertently missed or mis-selected something at install, then kde should start (the kdm is just kde desktop manager). If it does, then you probably need to change the /etc/inittab - but see if you can get it running first - once you can do that, at least you're up and running - find out about which changes to make (if any later)

regards

John

p.s. when you've got the "boot dialogue" scrolling up the screen, you should see something like "entering run level 3" - level 3 is that same system management that you seem to have arrived at - changing the /etc/inittab is changning it from level 3 to level 5 which is the graphical login.
 
Old 03-05-2004, 08:21 AM   #3
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Original Poster
Rep: Reputation: 15
Hi, I try typing kdm, but it didnt give me anything. It just goes to a new line, with another prompt [root@localhost]#
 
Old 03-05-2004, 08:21 AM   #4
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
To get the graphics going, type 'startx'.
If you want to go straight to the gui on startup, you will need to change the default runlevel to five. You do this by editing the /etc/inittab file. You will need to be root user to do this:
(assuming you have the easy 'pico' text editor installed)

pico /etc/inittab

Look for a line similar to this:

id:5:initdefault:

It may have comments (lines with a '#') around it talking about runlevels. If it has a '3' instead of a five, change it to a five. Save, and reboot. You should end up at a graphical login screen.
 
Old 03-05-2004, 08:26 AM   #5
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Original Poster
Rep: Reputation: 15
Hi, I tried what you said above, that is the kdm, and it basically didnt do anything for me. Then I tried startx as advised, it gives me several lines which says :
xauth: creating new authority file /root/ . Xauthority
----------------same line ------------------------------------
using authority file /root/ .xauthority
writing authority file /root/ .xauthority
using authority file /root/.authority
writing authority file /root/ .xauthority

execve failed for /etc/x11/x (errno 2)

Should I just go with the 'pico /etc/inittab'? I tried doing ls and it only has two folder available, that is drakx/ and tmp/
 
Old 03-05-2004, 08:38 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Did you enter a user name for yourself? If you did, enter that and the password.
After logging in enter startx. You'll get a first-time dialog to select whether you prefer KDE, Gnome or one of the other window managers. (Assuming you installed them)

After that, click on the start icon on the far left of the 'kicker' task bar. A menu will come up. Select System -> Configuration -> Configure your Computer.
After entering your root password, the MCC (Mandrake Control Center) will pop up.
Select the Auto Logon icon. Click on the first box for: Launch the graphical environment ...

An alternate way to do the same thing is to change a single entry in the /etc/inittab file.
You need to be logged in as root to do this.
As the root user type in "vim /etc/inittab"
Cursor down to line 18. Part of the file looks like this:
Code:
# Default runlevel. The runlevels used by Mandrake Linux are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:
You want to change the number 3 to a 5 in the last line I've shown you. To do that, position the cursor over the 3, type the letter 'r' type the number 5.

Now the line should read:
id:5:initdefault:

To save your changes type :wq

This will tell the computer to boot into run level 5.

Last edited by jschiwal; 03-05-2004 at 08:39 AM.
 
Old 03-05-2004, 08:40 AM   #7
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
If startx is not working, then I don't think the runlevel five will work. KDM won't work, no graphics will work. Try switching to runlevel 5 and see:

init 5

When you do a 'ls', you are shown the contents of your home directory, /root . To see other directories, like /etc , try 'ls /etc'. Use 'cd' to switch directories: 'cd /etc'.
Try posting the output these here:

cd /etc/X11
ls -l

^That's an L next to ls.
 
Old 03-05-2004, 09:15 AM   #8
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Original Poster
Rep: Reputation: 15
After reboot, I try looking the etc/inittab again. and the line about the init now says id: 5 : run... etc etc
did you mean I run the command 'init 5' on the system? I did it, and it also looks like it do nothing
the output to the command u asked me to put is :a list of 152 files printed out.

What should I do then to get KDE running? What is wrong with my installation actually? How come none of the above didnt even work?
 
Old 03-05-2004, 09:54 AM   #9
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try 'ls -l x' instead of just 'ls-l'
 
Old 03-05-2004, 09:56 AM   #10
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Original Poster
Rep: Reputation: 15
It said
ls : x : No such file or directory.
 
Old 03-05-2004, 09:57 AM   #11
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try 'ls -l X', and make sure you are in the /etx/X11
 
Old 03-05-2004, 09:59 AM   #12
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Original Poster
Rep: Reputation: 15
Yes, I am in the directory /etc/X11. I have done 'ls -l X' and 'ls -l x' as you suggested, both returned
ls : X : No such file or directory
 
Old 03-05-2004, 10:10 AM   #13
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
How about:
ls -l /usr/bin/X11/X
 
Old 03-05-2004, 10:16 AM   #14
suwandy_chandra
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian & Mandrake
Posts: 44

Original Poster
Rep: Reputation: 15
it has a result which look like (if what u mean is calling the command from etc/X11)
lrwxrwxrwx 1 root root 8 Mar 5:01:14 /usr/bin/X11/X -> Xwrapper*
the 'xwrapper' is highlighted in red
 
Old 03-05-2004, 10:18 AM   #15
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
It sounds like the installation didn't work properly. What options did you choose in the installation?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10.1 Installation hangs at Installation of Bootloader dnl Linux - Software 12 01-08-2005 07:48 AM
Mandrake 9.2 installation program crashes in the final step of the installation iqbala Mandriva 0 12-03-2003 02:59 PM
Mandrake 9.1 installation help wasabi Mandriva 4 09-02-2003 09:22 PM
installation of mandrake 9.0 kouack Linux - Newbie 2 08-27-2003 04:33 PM
Mandrake 9.1 installation teamstatic84 Linux - Distributions 7 07-18-2003 10:18 PM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration