LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-22-2010, 09:17 AM   #1
madde
LQ Newbie
 
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0
Making sure a module is loaded in the kernel upon boot.


Hi, im doing a school assignement and i cant find any info about this anywhere.
How do i make sure that a module is loaded into the kernel upon boot?

Best regards Madde
 
Old 12-22-2010, 09:36 AM   #2
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Depends on which distro you're using. In Debian or Ubuntu, for example, add the module name to /etc/modules.

http://tldp.org/LDP/lkmpg/2.4/html/x49.html
 
Old 12-23-2010, 04:13 PM   #3
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Rep: Reputation: 103Reputation: 103
dmesg | grep "name of module" ---> Modules loaded during boot.

lsmod | grep " name of module" --> Currently loaded.


Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse: prevent Module from being loaded at boot. linusneumann Linux - General 6 05-09-2007 06:08 PM
Truecrypt: Kernel module not loaded Synatic Linux - Software 4 01-21-2006 03:43 PM
the kernel module for tv support could not be loaded ylts SUSE / openSUSE 3 04-15-2005 09:14 AM
Module loaded into kernel at Boot Wolf_Assassin Linux - Software 11 08-11-2004 06:57 PM
kernel: No module symbols loaded - kernel modules not enabled. Qucho Debian 9 05-26-2004 03:50 AM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration