LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2011, 09:10 AM   #16
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Original Poster
Rep: Reputation: 3

Quote:
Originally Posted by TobiSGD View Post
Did you get any error-messages?
Please post the output of
Code:
ls -l /var/www
-rw-r--r-- 1 root web 43 Jan 21 15:19 ajax.php
-rw-r--r-- 1 root web 63 Jan 21 15:19 announce.php
-rw-r--r-- 1 root web 3821 Jan 21 15:19 api.php
-rw-r--r-- 1 root web 77 Jan 21 15:19 artist.php
-rw-r--r-- 1 root web 73 Jan 21 15:19 better.php
-rw-r--r-- 1 root web 0 Jan 21 15:19 block_04097.html
-rw-r--r-- 1 root web 40 Jan 21 15:19 blog.php
-rw-r--r-- 1 root web 73 Jan 21 15:19 bookmarks.php
-rw-r--r-- 1 root web 37 Jan 21 15:19 browse.php
drwxr-xr-x 2 root web 4096 Jan 21 15:19 captcha
-rw-r--r-- 1 root web 40 Jan 21 15:19 captcha.php
-rw-r--r-- 1 root web 4315 Jan 21 15:19 CHANGES.txt
-rw-r--r-- 1 root web 41 Jan 21 15:19 chat.php
-rw-r--r-- 1 root web 41 Jan 21 15:19 cheaters.php
drwxr-xr-x 3 root web 4096 Jan 21 17:30 classes


There are more files, but I think those are enough to figure out whats happening.
 
Old 01-24-2011, 05:22 PM   #17
rmknox
Member
 
Registered: May 2010
Posts: 354

Rep: Reputation: 34
i understand your problem
in fedora i solve it this way

sudo gedit

to use sudo you need to modify its control file -- /etc/sudoers --which you can do with visudo

you need to be super user to run visudo
man visudo tells you how
i gave myself the same premissions as root when i invoke sudo

depending on the version of gedit - to eliminate a bunch of complaints - you need -lang NULL - as I recall - or maybe --lang NULL. My current gedit does not have this prob
 
1 members found this post helpful.
Old 01-24-2011, 05:31 PM   #18
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
All that files only have read permission for the group they belong to. If you want to make changes you have to make them writable for your group.
Code:
chmod -R g+w /var/www
will make all files in /var/www writable for your group.
 
1 members found this post helpful.
Old 01-24-2011, 08:12 PM   #19
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
As per post #18 above
 
Old 01-24-2011, 09:19 PM   #20
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Original Poster
Rep: Reputation: 3
Oh, I see.

Im kind of new to these permission stuff, but I can assure you that in the console I can delete or create anything I want using sudo or su... and apparently they share the same rights right?

I'll test it asap.
 
Old 01-24-2011, 09:54 PM   #21
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
If you have done all exactly the way you were suggested, you shouldn't neet to use su or sudo, because your user belongs to a group that has the permissions to change files in /var/www.
 
Old 01-24-2011, 10:39 PM   #22
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Oh, I see.
Im kind of new to these permission stuff, but I can assure you that in the console I can delete or create anything I want using sudo or su... and apparently they share the same rights right?
I'll test it asap.
Now that your user has super powers you should setup another user for everyday use.
 
Old 01-25-2011, 09:02 AM   #23
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by TobiSGD View Post
If you have done all exactly the way you were suggested, you shouldn't neet to use su or sudo, because your user belongs to a group that has the permissions to change files in /var/www.
Yeah it worked, I didnt say it didnt.
 
Old 01-25-2011, 09:51 AM   #24
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,029

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
this is probably terrible advice but what you can do is hold down ctrl-alt-f2 and log in as root then type in startx -- :1 and it will start a gnome/ kde session for root.
 
Old 01-25-2011, 09:56 AM   #25
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Quote:
Originally Posted by schneidz View Post
this is probably terrible advice but what you can do is hold down ctrl-alt-f2 and log in as root then type in startx -- :1 and it will start a gnome/ kde session for root.
It probably is. Why do you give it then?
It seems the problem has already been resolved anyway.
 
Old 01-25-2011, 10:12 AM   #26
LittlePenguin
Member
 
Registered: Jan 2011
Posts: 52

Original Poster
Rep: Reputation: 3
Yeah it worked, and now I know how groups work, thx Tobis.
 
Old 08-21-2011, 05:47 PM   #27
grizlbr
LQ Newbie
 
Registered: Sep 2010
Posts: 26

Rep: Reputation: 0
Root logon squeeze

Quote:
Originally Posted by LittlePenguin View Post
You dont get it...

If I use su or sudo, Im making my TERMINAL user a root user, but my GUI user (the one that clicks everything :P ) is still having restrictions.
I had a stroke: do 1 thing at a time period! How do I put "root" as other logon? If I need to remove linux I use DISKPART I do not need to determine what to enter to start a program in root terminal as root I need to do it the way I know. I will not ask for help putting DOS7.1 on my first partition to use Norton diskedit to remove grub from my hidden 63 sectors to install a program I can use.
So how do I accomplish this in squeeze. I can not locate the instructions that worked before Vista ate my hard drive and had to start with a blanked hard drive. My last action was to copy my dos and ntfs partitions to another hard drive before squeeze refused to install. Now that I have flamed: I recall that my install was allow root. So if some one can recall the passwd -l command to enable root logon I would greatly appreciate it.
 
Old 08-21-2011, 06:16 PM   #28
grizlbr
LQ Newbie
 
Registered: Sep 2010
Posts: 26

Rep: Reputation: 0
Exclamation Enable root logon

You dont get it... Squeeze install: allow root logon. Just reset root passwd: authenication failure.

If I use su or sudo, Im making my TERMINAL user a root user, but my GUI user (the one that clicks everything :P ) is still having restrictions.
So if the information is too dangerous for the general population: just email me @yahoo. I assume full responsibility for the use on my computer. I have done this before and saved the directions BUT Vista SP2 eats my harddrive, back at 1.
 
Old 08-21-2011, 06:54 PM   #29
grizlbr
LQ Newbie
 
Registered: Sep 2010
Posts: 26

Rep: Reputation: 0
Exclamation

Debian log in screen, go to Actions-->Configure the Login Manager and click OK. How do I get to this point in squeeze?


Quote:
Originally Posted by frankbell View Post
You should not give your user logon root privileges, but you can enable a root logon to the GUI.

This works on Lenny. I suspect that it will work on Sid and Squeeze also, though I haven't used them.

On the>>> Debian log in screen, go to Actions-->Configure the Login Manager and click OK.

Debian will ask for the root password. Enter it.

When the dialog box appears, click the "Security" tab, then select "Allow local administrator logon."

Editorial:

Ubuntu has convinced a lot of folks that logging in as root is inherently a bad thing.

It's not.

Logging in as root and then doing stupid stuff is inherently a bad thing. Stupid stuff=bad thing.

Root can find the GUI more convenient than the command line, just as user does.
 
Old 08-22-2011, 03:00 AM   #30
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 866

Rep: Reputation: 121Reputation: 121
it's YOUR system
it's YOUR problem if you mess it up running as root
understanding the last point go a head and log in as root
but remember you can destroy the whole system and every thing on your disk as root with just one command
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root user is not logging in gui singh_chitranjan Linux - Server 2 12-13-2010 06:43 AM
Couldn't GUI login as any other user than root rugdude SUSE / openSUSE 3 03-19-2007 05:11 AM
no gui for normal/root user.. aaru_ali SUSE / openSUSE 0 10-24-2004 01:37 AM
making a psudo-root user babyphil Linux - General 1 08-17-2004 12:34 PM
Loggin into my GUI as root user MackH Mandriva 6 06-08-2004 12:18 PM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration