LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-27-2004, 03:31 PM   #1
pablowablo
Member
 
Registered: Apr 2004
Posts: 131

Rep: Reputation: 15
making mounted drives accessible to user


How do I make mounted drives accessible to user?

Somehow I can only access my mounted drives when I log in as root... I tried changing my user named pablo to group root by

usermod -G root pablo

but I still couldn't access the mounted drives.

I also tried changing the permission of the drive by

chown -R pablo /mnt/drive

but it said that the operation was not permitted. How do I solve this? thanks very much.
 
Old 07-27-2004, 03:34 PM   #2
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
Edit the /etc/fstab file and next to the drive you wish users to be able to access, add the option 'users' (options are the bit containing 'default,noauto' etc, seperated by commas).
 
Old 07-27-2004, 03:34 PM   #3
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
add the drive to /etc/fstab
make sure the value 'user' is in the options section.
also, umask=0
 
Old 07-27-2004, 03:37 PM   #4
pablowablo
Member
 
Registered: Apr 2004
Posts: 131

Original Poster
Rep: Reputation: 15
great! thanks for the quick replies! it worked out fine
 
Old 07-27-2004, 03:40 PM   #5
devinWhalen
Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Red Hat, openBSD,Mandrake,freeBSD,SunOS
Posts: 168

Rep: Reputation: 30
Hey,

You have to edit the /etc/fstab file.

Here is an example line:
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
to change this so that regular users can edit it I would change it to:
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,user,exec 0 0

I changed the ro to user. This file also controls what is mounted on boot up.

In case I was too breif and you need more help just let me know .

Later
 
Old 07-27-2004, 04:32 PM   #6
pablowablo
Member
 
Registered: Apr 2004
Posts: 131

Original Poster
Rep: Reputation: 15
argh I can't seem to make it work again.

Here is my fstab file

# <device> <mount point> <type> <options> <dump> <pass>
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda3 /boot ext2 defaults,errors=remount-ro 0 2
/dev/hda1 /windows ntfs defaults,ro,gid=windows,umask=002 0 0
/dev/hda4 none swap sw 0 0


/dev/hdb6 /mnt/C auto user,unmask=0,rw,exec 0 0
/dev/hdb1 /mnt/D auto user,unmask=0,rw,exec 0 0


proc /proc proc defaults 0 0
/dev/fd0 /floppy auto defaults,user,noauto 0 0
usbfs /proc/bus/usb usbfs rw,devmode=0660,devgid=432 0 0
/dev/hdd /cdrom udf,iso9660 defaults,user,noauto,ro 0 0
/dev/scd0 /cdrom1 udf,iso9660 defaults,user,noauto,ro 0 0

/mnt/C and /mnt/D are the directories I want to access

When I open the directory /mnt/C in Nautilis it displays the file for a second but disappears the next. I don't know what's wrong here When I open it in terminal it says that I still don't have permission to access the directory.
 
Old 07-27-2004, 04:37 PM   #7
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
That should say umask, not unmask
 
Old 07-27-2004, 04:42 PM   #8
pablowablo
Member
 
Registered: Apr 2004
Posts: 131

Original Poster
Rep: Reputation: 15
*sigh* stupid me... it works now, thanks!

I can finally sleep
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant access mounted drives when logged in as a user Shantesh Linux - General 1 12-25-2003 08:07 PM
mounted disk not accessible via samba revrev Linux - Networking 1 11-29-2003 02:10 AM
Need help making FTP daemon accessible through firewall Electrode Linux - Networking 1 08-12-2003 05:35 PM
fat mounted drives not accessable as user Cubix Slackware 1 07-11-2003 07:55 PM
User priv's on mounted hard drives harperonline Linux - Networking 3 03-11-2003 05:35 AM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration