LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-03-2005, 03:52 PM   #1
Ab3n
Member
 
Registered: Sep 2004
Location: Colorado, USA
Distribution: CentOS 5
Posts: 144

Rep: Reputation: 15
Making Apache work


Hey guys,

I just installed Fedora core 3 with the intent of setting up my own webserver with apache 2.0.53. I downloaded, installed and even configured part of apache so that I can go to http://localhost and see the apache/fedora test page. My question is how do I get my webserver to catch everything going to my domain? My domain is using a dns that is pointed to my ip address, and I made a virtual host with that address and the same document root as the default server. When I go to that domain it comes up with the apache/fedora test page as it should, but when I try it on another computer I get "connection was refused". How do I configure apache?
 
Old 04-03-2005, 04:25 PM   #2
RobertP
Member
 
Registered: Jan 2004
Location: Manitoba, Canada
Distribution: Debian
Posts: 451

Rep: Reputation: 32
Do you have an Allow from all directive in httpd.conf?

It may not be the httpd configuration but firewall/port permissions. As root, try
iptables -L to see what your firewall settings are.
cat /etc/hosts.allow
cat /etc/hosts.deny may be set to block outsiders.
From another PC, try
nmap ipaddress_of_server

When httpd started, did you get a message "Listening on port 80"?
 
Old 04-03-2005, 04:35 PM   #3
Ab3n
Member
 
Registered: Sep 2004
Location: Colorado, USA
Distribution: CentOS 5
Posts: 144

Original Poster
Rep: Reputation: 15
Thanks for the reply,
There is nothing stored in the hosts.allow or .deny files and i believe that my httpd is set to port 80. Also the only other computers I have access to are windows, so the nmap didnt work and fedora didn't recognize the iptables command.

P.S. (I'm using webmin for configuration, but dont mind using the terminal.)
 
Old 04-03-2005, 05:41 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,060

Rep: Reputation: 295Reputation: 295Reputation: 295
If you're just going to be serving up one domain, you don't need a vhost and is probably what's causing you trouble. I'd just use your standard document root and set the ServerName parameter accordingly. If that doesn't work, make sure that the server is running (using netstat to see if anything is listening on port 80).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making wireless work piva.francesco Ubuntu 3 10-02-2005 03:34 PM
making it work Cap'n Skyler Linux - Newbie 8 11-16-2004 02:07 AM
making FTP work explorer Fedora 9 08-12-2004 10:24 AM
making telnet work explorer Fedora 2 05-02-2004 02:56 PM
making something.something.com in apache and bind kunteper Linux - Software 0 02-24-2004 12:30 AM


All times are GMT -5. The time now is 08:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration