LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2003, 05:44 AM   #1
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 895

Rep: Reputation: 30
Make Modules_install unresolved symbols


I don't know if I will ever get leave this newbies area... I wonder if I will be a newbie forever!
Anyway.

After recently compliling the kernel when I did make modules install near the end it gave a few errors

Unresolved symbols in lib/modules/2.3.22/kernel/drivers/i2c/scx200_i2c.o
depmod scx200_gpio_configure
depmod scx200_gpio_base
depmod scx200_gpio_shadow

I thought hmmm

Then after installing drivers for my linmodem I got the same error.

Is this because missed out compiling somthing that this scx200_i2c.o driver? If it is could someone give me a hint as to what I might need to put back/make as a module in the kernel?

Thanks

Adam
 
Old 11-14-2003, 07:37 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Are you doing this in Slackware??
according to the Slackware Essentials Book,
you do not have to --make modules install!!--
goto slackware.com and read up on this, it will show you
the proper Slackware Way to configure the kernel..........
 
Old 11-15-2003, 12:28 PM   #3
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 895

Original Poster
Rep: Reputation: 30
Thanks Iīm going to go have a bit of a read up

I have been following the Compiling guide for newbies that I got of here ages ago and it seems to work fine... only I donīt know EXACTLY what I do and donīt need in the Kernal... so although the way I am doing the compilation I donīt think is directly realated to my current problem.... I am going to take your advice and go have a read on the slackware site.

Thanks!

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unresolved symbols? CletusJones Debian 3 08-16-2005 02:45 PM
Unresolved symbols dimi Linux - Laptop and Netbook 6 12-14-2003 08:00 PM
Unresolved symbols dimi Linux - General 3 12-08-2003 04:34 PM
***Unresolved Symbols*** red8user Linux - Software 0 09-11-2003 06:37 PM
unresolved symbols acid_kewpie Linux - General 7 04-19-2002 06:30 PM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration