LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-02-2006, 02:58 AM   #1
dragunu
Member
 
Registered: Apr 2006
Distribution: Fedora Core 3
Posts: 47

Rep: Reputation: 15
make install problem on vsftpd


when i do make install its giving me this :

Code:
if [ -x /usr/local/sbin ]; then \
        install -m 755 vsftpd /usr/local/sbin/vsftpd; \
else \
        install -m 755 vsftpd /usr/sbin/vsftpd; fi
if [ -x /usr/local/man ]; then \
        install -m 644 vsftpd.8 /usr/local/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/local/man/man5/vsftpd.conf.5; \
elif [ -x /usr/share/man ]; then \
        install -m 644 vsftpd.8 /usr/share/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/share/man/man5/vsftpd.conf.5; \
else \
        install -m 644 vsftpd.8 /usr/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/man/man5/vsftpd.conf.5; fi
if [ -x /etc/xinetd.d ]; then \
        install -m 644 xinetd.d/vsftpd /etc/xinetd.d/vsftpd; fi
i have the gcc installed and it still giving me this problem. im using fc 3

thanks
 
Old 05-02-2006, 03:39 AM   #2
Amuro-Ray2020
Member
 
Registered: Aug 2004
Location: Arizona
Distribution: Linux Mint
Posts: 81

Rep: Reputation: 15
That doesn't look like it's giving you an error. You see that sort of thing during many compiles. Is it giving you any other information?
 
Old 05-02-2006, 03:42 AM   #3
zulfilee
Member
 
Registered: Apr 2004
Location: India
Distribution: Redhat,Fedora
Posts: 430

Rep: Reputation: 39
Where did it show any problem ?

It says that it has installed vsftp in /usr/local/sbin/

Check the directory and see if vsftpd has got installed.

To enable vsftpd use "ntsysv" and enable vsftpd.
 
Old 05-02-2006, 03:51 AM   #4
dragunu
Member
 
Registered: Apr 2006
Distribution: Fedora Core 3
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Amuro-Ray2020
That doesn't look like it's giving you an error. You see that sort of thing during many compiles. Is it giving you any other information?
thats the only info its giving me

Quote:
Originally Posted by zulfilee
To enable vsftpd use "ntsysv" and enable vsftpd.
i did not understand exactly what do u mean by that command.

thanks a lot for ur help guys. rly appreciated
 
Old 05-02-2006, 03:58 AM   #5
zulfilee
Member
 
Registered: Apr 2004
Location: India
Distribution: Redhat,Fedora
Posts: 430

Rep: Reputation: 39
Cool
Then that is an info not error.

And if you want to see if vsftpd has got installed or not do the following

cd /usr/local/sbin/
ls vsftpd

If it shows vsftpd then it is installed.

Ok if vsftpd is installed you have to enable it with some command right

For that login as root
type

ntsysv

This will show u a menu where you can select 'vsftpd' and enable it.
 
Old 05-02-2006, 04:16 AM   #6
dragunu
Member
 
Registered: Apr 2006
Distribution: Fedora Core 3
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by zulfilee
Cool
Then that is an info not error.

And if you want to see if vsftpd has got installed or not do the following

cd /usr/local/sbin/
ls vsftpd

If it shows vsftpd then it is installed.

Ok if vsftpd is installed you have to enable it with some command right

For that login as root
type

ntsysv

This will show u a menu where you can select 'vsftpd' and enable it.
ok i shall try when i am at home cause at the moment im at wrk:P

thanks a lot!
 
Old 05-02-2006, 04:27 AM   #7
dudulz
Member
 
Registered: Feb 2005
Location: Australia
Distribution: [Redhat] [Slackware] [SuSe] [FreeBSD]
Posts: 81

Rep: Reputation: 15
You should have to enable vsftpd in /etx/xinetd.conf.
 
Old 05-02-2006, 04:31 AM   #8
dragunu
Member
 
Registered: Apr 2006
Distribution: Fedora Core 3
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dudulz
You should have to enable vsftpd in /etx/xinetd.conf.
how do i enable it in the config?

and now when im running /usr/local/sbin/vsftpd its giving me

500 OOPS: vsftpd: not configured for standalone, must be started from inetd

i have googled the problem a bit but everyone seems to give a solution that i being a noob cnt understand hehe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
make install problem with vsftpd dragunu Linux - Software 1 05-02-2006 10:50 AM
make install errors in vsftpd swatward Linux - Software 4 09-20-2005 10:47 PM
vsftpd install problem rajesh_b Linux - Software 5 11-12-2004 12:08 PM
how to make links in vsftpd? pablovschby Linux - Networking 4 11-09-2004 09:00 PM
Problem with Configure, Make, Make Install n8tgc Linux - Newbie 2 07-13-2004 04:16 PM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration