LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2010, 08:16 AM   #1
yolinux
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Rep: Reputation: 0
make eth0 active


Dear all , I've installed Eagle Server in a Cisco lab but R1-ISP router can not see the server because of eth0 is inactive.I'm new in Linux OS.So, how can I make eth0 to be active?
best regards
 
Old 01-18-2010, 08:20 AM   #2
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,031

Rep: Reputation: 63
Quote:
Originally Posted by yolinux View Post
Dear all , I've installed Eagle Server in a Cisco lab but R1-ISP router can not see the server because of eth0 is inactive.I'm new in Linux OS.So, how can I make eth0 to be active?
best regards
Is it ?
Code:
ifconfig eth0 up
 
Old 01-18-2010, 08:33 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,542
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Welcome to LQ!

You could use the 'ifconfig -a' from the cli to see if the device is there, even if down. You could then use the 'ifconfig eth0 up' if the device was shown in the previous command. If you don't have a recognized device the issue of the command won't produce results.

If the 'eth0' device is not recognized you could use the commands 'dmesg |grep -i eth';

Code:
example;
# dmesg |grep -i eth0
eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:19:b9:51:81:1a
To see if the system even recognized the device. If not then you will need to find out which device is available on your system with a 'lspci -vv';

Code:
example;
~# lspci -vv |grep -i ethernet
08:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
Once you have identified the device then you would need to be sure that your kernel supports the device. If you are lucky then the driver is available for your use. You could then use the 'modprobe device_driver' to load the driver module. Once you issue the 'modprobe' command for the device, any other necessary modules that associate with the driver will be loaded. You could see the modules with the 'lsmod' command.

You can 'man command' to get a better understanding of the above commands.

Just a few links to aid you;

Linux Documentation Project
Rute Tutorial & Exposition
Linux Command Guide
Utimate Linux Newbie Guide
LinuxSelfHelp
Getting Started with Linux
Advanced Bash-Scripting Guide
Linux Home Networking


The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 01-20-2010, 11:30 AM   #4
yolinux
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks a lot , Gary. My case was the worst . The kernel doesn't support the NIC so I needed to install the driver for Broadcom NIC.thank you for the links,also. They are very useful.
best regards ,
Yolita
 
Old 01-20-2010, 11:34 AM   #5
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,031

Rep: Reputation: 63
Mark the thread as "[SOLVED]" if it's solved.This option is under the "Thread Tools" above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
test to see if eth0 is active DragonM15 Linux - Networking 2 07-09-2008 05:00 PM
Eth0 is not active after boot toes Linux - Wireless Networking 3 07-23-2006 05:34 PM
Cannot ping self ??? eth0 not active ??? Wynand1 Linux - Networking 2 06-29-2006 01:11 AM
interface eth0 is not (yet?) active jorcas SUSE / openSUSE 1 11-22-2004 07:53 PM
eth0 not active on startup rocket84 Linux - Networking 6 07-21-2003 02:09 AM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration