LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Make doesn't work in Fedora (http://www.linuxquestions.org/questions/linux-newbie-8/make-doesnt-work-in-fedora-745525/)

Jani64 08-06-2009 04:59 AM

Make doesn't work in Fedora
 
Hello!

I only know the basics of Linux really, and now I'm trying to install the driver for my IWL3945 wireless card. And I tried following a tutorial that said I had to do this:

% tar xzvf ieee80211-1.1.14.tgz
% cd ieee80211-1.1.14
% make
# make install <--- You may need to be root
% cd ..

And now when I tried to use the make command, I get this error:
Code:

[root@subcane ieee80211-1.1.14]# make
Checking in /lib/modules/2.6.29.4-167.fc11.i686.PAE for ieee80211 components...
find: `/lib/modules/2.6.29.4-167.fc11.i686.PAE/build/': No such file or directory
egrep: /lib/modules/2.6.29.4-167.fc11.i686.PAE/build//.config: No such file or directory
egrep: /lib/modules/2.6.29.4-167.fc11.i686.PAE/build//include/linux/autoconf.h: No such file or directory
find: `/lib/modules/2.6.29.4-167.fc11.i686.PAE/build/': No such file or directory
make -C /lib/modules/2.6.29.4-167.fc11.i686.PAE/build M=/tmp/ieee80211-1.1.14 modules
make: *** /lib/modules/2.6.29.4-167.fc11.i686.PAE/build: No such file or directory.  Stop.
make: *** [modules] Error 2
[root@subcane ieee80211-1.1.14]#

This was also the case when I had Fedora 9 and 10 on the same system. Even with other packages. I tried installing gcc but I do not know if I even need it for the make command.

Thanks in advance!

Nylex 08-06-2009 05:04 AM

It looks like you need to install the kernel source (and probably kernel headers) package for Fedora. You also don't need to run "make" as root, just "make install".

Jani64 08-06-2009 05:09 AM

Quote:

Originally Posted by Nylex (Post 3633368)
It looks like you need to install the kernel source (and probably kernel headers) package for Fedora. You also don't need to run "make" as root, just "make install".

How would I go about installing the kernel source? I tried googling it and it said yum install kernel-sourcecode works, but it didn't work on this end.

jf.argentino 08-06-2009 06:07 AM

try "yum install kernel-devel" and "yum install kernel-headers"

Jani64 08-06-2009 06:27 AM

Quote:

Originally Posted by jf.argentino (Post 3633418)
try "yum install kernel-devel" and "yum install kernel-headers"

Well it installed, but make still won't work:

Code:

[root@subcane ieee80211-1.1.14]# yum install kernel-devel
Loaded plugins: refresh-packagekit
Setting up Install Process

Resolving Dependencies
--> Running transaction check
---> Package kernel-devel.i586 0:2.6.29.6-217.2.3.fc11 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================
 Package              Arch          Version                          Repository        Size
==============================================================================================
Installing:
 kernel-devel          i586          2.6.29.6-217.2.3.fc11            updates          6.2 M

Transaction Summary
==============================================================================================
Install      1 Package(s)
Update      0 Package(s)
Remove      0 Package(s)

Total download size: 6.2 M
Is this ok [y/N]: y
Downloading Packages:
kernel-devel-2.6.29.6-217.2.3.fc11.i586.rpm                            | 6.2 MB    02:30
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing    : kernel-devel                                                          1/1

Installed:
  kernel-devel.i586 0:2.6.29.6-217.2.3.fc11

Complete!

Code:

[root@subcane ieee80211-1.1.14]# yum install kernel-headers
Loaded plugins: refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 22846.
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  73 M RSS ( 84 MB VSZ)
    Started: Thu Aug  6 13:25:46 2009 - 00:10 ago
    State  : Sleeping, pid: 22846
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  73 M RSS ( 84 MB VSZ)
    Started: Thu Aug  6 13:25:46 2009 - 00:12 ago
    State  : Sleeping, pid: 22846
Setting up Install Process
Package kernel-headers-2.6.29.6-217.2.3.fc11.i586 already installed and latest version
Nothing to do

Code:

[root@subcane ieee80211-1.1.14]# make
Checking in /lib/modules/2.6.29.4-167.fc11.i686.PAE for ieee80211 components...
find: `/lib/modules/2.6.29.4-167.fc11.i686.PAE/build/': No such file or directory
egrep: /lib/modules/2.6.29.4-167.fc11.i686.PAE/build//.config: No such file or directory
egrep: /lib/modules/2.6.29.4-167.fc11.i686.PAE/build//include/linux/autoconf.h: No such file or directory
find: `/lib/modules/2.6.29.4-167.fc11.i686.PAE/build/': No such file or directory
make -C /lib/modules/2.6.29.4-167.fc11.i686.PAE/build M=/tmp/ieee80211-1.1.14 modules
make: *** /lib/modules/2.6.29.4-167.fc11.i686.PAE/build: No such file or directory.  Stop.
make: *** [modules] Error 2
[root@subcane ieee80211-1.1.14]#


jf.argentino 08-06-2009 06:32 AM

You haven't installed the good version of kernel-devel:
Quote:

kernel-devel-2.6.29.6-217.2.3.fc11.i586.rpm
but you're running
Quote:

2.6.29.4-167.fc11.i686.PAE
Try
Code:

yum install kernel-devel-2.6.29.6-217.2.3.fc11.i686.PAE
, if it doesn(t work install yumex, a yum GUI, search for "kernel-devel" with it and install the good one.

Jani64 08-06-2009 06:47 AM

Quote:

Originally Posted by jf.argentino (Post 3633440)
You haven't installed the good version of kernel-devel:
but you're running
Try
Code:

yum install kernel-devel-2.6.29.6-217.2.3.fc11.i686.PAE
, if it doesn(t work install yumex, a yum GUI, search for "kernel-devel" with it and install the good one.

I can't find anything with i686 in it, only i586.

Code:

[root@subcane ieee80211-1.1.14]# yum install kernel-devel-2.6.29.6-*
Loaded plugins: refresh-packagekit
Setting up Install Process
Package kernel-devel-2.6.29.6-217.2.3.fc11.i586 already installed and latest version
Nothing to do

I'll try the GUI thing later though, I don't have access to the physical computer for a while.

jf.argentino 08-06-2009 07:25 AM

If you're accessing the linux box through ssh, add -X option to enabling remote graphical session, be sure that server side;, in the sshd_config file (somewhere under /etc or /etc/ssh), the line
Code:

X11Forwarding yes
appears.
Another solution is to reboot the linux box with the 2.6.29.6-217.2.3.fc11.i686.PAE kernel, just edit "/boot/grub/menu.lst" file and change the "default=" to the proper kernel (first one is 0)


All times are GMT -5. The time now is 02:46 AM.