LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-21-2004, 07:46 AM   #1
Veivann
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 16

Rep: Reputation: 0
make command for driver produces error and blames stdio.h!


Hi!

One more question before I get this modem to work...

I now have my kernel-include files thanks to acid_kewpie and I cd to the directory of the driver and write make. This is supposed to be error-free but here's the error I managed to come accross:

gcc -Wall -O3 -fomit-frame-pointer -D__KERNEL__ -DMODULE -DEXPORT_SYMTAB -I. -I/
lib/modules/2.4.22-10mdk/build/include -DMODVERSIONS --include /lib/modules/2.4
.22-10mdk/build/include/linux/modversions.h -o kernel-ver.o -c kernel-ver.c
In file included from kernel-ver.c:47:
/usr/include/stdio.h:329:12: invalid suffix "d26aa98" on integer constant
In file included from kernel-ver.c:47:
/usr/include/stdio.h:329: error: syntax error before numeric constant
/usr/include/stdio.h:330: error: `sprintf_R_ver_str' declared as function return ing a function
/usr/include/stdio.h:344:12: invalid suffix "b0008" on integer constant
/usr/include/stdio.h:344: error: syntax error before numeric constant
/usr/include/stdio.h:345: error: `vsprintf_R_ver_str' declared as function retur ning a function
/usr/include/stdio.h:351:12: invalid suffix "da070" on integer constant
/usr/include/stdio.h:351: error: syntax error before numeric constant
/usr/include/stdio.h:353: error: `snprintf_R_ver_str' declared as function retur ning a function
/usr/include/stdio.h:355:12: invalid suffix "a769" on integer constant
/usr/include/stdio.h:355: error: syntax error before numeric constant
/usr/include/stdio.h:357: error: `vsnprintf_R_ver_str' declared as function retu rning a function
/usr/include/stdio.h:401:12: invalid suffix "af" on integer constant
/usr/include/stdio.h:401: error: syntax error before numeric constant
/usr/include/stdio.h:402: error: `sscanf_R_ver_str' declared as function returni ng a function
make: *** [kernel-ver.o] Error 1

Is something wrong with my driver or kernel-ver.c file? Totally unable to understand what can be wrong Hope you can help one more time

Thanks a lot!
 
Old 03-06-2004, 11:55 AM   #2
randyriver10
Member
 
Registered: Sep 2003
Location: Nova Scotia
Distribution: Mandrake
Posts: 122

Rep: Reputation: 15
hate to disappoint you cause I aint got the answer, but someguy on a different post said to try 2.7-10debug...but i cant find it! Im havign the sam e problem as you!
 
Old 03-06-2004, 02:00 PM   #3
Veivann
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 16

Original Poster
Rep: Reputation: 0
You can get it from http://linmodems.technion.ac.il/packages/smartlink/
Many thanks to wmontez

Hope that helps
 
Old 03-07-2004, 05:51 PM   #4
randyriver10
Member
 
Registered: Sep 2003
Location: Nova Scotia
Distribution: Mandrake
Posts: 122

Rep: Reputation: 15
strange...it times out...I tried the site with mozilla, netscape, and IE on all different computers...is their a mirror I could use"?
 
Old 03-11-2004, 01:34 AM   #5
Veivann
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 16

Original Poster
Rep: Reputation: 0
Hmm, not sure.
Why dont you try ftp.smlink.com/linux
Here's the path to it unsupported -> old -> and here's it!!!
Hope it helps
 
Old 03-11-2004, 06:02 PM   #6
randyriver10
Member
 
Registered: Sep 2003
Location: Nova Scotia
Distribution: Mandrake
Posts: 122

Rep: Reputation: 15
lol got it worken but...

after installing modem driver my computer freezes when sound is played! When I was dialing up to the internet I stopped playing music(paused it) to see if it was making sound then I pressed play and it froze (cant move mouse,totally nothing!)! I then restarted then connected to the internet but didn't play music at all and it worked fine... untill I started xmms and played music (complete freeze!) Then I restarted and then did internet stuff disconnected and then played music....and it worked!!!! It freezes when iI use an media player or when I enable sound server

any ideas?
I got a smart link 561 PCI modem
NForce 2 audio codec interface sound card
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GCC 3.2.3 gives error with <stdio.h> on slackware 9.1 Daid Slackware 4 03-01-2009 11:53 PM
error on "make"command; ralink 2500 driver jimbrook Linux - Wireless Networking 2 05-23-2005 11:58 PM
make produces errors glevine Programming 1 05-08-2005 08:33 PM
ALSA driver installation: problem with 'make' command la_crack Linux - Software 5 10-31-2003 02:15 PM
make: cc: command not found make: *** [gzip.o]error 127 zyjk Linux - Newbie 5 02-08-2002 10:58 AM


All times are GMT -5. The time now is 02:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration