LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-26-2004, 02:50 AM   #1
Xodiak
LQ Newbie
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Mandrake 10.1
Posts: 6

Rep: Reputation: 0
make: *** [_modinst_post] Error 143


Greetings, I am using Fedora Core 2 and I need to add some options to the kernel that are not turned on by default right after the initial installation. I configure the kernel options with "make menuconfig" and start the compiling process with "make". After make finishes I start the "make modules_install" but it finishes with the following error:

INSTALL lib/zlib_deflate/zlib_deflate.ko
INSTALL drivers/media/video/zr36016.ko
INSTALL drivers/media/video/zr36050.ko
INSTALL drivers/media/video/zr36060.ko
INSTALL drivers/media/video/zr36067.ko
if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.7-rc3; fi
make: *** [_modinst_post] Error 143

It takes a while for the error message line to appear after the line just before appears. I have tried to follow the instructions of kernel compiliing as much carefully as I could.

Thank you very much!
 
Old 06-26-2004, 10:50 AM   #2
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
Can you please try following:

Go to your /usr/src/linux-2.x
I guess in your case it will be /usr/src/linux-2.6.7-rc3
So change in the directory containing the kernel sources you would like to enable the options.

Clean everything with
make clean
make mrproper

Make a backup of your Makefile.

cp Makefile Makefile.old.bak
At the top you will find an entry like:

VERSION = 2
PATCHLEVEL = 6
SUBLEVEL = 7
EXTRAVERSION =-rc3

Change EXTRAVERSION to
EXTRAVERSION =-rc3custom

Now recompile your kernel after configuring it via make menuconfig (of course also enable the options you need.)
So
make
after that
make modules_install

Is this working ????

Last edited by Vlad-A; 06-26-2004 at 11:03 AM.
 
Old 06-26-2004, 08:19 PM   #3
Xodiak
LQ Newbie
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Mandrake 10.1
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you Vlad-A for being very helpful.

Unfortunately it is not working. I have tried so far to build the kernel from the original Fedora Core 2 distribution sources, linux-2.6.5-1.358 and the linux-2.6.7-rc3 which I downloaded. I have tried your suggestion to change the EXTRAVERSION =-rc3custom. The error is still the same. I have also tried to build with the following make options:
make O=/home/xodiak/build/kernel menuconfig
make O=/home/xodiak/build/kernel
make O=/home/xodiak/build/kernel modules_install
but after the
if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.7-rc3; fi
it still shows:
make: *** [_modinst_post] Error 143

I do not understand the nature of the error so I cannot try something specific to fix it.
Could it be related to the fact that I only have 128 MB of memory? Fedora needs 256MB as minimum.

The only reference to the problem I cound find on search engines is this, but unfortunately an answer is not offered without a cost.

http://www.experts-exchange.com/Oper..._20998803.html

Thank you again!
 
Old 06-26-2004, 11:25 PM   #4
Xodiak
LQ Newbie
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Mandrake 10.1
Posts: 6

Original Poster
Rep: Reputation: 0
As I was searching on howto and faq files on the internet and the specific error message,
make: *** [_modinst_post] Error 143
on search engines, I realised that I could find only one or two references of the same error, which made me believe that it is not a common error and that it must be me doing something wrong.
I thought that the problem might be that I installed Fedora Core 2 with only 128MB of memory.
As an experiment I pressed ctrl-alt-F6 to bring the text console, I logged in as root and went to the kernel source directory and typed:
make O=/home/xodiak/build/kernel modules_install
and in the end the following errors appeared:

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.7-rc3; fi
Out of Memory: Killed process 2756 (rhm-applet-gui)
Out of Memory: Killed process 2748 (nautilus)
Out of Memory: Killed process 5956 (depmod)
make: *** [_modinst_post] Error 143
make: *** [modules_install] Error 2

This also reminded me that previously, as I run the make modules_install on a terminal window, mozilla would close if I had an open html document.

Do these messages mean that I must upgrade my memory? I am buying an additional 256 memory in the next few days and I wish that would fix the error.

>:)
 
Old 06-27-2004, 02:59 AM   #5
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
Why don't you boot into init level 3 (so no GUI) and try again ?
Perhaps this can help you as for now.
 
Old 06-27-2004, 09:11 AM   #6
Xodiak
LQ Newbie
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Mandrake 10.1
Posts: 6

Original Poster
Rep: Reputation: 0
Talking

Yes, this helped me very much and the make modules_install had no errors this time. <:)
Thank you very much, Vlad-A, you are very helpful!

Last edited by Xodiak; 06-27-2004 at 09:13 AM.
 
Old 07-07-2004, 05:57 AM   #7
midimarcus
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Rep: Reputation: 0
Unhappy RE: make: *** [_modinst_post] Error 143

Hi guys!

In my case problem is not the memory, I run FC2 with 512 MB of RAM but I have the same problem as you, except for having no message like "make: *** [_modinst_post] Error 143" but only the first line saying "if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.7leonardo; fi".

I tried to compile kernel from Fedora Core sources and from kernel.org sources; I also tried to compile in more than 1 machine but the result is the same!!

Do you really think the problem is so unusual?

Have you ever thought that the problem could be the configuration in make menuconfig?

Please, help me!

midimarcus
 
Old 07-07-2004, 06:06 AM   #8
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
Midimarcus,

please open a new thread. Your problem is *not* realted to the original posting at all.

I may be able to help you, but please open a new thread!!!

Also include "WHAT" Kernel are you compiling. A Fedora Kernel or an one from kernel.org!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to open 143 port in ipchains? htic22 Linux - Software 5 10-26-2004 10:52 AM
2.6.7: modules: *** [_modinst_post] Error 1 aze Linux - Software 0 08-09-2004 12:04 PM
enabling port 143 jay_gonzales Linux - Software 10 03-01-2004 04:39 AM
port 143. can't telnet, service enabled, no iptables. help? trossachs Linux - Networking 21 02-18-2004 05:48 PM
IMAP port 143 ... and I'm an I-dot onescrewloose13 Linux - General 2 09-19-2003 08:00 AM


All times are GMT -5. The time now is 03:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration