LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-05-2004, 12:22 AM   #1
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Major screen resolution issue


Hello!

I have done a fair amount of research here and and google, and I haven't found a successful solution to my problem. I had Fedora Core 1 running fine a week ago, and formatted and reinstall to correct a kernel upgrade gone awry.

I used to have the screen set to 1024x768 resolution, and that is what I want to get back to. FC for whatever reason won't allow anything bigger than 800x600, which makes it impossible to see most web pages. Fedora does correctly see my video card as an ATI Mach64 3D rage II. It doesn't detect my monitor, but that is irrevalent to screen resolution, afaik.

I have ran the redhat-config-xfree86 command, and that simply brings up the same GUI as doing system settings -> display in Gnome. I am only shown 800x600 and 640x480 resolutions. I have the choice of 256, thousands, or millions of colors.

I tried manually adding "1024x768" into first place in my /etc/X11/XF86Config, and restarted x, but that didn't work either. Even though I made the changes as root, after restarting X it simply added lines below the one I edited, screwing things up. Here is my /etc/X11/XF86Config file in full:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unprobed Monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "ati"
VendorName "Videocard vendor"
BoardName "ATI Mach64 3D RAGE II"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

#####################################################################

As you can see just above, it doubled the [SubSection "Display"], I'd assume because it didn't like my values. When I added the 1024 resolution, the depth was set to 16, and the system changed that to 24, and I see the default depth calls for 16. I just swaped the 2 depth numbers, so the SubSection "Display" with 1024 is now 16, and the one without it is 24. I'll try restarting X again, and see if that corrects it.


Any help that anyone can give will be greatly apprecaited as it always is.

I live on this site it seems!

Peace,
JImBass

After a restart of x, the damn computer switched my values AGAIN! After switching the 16 and the 24 in the 2 SubSection "Display" lines, it switched the default from 16 to 24. I forgot to mention earlier, ctrl-alt + or - switches back and forth between 800x600, and 640x480, but won't get any bigger. Thanks again.

Last edited by JimBass; 06-05-2004 at 12:30 AM.
 
Old 06-05-2004, 02:15 AM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
You've still got the "old 'subsection display'" in your file (immediately after your altered preferences). Comment it out with the '#', or remove it altogether. Likely, the last one is the one accepted, meaning you're set at the two lower resolutions and 16 bits. Personally, I'd toss any resolutions I wasn't planning on using, as well. Just dump the 800x600 and 640x480 parts.
-------
Edit: As root, use nano/ae/pico or similar text editor to alter the file by hand. It's not like a windows registry file, where the slightest typo will send your system to oblivion (though it might feel like it at first). Gedit works if your able to use the system at the lower resolution.

As wonderful as GUI things are, they definitely do have their "oops" moments, no matter their age, maturity, or OS.

Last edited by scott_R; 06-05-2004 at 02:21 AM.
 
Old 06-05-2004, 07:56 AM   #3
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 49
scott_R,

I made the following changes to my /etc/X11/XF86Config:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
# SubSection "Display"
# Depth 24
# Modes "800x600" "640x480"
# EndSubSection
EndSection

Commenting out the offensive lines as you suggested. I logged out of X, and then restarted it. The file still shows up exactly as you see it above, but I'm still in 800x600 resolution! The only difference that seemed to cause was I can no longer do ctrl-alt-+ or - to change screen size.

I run my machine at runlevel 3, so even if I were to set something up that completely crashes X, I can still edit it in text mode. About the only thing I use X for is graphical internet. I don't mind lynx, but internet without the pictures is lame!


So in any case, is there another file that the configs for screen resolution may be pulled from? Obviously it is ignoring my XF87Config file. I'll use the windows solution of actually rebooting the box, and I'll see how that behaves itself afterwards.

Peace,
JimBass

Situation is the same after a reboot - file shows only 1024x768 resolution, but it boots into 800x600, and I can't switch between resolutions with ctrl-alt-(+ or -).

Last edited by JimBass; 06-05-2004 at 08:09 AM.
 
Old 06-05-2004, 12:15 PM   #4
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 46
The problem is you left the DefaultDepth set to 24

Set the DefaultDepth to 16
I had your same card and it's not going to do 24 at 1024x768

Comment out the lines on 24 bit depth like you did above
For the 16 bit depth section only have the one mode
Modes "1024x768"

Last edited by darthtux; 06-05-2004 at 12:16 PM.
 
Old 06-05-2004, 01:48 PM   #5
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 49
I made the changes suggested, here is the important part of the file:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
# SubSection "Display"
# Depth 24
# Modes "800x600" "640x480"
# EndSubSection
EndSection


I still get 800x600 resolution when I startx, and I can't switch it to 1024x768. Any further suggestions?

Thanks Again,
JimBass



Last edited by JimBass; 06-05-2004 at 08:00 PM.
 
Old 06-05-2004, 08:02 PM   #6
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 49
Shameless bump. Sorry for that, I just wanted to stay on page 1.

One further bit of useful info, I have installed vnc on the box, and vnc gives me a 1024x768 screen. I know that is because it is programmed to do so, and it is a virtual desktop, not the real one, which is why it is possible.

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Major Issue...Last Stop Before Format rhb327 Slackware 12 12-20-2004 02:16 PM
MAJOR usb issue PLZ help. Shad.. Linux - Newbie 0 03-19-2004 05:43 PM
Screen scolling problem / resolution issue? - Mdk 9.2 Ragnaar Mandriva 2 02-17-2004 04:02 AM
major redhat boot issue ferretmanus Linux - Newbie 2 01-09-2004 06:01 PM
Can somebody please help me with a major installing issue? DAKPluto Linux - General 6 06-03-2002 01:07 PM


All times are GMT -5. The time now is 05:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration