LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2005, 08:46 PM   #1
kougar
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10 Official
Posts: 8

Rep: Reputation: 0
MADwifi/cryptoAPI in kernel 2.6.13-gentoo-r3


My end goal: get my Atheros-based wifi card working.

To accomplish this goal, it was recommended that I try MADwifi. I downloaded the tarball and extracted it, but upon typing "make," got an error telling me that I needed to enable crypto API.

Since I'm on gentoo, I immediately just typed "emerge cryptoapi"
It connected and downloaded the files, but then gave me the following error message:

# emerge cryptoapi
Calculating dependencies ...done!
>>> emerge (1 of 1) app-crypt/cryptoapi-2.4.7.0 to /
>>> md5 files ;-) cryptoapi-2.4.7.0.ebuild
>>> md5 files ;-) files/digest-cryptoapi-2.4.7.0
>>> md5 src_uri ;-) cryptoapi-2.4.7.0.tar.gz
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 2.6.13-gentoo-r3

!!! ERROR: app-crypt/cryptoapi-2.4.7.0 failed.
!!! Function pkg_setup, Line 21, Exitcode 0
!!! CryptoAPI is only for 2.4 kernels

This is kind of vague, but what should I do in this situation? Do I need to find a way to install cryptoapi anyway to get MADwifi instead, or should I try to find an alternative method for installing the driver?

Thanks for your support.
 
Old 10-19-2005, 06:31 AM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Try enabling Crypto-API in kernel, it's right there with 2.6 kernels.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Madwifi Kernel Modules superdude_876 Linux - Wireless Networking 5 12-07-2005 11:09 AM
need help with kernel source and madwifi linuxcam Linux - Wireless Networking 10 07-06-2005 04:16 PM
regarding kernel-module-madwifi pranith Linux - Software 0 01-28-2005 09:53 PM
madwifi and kernel 2.6.8 ravalox Linux - Wireless Networking 2 08-27-2004 02:41 PM
CryptoApi works in kernel 2.6.0? pqpdc Linux - Software 0 12-20-2003 02:00 PM


All times are GMT -5. The time now is 04:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration