LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2009, 08:35 PM   #1
don_wombat_73
Member
 
Registered: Sep 2005
Posts: 60

Rep: Reputation: 15
LVM startup problem after 9.04 upgrade


Hey All,

I was wondering if you could please help me out. I had a LVM for storage that worked fine under Kubuntu 8.10. After performing an upgrade to Kubuntu 9.04, my LVM init script no longer worked.

I've used the script here for quite some time:
http://www.tldp.org/HOWTO/LVM-HOWTO/...iptdebian.html

Thinking that it might have been something borked with the current install, I backed everything up and did a fresh install of 9.04 and then install lvm2. The script would still not work on reboot. The LVM still exists and works if I manually 'vgscan', 'vgchange -ay' and 'mount' the LVM. The startup script in /etc/init.d/lvm will not function any longer.

I've tried searching for bugs on this topic, but have not been able to find anything.

Thanks for any help or pointers you can give on this topic!
 
Old 05-12-2009, 06:19 AM   #2
Dudydoo
Member
 
Registered: Sep 2003
Location: UK
Distribution: I use 'em all ;-)
Posts: 275

Rep: Reputation: 38
Do you get any errors? Is the dm-mod module getting loaded at boot?
 
Old 05-12-2009, 07:14 AM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,529

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Quote:
Originally Posted by don_wombat_73 View Post
... and did a fresh install of 9.04 and then install lvm2. The script would still not work on reboot.
How did you reinstall LVM ?. If from the repos (apt-get or synaptic), the init scripts show be valid. You shouldn't need that script.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade to fedora 8 how to mount old lvm ? gfem Fedora 1 12-10-2007 12:53 PM
saving a raid+lvm partition on upgrade mort67 Linux - Software 3 10-02-2007 10:03 AM
upgrade fc2 lvm to fc4 bic Fedora 0 10-25-2005 02:39 PM
Activating LVM Volume Groups at startup TomF Linux - Newbie 0 05-05-2004 05:05 PM
LVM upgrade but says I need rawio patch briankb713 Linux - Software 0 03-21-2004 04:46 AM


All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration