LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   LVM needs e2fsck after Upgrade from Kubuntu 8.10 x64 to 9.04 x64 (http://www.linuxquestions.org/questions/linux-newbie-8/lvm-needs-e2fsck-after-upgrade-from-kubuntu-8-10-x64-to-9-04-x64-722467/)

don_wombat_73 04-29-2009 09:01 AM

LVM needs e2fsck after Upgrade from Kubuntu 8.10 x64 to 9.04 x64
 
For the most part, the upgrade went fine. But I'm stuck with manually mounting my LVM every time.

Here is the output of /var/log/fsck/checkfs:

dpich@dpich-desktop:~$ sudo cat /var/log/fsck/checkfs
Log of fsck -C3 -R -A -a
Sun Apr 26 19:10:24 2009

fsck 1.41.4 (27-Jan-2009)
fsck.ext3: No such file or directory while trying to open /dev/Storage/Stuff
/dev/Storage/Stuff:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

fsck died with exit status 8

Sun Apr 26 19:10:24 2009
----------------
dpich@dpich-desktop:~$

bhaslinux 04-29-2009 09:56 AM

is the manual mouting working ?
are you (without any warning/error) able to mount the volume /dev/Storage/Stuff manually ?
when you are able to mount, is the VG Storage already active or do you manually activate it ?

don_wombat_73 04-29-2009 01:00 PM

Yes. It works perfectly if I do:

vgscan
vgchange -ay
mount

When I do those all in order, my lvm becomes active. Manually works like expected.

bhaslinux 04-30-2009 05:13 AM

the problem is somehow the machine is not enabling your LVM volumes during boot.
Based on the distribution, is the lvm service enabled during startup ?
in fedora it is netfs (which does the lvm work and mounts all the LVs)
in debian it is lvm2

make sure these are enabled in your runlevel and at the rcS.d level

don_wombat_73 04-30-2009 12:14 PM

Please help me understand what you are saying. I rechecked my script in which is /etc/init.d/lvm.

dpich@dpich-desktop:/$ cat /etc/init.d/lvm
#!/bin/sh

case "$1" in
start)
/sbin/vgscan
/sbin/vgchange -ay
;;
stop)
/sbin/vgchange -an
;;
restart|force-reload)
;;
esac

exit 0

dpich@dpich-desktop:/$


When I tried to update the service, I got the following:

dpich@dpich-desktop:/$ sudo update-rc.d lvm defaults
update-rc.d: warning: /etc/init.d/lvm missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
System startup links for /etc/init.d/lvm already exist.
dpich@dpich-desktop:/$


Am I missing something basic?

bhaslinux 04-30-2009 04:53 PM

what is the distro you are using ?
based on this the commands may change
in case fedora ... redhat versions you have to use
ntsysv --level S
and enable lvm

in case of debian
manually add lvm at a top runlevel (<20)

don_wombat_73 04-30-2009 05:13 PM

Running into some other problems with the upgrade from 8.10 to 9.04, I decided to scrap my 8.10 system and start fresh with 9.04.

Following this:
http://www.tldp.org/HOWTO/LVM-HOWTO/...iptdebian.html
still gives me a problem loading the lvm. I still have to manually run 'vgscan', 'vgchange -ay', and mount to get the lvm working.

I'm looking for bugs via Google, but nothing has come up. How else can I troubleshoot this?


All times are GMT -5. The time now is 06:45 AM.